Samsung Connect Home/SmartThings WiFi Hub Firmware Release Notes - 0.52.21

Hello, Friend, how did you replace the wifi/hub with the new hub? In my case, it doesn’t allow me to make this substitution.
If you can give me any advice I would appreciate it.

Can you provide more details? Do you see the option to use Hub Replace? If yes, when you click on it, does it fail there or allow you to continue. When did you add the new hub to your account? Did you select Multi Hub when setting up the new hub? The more details you provide are helpful.

Do you have any Z wave devices? The station does not have a Z wave radio, so you can’t move zwave devices to the station.

Also, I am pretty sure that only the primary hub from the Wi-Fi mesh system can be transferred to a new hub. :thinking:

Do you see where in the app to initiate the feature? It’s a bit Byzantine, IMHO, but for the SmartThings WiFi Hub in the ST app one must select their hub as a Device, then tap “Use SmartThings Hub,” and then “Manage SmartThings Hub.” At that point it should be in the three-dots menu in the upper right. (I’m fairly sure this is correct, but I don’t have access any longer, so I’m going by memory and a previous post I made about getting the firmware information. I think that’s the same place where I could select “Replace hub.”)

1 Like

I don’t have any Zwave devices on my network, they are all 100% Zigbee
And the Hub’s are on the same network and in the same house.
I don’t know what’s happening, it must be something that is going unnoticed.

1 Like

Hello, sorry for the delay in responding.
Yes, I can see “replace your hub” in the APP and I can even click on it, but after a brief wait and analysis of the system, it appears that it cannot be replaced.
I’ve already checked all possibilities, drivers, locations, etc… but nothing works.

This sounds like what I experienced for a few days. Unfortunately, I don’t think I did anything to fix it. I contacted support, and their suggestion was to re-install the app, which I did, but that didn’t result in any immediate change.

I do note that at one point the hub started to identify as being “Off” in the app, even though it continued to work. After a day it two it then showed as “On” again, and at that point the hub-replace feature actually worked.

It’s possible that support did something else in the background for me, specifically, based upon my request (and I had enabled access for them to do so), but I wasn’t notified about it if they did.

Ultimately, I’m very happy that this finally worked for me, as being on a newer hub, and one that’s a dedicated smart hub without the extra layer of also being a WiFi router, that I can’t turn off, gives me greater peace of mind.

Hopefully you’ll be able to execute the Hub replace feature soon. If not, I guess I’d recommend contacting support.

1 Like

There is another possibility, but only support would know for sure…

The Replace feature uses a snapshot backup that the original hub creates periodically. I believe this must eventually be stored in the cloud since the replace feature is supposed to work even if the original hub has failed. (Although I haven’t heard of any community members who have reported actually using it in that situation.)

Anyway, maybe a backup hasn’t been created yet? But I’m just guessing, again, official support would be the only ones who could tell at this time, I think.

At least that would explain why some community members have reported that originally the feature was not available to them for a specific hub, but after a few days it was. :man_shrugging:t2:


you may want to try resetting the new hub first and adding it back.

to do a full reset:

  • disconnect it off by removing the power cord
  • insert a pin in the reset slot and hold, plug the power cord back in
  • wait until you see the solid yellow led on the hub and release the pin from the reset slot
  • wait about 1 minute or until the LED should flash red**/** green to indicate it is ready to be setup. You will have 30 minutes to start the setup process.
1 Like

Ah, that’s interesting. I wasn’t aware that others had experienced this, too. Your hypothesis sounds reasonable to me. (And, I hope you’re right regarding the cloud-based backup and the ability to replace a hub subsequent to failure.)


I always thought the backup was kept in the cloud. Interesting, you’ll note that the hub has a public key for the backup in the AWA further supporting the idea that there is a backup that can be decoded.


Possibly, but the idea is that a fresh backup is created for the replace operation if the hub is online so it would seem unnecessary to wait. Of course, being unnecessary doesn’t mean it doesn’t happen.

Presumably that is just the public key used to encrypt the regular backups sent to the cloud.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.