Request: Edge URI Button

Currently I use a URI button DTH to change the Source/Input on my Samsung soundbar using Harmony. Harmony pushes the button and then the Input changes via HTTP request. SmartThings/uributton.groovy at master · ruricu/SmartThings · GitHub

I can’t seem to find anything similar for Edge and can envision many use cases for this. Thanks guys!

Tagging @TAustin

1 Like

My webrequestor driver allows you to send most http requests. You might try using that.

Let me know if you have any questions.


Thanks for the reply. I actually tried using it and didn’t work for me unfortunately. It seems the requests weren’t making it to the soundbar via the driver itself. I need them to be a button/switch as that is how Harmony sees and actuates them. I might be able to accomplish that with your driver as part of a Routine linked to the Harmony Activity. Not sure why the requests aren’t making it to the soundbar. They do work when put in a browser so it functions.

EDIT: Actually I was using the Web Requestor 1.2 driver. Just realized that and used the one you posted and it is working as expected! For some reason most things are showing as “Untitled” and I don’t see where the button would be created. Any guidance on that?

Unfortunately the mobile app is not properly displaying field labels right now for any community-created devices with custom capabilities. I don’t know when this will be fixed!

You could use my vEdge driver to create a virtual button or switch and then create an automation that, when the button is pressed, triggers the specific webrequestor request.



You may also want to look at @lmullineux harmony driver. It allows local control of a hub.

I have it paired with @ygerlovin Virtual Things Edgw Driver, using a momentary button to send commands to harmony for devices. Possibly @TAustin has similar functionality. I am going to take a look at his Lan driver to switch motion notifications for my cameras usin a uri

@TAustin I essentially have this working now, except that Harmony shows “No Connection” with any switches using your driver. Stock Smartthings Virtual Switch is working, and local, but I think that is Groovy so would be going away. Any idea why Harmony wouldn’t be able to see the status of your device?

I’m not familiar with how Harmony knows or sees SmartThings devices. Is there some kind of official integration between the two?

I’m thinking of the way Alexa integration works, and with that, Alexa supports only specific device types for conditions vs actions. But switch is a pretty basic type to support for actions.

Does Harmony recognize ANY Edge- based drivers or does it only work with Groovy devices?

We may need to consult the guy that did the Edge Harmony driver. I just don’t know how they integrate.

@lmullineux. Can you shed some light?

1 Like

My driver works in the st → harmony direction. So st controlling harmony devices. @RJGill84 is asking about the opposite direction (harmony to st) harmony controlling st devices.

I don’t know how that works, but on my driver’s thread their is a conversation right now trying to figure that out.

The suspicion is this is cloud to cloud, but relies on groovy somehow, this is probably why it can’t see edge drivers (although this is not something I noticed myself).


Yes it is an official C2C integration. Harmony supports “Lights” and “Plugs” so perhaps I need to create one of those, rather than a switch, with your driver. I’ll report back.

1 Like

@TAustin I tested it using the virtual light function and still the same result. Harmony shows “No Connection”, although interestingly it is mostly able to turn them on/off, it just doesn’t seem to be able to see the state of the device. The error in Harmony is “Failed to retrieve state of <switch/plug/light name>”.

It’s possible that its cloud service for some reason doesn’t recognize Edge devices. Do you know anyone that has been successful getting Harmony to recognize an Edge device (real or virtual)?

I’m going to try some of the other virtual device drivers and I’ll report back.

It looks like it’s a Groovy SmartApp backing it. And with Logitech putting Harmony on life support, I doubt they would update it to one of the modern integration types. :grimacing:

I believe at one point there was a Groovy smart app but I don’t have any smart apps installed at all currently. IDE shows no smart apps installed and reports the Hub and devices as “Harmony C2C” in devices. Unless it’s running a groovy app that’s just not visible through the SmartApps panel.

I just went through the authorization flow from the Harmony app and it’s definitely still hitting a Groovy SmartApp.

In the IDE, I’m not sure where you were looking, but it won’t show up under ‘My SmartApps’ as those are just the custom ones you’ve installed. If you click ‘My Locations’, then under the ‘Installed SmartApps’ column you can tap the ‘smartapps’ link on the same line as your hub to see all the installed SmartApps.

Logitech Harmony (Connect) shows up in my installed SmartApps list.


1 Like

Yep, you’re correct - it is there as a Groovy smartapp. This doesn’t bode well for us given that Harmony is a deprecated product.