[RELEASE] Remotec ZXT-120 AC IR Controller (2015)

Hi sorry for my newbie question
I just buy the smarthings hub v2
and also today I receive the zxt 120 from ebay
can you tell me step by step how to add it on my app or a link that shows the steps?

I have connect the hub to smartthings app
I have also copy the code and save and publish on api smartthings site for the device handler
and I have do the same for the app that start via change on temp

now how I can add the zxt to the app?

thanks and sorry

Edit I found and pair the zxt
Now I try all the code at remote code at settings and does not working so I try 1 by 1 all the codes from 1 to 550 is any other way? The learning code is exist?

@b16b This thread you just posted in and the Readme file should help you with step by step. It is a tricky device to set up so read carefully and do your homework.

Like any other app, select the configuration and select the zxt-120 you added.

Read the manuals that came with the device, it includes a list of IR codes.

Thanks Ron I fix it the slider on smart app is different than your pdf and also not working for me

Is a way to make something like

If tempreture is lower than 18 open to heat and this only after 18:00

If is more than 24 open to cool only after 18.00 etc?

Yea, Smart Things Changed the slider design. I hate the new version but nothing you can do. I don’t have time to fix the readme every time they make changs :frowning:

Just saying doesn’t work for you doesn’t really help me understand what you need and as I said you need to do some homework to understand how this all works, your reply is so soon after mine I suspect you didn’t try very hard to solve any issue you have.

There are lots of ways to do this. You need to look at the smart apps, routines, modes. Basically you need to learn how to use SmartThings. My Smart App will handle the turn on based on temp and you can use modes to deal with the time. Another option would be to use something like CORE.

Thanks again for your great work and quick reply I will try to find how can make my scenario better…

For tempreture up and down I see only this new slider in black background and the only exit is by X first is not in Celsius and second whatever position I will left it nothing change

FYI, In the past 3 years, I have built the ScheduleTstatZones & ecobeeSetZoneWithSchedule smartapps which allow you to create zones inside your home for more targeted heating/cooling.

Here is the new virtual zone UI:

I’ve recently modified ScheduleTstatZones & ecobeeSetZoneWithSchedule to be able to control more effectively any portable coolers/heaters, split/window units based on My HvacUnit or the Remotec ZXT120 AC DTHs. For example, the smartapps can determine the best fan speed based on the max temp differential allowed for the zone(s).

For more details on My Flair HvacUnit, refer to:

In the ScheduleTstatZones smartapp, you can configure your rooms/zones/schedules. You then associate your zone/room thermostats to your zones and schedule your zones during the day.

In your home, you don’t always want to heat/cool all your rooms. In the evenings or at night for instance, you may want to direct more heat to your bedrooms.

The smartapp lets you choose a master thermostat which controls other slave (zone/room) thermostats in terms of mode and setpoints. The thermostats need to follow the ST standard capabilities.

You can also define enter some delta temp adjustments to make some specific zoned rooms cooler or hotter. You can also use your room’s motion sensor to take into account if the room is occupied or not. The occupied threshold can be defined on a room by room basis for more flexibility.

There are many other features, refer to the ST community wiki for more details:

http://thingsthataresmart.wiki/index.php?title=ScheduleTstatZones

And the following ST community thread:

You can download the code at my store.

www.ecomatiqhomes.com/store

Regards.

Can anyone tell me what lines I must change to covert Fahrenheit slides to Celsius?

EDIT
I find solution
change this line

controlTile(“coolSliderControl”, “device.coolingSetpoint”, “slider”, height: 1, width: 2, inactiveLabel: false, range:"(18…28)") {
state “setCoolingSetpoint”, action:“thermostat.setCoolingSetpoint”, backgroundColor: “#1e9cbb

18…28 was 67…84

do the same for the heat

1 Like

Glad you figure it out. There are comments in the code that tell you which lines to change. Your change will work but I already defined two sets of tiles you just need to switch between them.

The DH is commented to explain this.

Also keep in mind the code looks at your Smart Things setting for C or F so if you mix them it will not work correctly. Only change to Celsius sliders if your ST setting is set to Celsius.

Hi Ron thanks for reply as you see I found the solution but I have something new to ask
As you see with new update of SmartThings app have scenes I found the ZXT-120 but have only option for on and off and goes only at cool when you enable it even if your last time was heat can you add more option than on off… Also I use your smart app based on temp but again you can’t set to open at heat or open at cool

@b16b

The open method is hard coded to call “cool” you can change that hard code to heat if you want. There is no way to know what your last setting was on the AC unit because it doesn’t report both ways. The ZXT-120 talks to the AC unit but the unit doesn’t report back. So if you turn on AC with the DH and then turn on heat with your remote it wouldn’t know your last setting. I could have coded it to remember the last selected mode but I had no need for that so I didn’t write it that way.

You can just change on to call switchModeHeat() instead of switchModeCool(). If you want both then you need a smart app that works with thermostat not just switch.

I am not sure why you say my Smart App doesn’t let you select heat or cool. It definitely does.

Has anyone else struggled to get the device to learn? I was able to add it and pressing the yellow button causes the red LED to flash once. Yet when I try to get it to learn I only get the six flashes. The remote works (it’s a window unit and I plan on dealing with the various challenges there but i can’t start until I get it to learn anything)

I want to learn also how can set the learn mode because my air condition have a button that cold powerful and goes to maximum for some minutes… And I want to have that

I’m trying this unit with power allowance but it doesn’t seem to turn off the unit after the 2 minutes (2 minutes was put for testing only) I guess he doesn’t take heat or cool as an on command?
Screenshot_20171122-233842
Screenshot_20171122-233919

I want this:
Example: if open A/C with ST from my phone from example at heat and 22C and then closed
If set routine to open A/C when I am back to home
Then open A/C at last settings in our example heat 22C

So the last settings of device handler is that possible?

Hello:
I’m a new user of Smarthing.
I got no ST programming skills.
I have installed several A/C units in my apartment.
Some are from LG and some from Samsung.
I got the code list from Remotec.
I’m buying their ZXT-120 AC IR controller.
Could any of you share a simplified step-by-step set of instructions to configure the devices from A to Z?
Thank you very much in advance.
Best.
Antonio

I want to ask if somehow can connect 2x zxt-120 as 1 because i have 2 air condition in my living room…???

A.gennari you must
copy the code of git hub (tap raw)
then go to api smarthings web page log in
go to location select home then
click to device handler then
add new device handler
from code
paste the code
save
and publish for me
go to the app
tap + things
when searching push the button on top of zxt-120
you will found it then open the zxt UI
go to settings
put your code and save
the go at the buttom and push config and refresh

now everythings must work or just use one of the other codes for your aircondition

No but the zxt-120 sends the signal in a 360 radius so perhaps one will work for both. Also the zxt120 has a jack for an IR emitter so you could wire an extra emitter if the units are not close to each other.

I use batteries inside to ZXT-120 and is a point that read the battery as 255% then ZXT-120 does not work can we fix it?
If I charge the batteries and install it again then works fine

Ps. With full charge batteries and new batteries max shows 80%

@b16b

The ZXT-120 doesn’t work in continuous mode when using batteries. It uses flirs mode which will sleep when not actively sending signals. That makes it not work with SmartThings. This is why I recommend in my instructions that you have to use a power adapter and you have to place the device in continuous “always listening” mode and not flirs mode before you pair it with SmartThings. (see page 5-6 in manual)

What you are doing when you replace the batteries is waking up the device and it is working for a brief period while it is awake (same would happen if you pressed the center button). Then it goes to sleep and stops working.

The battery reading is not causing this issue. The issue is cause by the device going into sleep mode.

I don’t know why your battery reading is 255%, mine is 100% but I don’t insert batteries since I plug mine in.

Mine start from 80 with batteries and somewhere between 50 to 35 shows 255 then stuck also I do not have problems for sure work one week before shows 255 and then crash

Thanks for quick reply maybe is not a fix around I will try to plug it all ZXT-120