RELEASE Generic Media Renderer (DLNA Speakers). Cheap Sonos Alternative (Update V2)

dth_speakers
dth_voice
dth_alerts

#970

Thats how it works.


#971

On a samsung tv it switches back


#972

I’m trying to connect to 3 Fabriq speakers. I followed the instructions to install the Connect smartapp, and the Player device type. I installed the player as a “device handler” in the IDE, I did not see a “device type” section (did I miss something?)

From the Smartthings app, pressing “+” to add a new thing does not give me any option to use a smart app. If instead I go to the automation section, I can get to the Mediarenderer (Connect) app, but the discovery process does not find anything. I do have upnp enabled on the router. Did I install something wrong? I saw a similar post earlier in the thread but did not see any resolution for it? Thank you.

Update: I see the 3 speakers on the network and can stream to them from the PC. Also, installed Bubbleupnp on my android and can see/control the speakers from there as well. I tried reinstalling the app/DH, resetting the hub, etc. But smartthings app still does not discover the 3 speakers or Bubbleupnp. Here is the only thing showing in the log…

ed6cbbe8-8459-44cf-a8d3-152f78b51b61 ‎9‎:‎11‎:‎00‎ ‎AM: debug getChildDevices(false), children=0

ed6cbbe8-8459-44cf-a8d3-152f78b51b61 ‎9‎:‎10‎:‎17‎ ‎AM: trace mediaRendererDiscovery() state.subscribe true

ed6cbbe8-8459-44cf-a8d3-152f78b51b61 ‎9‎:‎10‎:‎00‎ ‎AM: debug getChildDevices(false), children=0

Any help would be much appreciated! Thanks,


(Matthew) #973

Deleted. posted this is the wrong forum


(Cesar Vasquez) #974

@ule Please merge this on github https://github.com/SmartThingsUle/DLNA-PLAYER/pull/15


(Jason) #975

@ule need a little assistance. I am using this on a fire tablet, with bubble upnp. I see the player going into play and stop on the tablet, but I am not getting any sound. And when I look in the activity of the player it says zero bytes sent.

Ok, I have music playing, but cannot get TTS to work, what am I doing wrong?


(Satish P) #976

@ule Need assistance on setting up your app with BigTalker2.0. I have installed DLNA Renderer app and installed the DLNA player DTH. Ran the discovery and found my Samsung Plasma TV. It added this as a speaker in my “Things”. I am using this as my talking device in BigTalker app and setup the events. When my door is opened or an event happens I dont listen to the notification on my TV. I have setup the delays as follows

Delay before msg - 5 seconds
Delay between actions - 2 seconds
Avoid Secure delay - off
Refresh frequency - Auto
Use External Text to Speech - off
TTS Key - blank
Music Genre - Smooth Jazz
Multiple Genres instead of Genre - off
Multiple Genres, Wite Exact Like Music Genre List - blank

I see in my activity Feed :
Talking Events Sent playtrackandrestore command to [TV] Samsung Plasma Speaker when an event happens.
Big Talker2 Sent refresh command to [TV] Samsung Plasma speaker.

But I dont hear any sound from my TV.

Any help would be greatly appreciated. I am a newbie and I don’t know how to turn on debug and track. Let me know how can i provide the logs so that you could help figure the issue.

FROM LIVE LOGS

3:56:17 PM: trace BIGTALKER2(P2.0.1) || [PARENT] TALK(Talking Events.motion)|mP| [TV]Samsung Plasma Speaker | cT=null | cS<>playing | Sending playTrackAndRestore() | CVol=18 | SVol=75
3:56:17 PM: trace BIGTALKER2(P2.0.1) || [PARENT] Sending playTrackandRestore() 8
3:56:17 PM: trace BIGTALKER2(P2.0.1) || [PARENT] TALK(Talking Events.motion)|mP| [TV]Samsung Plasma Speaker | (2) Current Status: no_media_present.
3:56:17 PM: trace BIGTALKER2(P2.0.1) || [PARENT] TALK(Talking Events.motion)|mP| [TV]Samsung Plasma Speaker | Volume: 18, Desired Volume: 75
3:56:17 PM: trace BIGTALKER2(P2.0.1) || [PARENT] TALK(Talking Events.motion)|mP| Last poll: 3:55:55 pm
3:56:17 PM: trace BIGTALKER2(P2.0.1) || [PARENT] TALK(Talking Events.motion)|mP| Resume is desired
3:56:17 PM: trace BIGTALKER2(P2.0.1) || [PARENT] TALK(Talking Events.motion)|mP@|75 >> front door bell is now active
3:56:17 PM: debug getMyVoice: settings.parent.speechVoice=Salli(en-us)
3:56:17 PM: debug getMyVoice: deviceVoice=null
3:56:17 PM: info SHM isActiveSensor(motion:active, app: off, location: off) = false, locationId: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
3:56:17 PM: debug motionOrContactHandler(Front Door Bell motion:active)
3:56:17 PM: debug Sending push
3:56:17 PM: debug motion:active, pushAndPhone:null, '{{ triggerEvent.descriptionText }}'
3:56:17 PM: debug Notify got evt physicalgraph.app.EventWrapper@51005b0c
3:56:17 PM: debug [SM] vendorMessage() - Motion Event Received for Front Door Bell.
3:56:17 PM: debug [SM] vendorMessage() - Event Type=new-motion
3:56:17 PM: debug [SM] vendorMessage() - Incoming message from Ring. Processing message.
3:56:17 PM: trace [SM] Executing 'vendorMessage()'
3:56:17 PM: trace [DTH] Exectuting handleMotionEvent()


(Gene Clark) #977

Did you ever get your Yamaha receiver to work? I’m in the market for a new stereo receiver and there’s two things I’d like that would be big selling points with me:

  • ability to add to SmartThings as a thing and slow for control of receiver through SmartThings

  • play SmartThings notifications


(Brian S. Lowrance) #978

No, I gave up and quit trying


(Satish P) #979

@ule did you get a chance to take a look at the log and see whats going on with my setup. I am unable to hear the voice on my TV. I did check with @rayzurbock on the Big Talker2 and he confirmed that the phrases are sent to DLNA renderer from Big Talker. I even enabled the logs and found the mp3 files that are sent from BigTalker app so I believe there is no issue with the delivery of hte message from this app. Something is going wrong with the renderer or the Samsung TV.

Any help would be greatly appreciated. This is the only setup I see DOESNT require any computer or additional service that needs to be running constantly. If this works, it would be great.


(Ule) #980

Hi, I don’t use Big Talker, I suggest you to use MediaRenderer Events to test your speakers.

if you can test your speaker with this app , the you can choose other apps.


#981

@ule

Any thoughts on this? I have deleted/installed the app/ device handler and the speakers numerous times, and the discovery process still never finds anything. This is when accessing the app through the “automation” section of the Android app. I could never find a way to get to it via “+ new thing”. Also still the same messages in the log. Thanks,


(Pizzinini) #982

You need to use the Mediarender Connect app to find them. It can take a minute or two for them to appear after you start searching.


#983

Thanks for the response. I am using the mediarender connect app, but might be missing something basic, as I can’t get to that app through the “+” new device process. Info from my original post…

I’m trying to connect to 3 Fabriq speakers. I followed the instructions to install the Connect smartapp, and the Player device type. I installed the player as a “device handler” in the IDE, I did not see a “device type” section (did I miss something?)

From the Smartthings app, pressing “+” to add a new thing does not give me any option to use a smart app. If instead I go to the automation section, I can get to the Mediarenderer (Connect) app, but the discovery process does not find anything. I do have upnp enabled on the router. Did I install something wrong? I saw a similar post earlier in the thread but did not see any resolution for it? Thank you.

Update: I see the 3 speakers on the network and can stream to them from the PC. Also, installed Bubbleupnp on my android and can see/control the speakers from there as well. I tried reinstalling the app/DH, resetting the hub, etc. But smartthings app still does not discover the 3 speakers or Bubbleupnp. Here is the only thing showing in the log…

ed6cbbe8-8459-44cf-a8d3-152f78b51b61 ‎9‎:‎11‎:‎00‎ ‎AM: debug getChildDevices(false), children=0

ed6cbbe8-8459-44cf-a8d3-152f78b51b61 ‎9‎:‎10‎:‎17‎ ‎AM: trace mediaRendererDiscovery() state.subscribe true

ed6cbbe8-8459-44cf-a8d3-152f78b51b61 ‎9‎:‎10‎:‎00‎ ‎AM: debug getChildDevices(false), children=0


(Satish P) #984

@ule I did install this smart app too and set the Action as “Sound” and Play this sound as “dogs barking”. But I still dont listen this sound on my TV.

Let me know if there is any thing i should do to enable logs and provide you for debugging the issue. Thank you for your help.

Just to recap, I have installed the Generic Media Renderer Connect, DLNA Player (DTH) and Media Renderer Events apps. Do I need to install any other apps or softwares on my IOS device to get the notifications working?


(KB) #985

It should work with Qualcomm AllPlay speakers, but the search does not find the, Any thoughts?


#986

I have Hitachi AllPlay speakers that stopped working a while back (was setup using an earlier version of Media Connect, Events, Player (would find them ok, but no sound). I removed everything in the IDE and created new apps for Events and Connect, and new handler for Player – but the newest version of Connect doesn’t find any DLNA devices. So … my plan right now is to find the old version of Connect and try to use the latest handler with it. I wish I hadn’t deleted my instance of the old versions …


(Mark Dee) #987

Is this still supported?

I’m trying to get my Pure Jongo T6 (freebie) to connect to Smartthings. I’ve been successful installing this and getting my ST Hub to see the device.

But when trying to use this speaker to give me voice notifications say when a door opens, this speaker doesn’t show in my list.

Pretty stuck what to do.

Thank you


(Ryan) #988

How did you add the speaker to ST? Through the SmartApp here? Or did you add it separately. I can’t see anything in the documentation for this speaker where it specifies its a DLNA device. Which means it wouldn’t work with this smartapp.


(Mark Dee) #989

I added it through this smart app. I can see it on my list of devices, just can’t do anything with it.