SmartThings Community

RELEASE Generic Media Renderer (DLNA Speakers). Cheap Sonos Alternative (Update V2)

I must be doing something wrong I cant get it to play either way. I cant even get it to play a sound. and when I go into smartthings app to see the jongo s3 the app crashes. Its only this device that does it.

Hey @ule. I am on the latest release of MR connect, MR events, and MR player. I am unfamiliar on how to get the logs, especially of those apps/processes I have deleted and re-installed. I am trying to re-setup my Kodi (localhost on Android) but now I can’t discover it via ST. I have not changed anything with ST or my Android/Kodi setup, but now it just won’t discover it at all. I’ve waited 10 minutes on the discovery part of the app and it’s not finding it as a renderer anymore. Very strange as it was just working a few days ago, then when it started to freeze it was still at least discoverable, but now it’s just not being found at all. I’m thinking it had something to do with all of the changes ST is doing. I will reset everything and try again and let you know if I can at least discover the renderer and get some logs. Thanks @ule!

HI @CodyWillner,

  1. Verify your router settings and check upnp its enabled
  2. Try to use some upnp finder to check your kodi it´s visible on your network ex Browse UPnP
  3. If you can find the device in your network but no ST.
    3a) Disconnect and reconnect your ST hub (some times works)
    3b) Try to change the ip of your mediarenderer

Hi @GunGeek, In Thing sections on ST app (IOS or Android) you must see your jongo speaker and the status, if the status is “NOT PRESENT” your jongo can not be reached, try to use some upnp app to check if your jongo its in your network.

It is present, shows playing. I can play audio from my network share on the Jongo through the jongo app on android. I can see the jongo on my PC for streaming and stream audio from network to jongo on pc as well. Again as soon as I click on the jongo in smartthings the app crashes. I got into see it in smart things one out of 10 times. I viewed the history and see both smartapps trying to either play a message or sound but nothing comes through the jongo. I have tried TTS and just a simple sound nothing so far.

Hi, I have update the speech to alexa connect app, now you can control switch devices with it. and you can add other languages to control.

Its really good option, just to take your android phone click the mic in firefox and ask , “turn on the kitchen light at 75%”

you can be anywhere, no need to be in house to control the switches, for me its better that to open the smartthings app and find the thing

and like google have several languages you can add other languages commands, I have added spanish , but its easy to add others.

I can say “enciende la luz de la cocina al 50%” or “apaga la bocina de la sala”

you can try it.

Is it possible for this to work with the Fire TV at all? Maybe using the AirPlay/DLNA Receiver (PRO) app? The goal is to have SmartThings driven sound notification coming through the Fire TV (assuing it is turned on) when ANY app is being used.

Hi @prjct92eh2, Sorry I dont understand your question, do you want to use the fire tv like ST speaker? the answer : maybe is possible, Fire TV have the DLNA app, but I dont known if is compatible , the software mediarenderer change the id each time is turned on, or maybe do not send all information, if the app have all DLNA settings it must work, but no one has confirmed it works
sorry if I misunderstand your question

Correct. If we are watching the Fire TV and ST pushes a voice alert i want the Fire TV to output the ST audio. The app was only $5 and i had some Amazon credit, so i bought it. Will report back after experimenting tonight if I have any luck.

Hi @prjct92eh2, I dont known if the app can run in background, you must try

It works! Obviously haven’t had time to do long term testing, but so far so good.

1 Like

Hi @prjct92eh2, Great news!, if you agree I want to update the compatibility list with your contribution?

Whats the name of the app?

The media renderer can play video, you can send the url video from your camera and stop it after some time when a knock its detected in front door.

Thanks

The app is AirPlay/DLNA Receiver (PRO). Currently $4.99 in the Amazon App Store.

Good to know about video! I’ll have to research that some more once I get the front porch camera in its permanent home. Still debating mounting it inside and tackling another solution for night time IR lighting, or outside and battling the elements.

Funny seeing you here! :joy::joy::joy: JDRoberts told me to check this post out.
-Larance

I had 5 DLNA speakers working for about 1 year now but yesterday they all became unresponsive and Media Render Connect did not discover them anymore.

I deleted the speaker devices
I deleted the Media Render Connect App from My SmartApps.
I deleted the DLNA Player Device type from My Device Handlers
I installed/published the “Media Render Connect” app (v2.0.1)
I installed/published the the “DLNA Player” device type (v2.1.1)

I am able to discover the speakers now when I start installing the Media Render Connect App.
When I click done on the “Search and configure your Media Renders” page I get a “Failed to save page: Mainpage” error.
I verified that I have the latest version of the DLNA Player device type installed and published

Here is my log entry from the IDE:

d711f996-3709-4dcf-8abe-4617e8d347cf 5:22:16 AM: error com.netflix.hystrix.exception.HystrixRuntimeException: C*-DeviceDataIndex-Create timed-out and fallback disabled.
d711f996-3709-4dcf-8abe-4617e8d347cf 5:22:05 AM: trace updated()
d711f996-3709-4dcf-8abe-4617e8d347cf 5:22:01 AM: trace mediaRendererDiscovery() state.subscribe true

Would you be able to help? Is this an app issue or a SmartThings platform issue after the recent update?

Thank you!

Hi @pizzinini, I hink its a ST problem, C*-DeviceDataIndex-Create timed-out, seems to be the problem, other user have tell me time ago , he has problem with wemo devices, but he want it to install 15 wemo at once, the solution , insatall one speaker at time until you finish. days after ST fix the problem and he could to install normally, then I think could be the same problem

Thanks for the quick response.

Yes this was definitely a platform issue. I tried again a couple of times today, also with just as single device and finally tonight it kind of worked… My devices all back and working. But for some weird reason the app did not install right. I can’t see it in the mobile app but in the IDE under locations it shows as “Media Render (connect) (dev)”. Same is true for the Media Render Events App… Installing the notify with sound app works fine.

Hope Smartthings fixes all this mess soon!

I went through all of your instructions and everything is working great except for one thing. If I press up or down on the arrow to change the temp, that particular temp gets stuck. So if I have an app such as keep me kozy to change the temp when I leave the house that setting never gets changed to the setting in keep me cozy. For example while playing with it I changed cool to 75 degrees with the arrows. My (keep me kozy) apps are set to 65/74 (h/c) in Home Mode 55/78 in AWAY and 60/71 in night mode. After changing the temp to 75 with the arrows only the heat setting is changing as it should be according to the mode ST is in. The cool setting is stuck at 75. Any idea what could be causing this?

I am using Private Dancer with a Samsung S2 hooked to a soundbar via audio jack.

Play Weather Report is working fine, but playing sound when something happens isn’t. I am using Ivona and it was working fine until yesterday.

Here is the log -
925b8511-e819-4de1-b490-a20fadcac442 3:38:33 PM: trace Exiting takeAction()
eb1058f9-a72d-456a-8e31-ab376eb4bac4 3:38:33 PM: trace previous notification in progress or Do Not Disturb Activated
74b780c8-7980-4bb4-967d-18af838a8d2b 3:38:31 PM: debug params: [ts:1462217872584, stateID:1462072948035, _:1462217780799, access_token:XXX-XXX, appId:74b780c8-7980-4bb4-967d-18af838a8d2b, param1:ping, action:[GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi]
80c64255-6ecb-4b67-bf7d-d999bb7ea3ff 3:38:31 PM: trace getPhrases(), state.welcomeIssue = null
80c64255-6ecb-4b67-bf7d-d999bb7ea3ff 3:38:31 PM: trace getPhrases(), state.welcomeIssue = null

I’ve also tried different modes, and still receive - “previous notification in progress or Do Not Disturb Activated” , but when I go back to Play Weather report it plays the weather without a problem.

Any suggestions? Thank you!

Has anyone tested this on the uk? Version 2.0.1

I’ve followed the instructions…

Smartapp doesn’t appear on my mobile device
The device handler doesn’t add unless I create in the ide.

Before spend time looking at it, wanted to check its not a know issue for uk smarthubs.