RELEASE Generic Media Renderer (DLNA Speakers). Cheap Sonos Alternative (Update V2)

@Kristopher

Did you get the voicerss to work as well? I can get the Bell or dogs barking but not voice. I guess I need to debug!

Roy

I couldn’t find how to make DLNA renderer play a specific song.
Is that supported ?

I installed the app and then I have the speaker showing up but as soon as I do the set trigger like motion at a certain location no sound starts on my bravia tv

Hi Jeet, Try to use the app

Hi @mrmrmrmr, You can use any DLNA control point to send music to your speaker, after that all the url tracks are saved inside the device, you can select some tracks to play when some event occurs, The ST is not a control point for music, you must to use a dedicated control point to select your music (read first post)

Hi @royleonard, try to use

@ ULE,

What happened to the custom TTS announcements?

Custom messages that were configured previously are still working a long as you don’t make any changes.

I had to delete and reinstall mine this weekend and the custom option was gone.

@ule

I am using the latest version, and I’m getting “unable to play content” message on the screen of the yamaha device when I send it the voicerss.org file, but not the standard mp3 files (e.g. sound, Bell 1)

Roy

HI @ATrain, what smartapp are you using?

Hi , @ATrain, are you using media renderer events?, in logs copy the url sent to speakers, and paste in a web browser to check if the audio is correct, possible your rss key is incorrect.

Hi, I’m new to dlna and I’ve set this up. I’m using a pure jango Wi-Fi speaker. I’m not playing music, just using it for notifications and alerts.

The problem is that there is a huge delay and the first have of the message is cutoff.

For example…

“The front door is open” is heard as " is open".

Any help would be greatly appreciated.

Have you tried to use the Delay before Message option? Try increasing the seconds.

@ule

I am using speaker notify with sound, but it no longer has the option for custom TTS. Looks like maybe tomorrow there will be a new release.

Hi @ATrain, try to use

Hi, the delay before message its when an audio cuts off at the end “the door is…” this means the speaker takes more time to load the audio, the delay adds more time “The door is opened” but, when the audio cuts off at beginning, the problem must to be the speaker , some speakers load the mp3 in several ways, maybe jongo have setting to allow gapless music, just check setting. maybe @BristolBaz can help us if the audio cuts off at the begining in these speakers.

I’m using a jongo speaker and its doing this too…

Hi @bamarayne, the post was about your question, @Mclovin50, just answer you about the delay, but I think its the speaker, @BristolBaz, has shared the jongo speakers works with mediarenderer, maybe he can help us to known if the problem its with all jongo speakers, or needs some setting to fix it, you can add a prefix in your messages like “Mesage, the door its opened” when the audio cuts at the beginning " the door its opened" will be complete, if you have other speakers all the sentence will be played

Thank you for the response. I am trying the “fill in the gap text” but haven’t had much time for testing.

I wanted the other jongo users to know it’s not just their speakers.

The delay at the beginning is kind of a bummer. It makes for a huge delay for tts, which ask I use the speakers for.

I’ll treat more this evening and post my results.