SmartThings Community

RELEASE Generic Media Renderer (DLNA Speakers). Cheap Sonos Alternative (Update V2)

dth_speakers
dth_voice
dth_alerts
#495

Thanks @mrmrmr, i completely missed the bits to insert extra details in the code, in the device handler, but saw it in the weather app!

This will be amazing if I can get the TTS ivona selected accent to work globally, controlled by the text input within rule machine :slight_smile:

#496

@ule has done a great job with this app!

Having the ability to set a global TTS service on the device handler would be a killer addition to an already great app! Especially for those of us without any coding skills!

(RoyL) #497

@Kristopher

Did you get the voicerss to work as well? I can get the Bell or dogs barking but not voice. I guess I need to debug!

Roy

(ilker Aktuna) #498

I couldn’t find how to make DLNA renderer play a specific song.
Is that supported ?

#499

I installed the app and then I have the speaker showing up but as soon as I do the set trigger like motion at a certain location no sound starts on my bravia tv

(Ule) #500

Hi Jeet, Try to use the app

(Ule) #501

Hi @mrmrmrmr, You can use any DLNA control point to send music to your speaker, after that all the url tracks are saved inside the device, you can select some tracks to play when some event occurs, The ST is not a control point for music, you must to use a dedicated control point to select your music (read first post)

(Ule) #502

Hi @royleonard, try to use

(Adam) #503

@ ULE,

What happened to the custom TTS announcements?

(Pizzinini) #504

Custom messages that were configured previously are still working a long as you don’t make any changes.

(Adam) #505

I had to delete and reinstall mine this weekend and the custom option was gone.

(RoyL) #506

@ule

I am using the latest version, and I’m getting “unable to play content” message on the screen of the yamaha device when I send it the voicerss.org file, but not the standard mp3 files (e.g. sound, Bell 1)

Roy

(Ule) #507

HI @ATrain, what smartapp are you using?

(Ule) #508

Hi , @ATrain, are you using media renderer events?, in logs copy the url sent to speakers, and paste in a web browser to check if the audio is correct, possible your rss key is incorrect.

(Jason "The Enabler" as deemed so by @Smart) #509

Hi, I’m new to dlna and I’ve set this up. I’m using a pure jango Wi-Fi speaker. I’m not playing music, just using it for notifications and alerts.

The problem is that there is a huge delay and the first have of the message is cutoff.

For example…

“The front door is open” is heard as " is open".

Any help would be greatly appreciated.

#510

Have you tried to use the Delay before Message option? Try increasing the seconds.

(Adam) #511

@ule

I am using speaker notify with sound, but it no longer has the option for custom TTS. Looks like maybe tomorrow there will be a new release.

(Ule) #512

Hi @ATrain, try to use

(Ule) #513

Hi, the delay before message its when an audio cuts off at the end “the door is…” this means the speaker takes more time to load the audio, the delay adds more time “The door is opened” but, when the audio cuts off at beginning, the problem must to be the speaker , some speakers load the mp3 in several ways, maybe jongo have setting to allow gapless music, just check setting. maybe @BristolBaz can help us if the audio cuts off at the begining in these speakers.

(Jason "The Enabler" as deemed so by @Smart) #514

I’m using a jongo speaker and its doing this too…