[RELEASE] Enhanced Z-Wave Plus Thermostat Device Handler - Honeywell, GoControl, CT, Linear, Trane, MCO, Remotec

It’s been tested with the ZXT-120, the ZXT-600 is similar so it should work. See the first post for a list of features:

The Off command works with ZXT-600, turning it on, setting to heat at 25 deg C does not work. See logs below.
2.35 PM sent Off command. It worked. Also heard the beep from the AC
2.40 PM sent On, Heat, Auto. Did not work.

The above are set using simple time based automation.

The fingerprint is below:
[zw:Ls, type:0806, mfr:5254, prod:0102, model:8490, ver:1.05, zwv:4.33, lib:03, cc:[5E, 98, 22, 5A, 59], sec:[7A, 72, 86, 85, 70, 73, 31, 40, 43, 44], endpointInfo:]

image

Your ZXT controller is busy and is rejecting the command

That’s bizarre as I have tried multiple times live logging does not shows anything else. It always has the same error. I’ll try with “Cool”.

Your logs are showing you’re sending too many commands at once. The device is telling the hub to wait for 2 seconds before trying to send the next command.

This time I just set Mode to “Heat”. It turned on, but the error is still there. I am fine with it if it works this way, do I just set the Heating Temp and Cooling Temp and use automation to change the mode and off?
image

Enhanced Z-Wave Thermostat with Humidity, Filters, Lock Controls and Setpoint Limits - Version 05.02.04

  • (Fix) for some device settings Save button not working after SmartThings mobile app update
  • (New) Added support for ZXT-600
    • Set air conditioner IR code ( learning not supported , refer to manual )
    • Humidity reporting
    • Humidity offset correction
  • (New) Added basic support for Alarm.com z-wave thermostat
1 Like

Thanks @maddie and @RBoy for adding ZXT-600.