[RELEASE] Enhanced Z-Wave Plus Thermostat Device Handler - Honeywell, GoControl, CT, Linear, Trane, MCO, Remotec

One reason why it doesn’t do that is because it would reduce the battery life polling the thermostat each time. So the question is do you prefer battery life or poll back on the temp?

Yeah…good point. Is it possible to poll it maybe every couple of hours. I guess it may not really matter once I get my schedule setup thru ST. Even if we manually change the temp on the thermostat, once the next schedule comes around it should sync everything up.

Don’t kill yourself over it :slight_smile: whatever you decide I’ll be fine with.

Thanks again!

I checked and it’s actually working fine for me - no changes, when I change the temp on the thermostat in about 10 seconds it shows up on my app. Check the code base you’re using, I’ve posted the code I’m using on the server in my first post.

Yeah, that’s weird. I just tried and it works the same way. I know I checked it before and it did not work. Maybe ST was having an issue when I tried.
Either way, it’s working. Great job!!

And my battery status stopped working after a day or so lol. I’ll rebuild the code and see if I messed anything up. Really liking this on my CT100

Put in a new battery fix recently. ST isn’t the most stable/documented platform

The work of users/coders like yourself is one of the major reasons that I decided to invest in ST. I know that they were busy with CES and the launch of Hub 2.0, but hopefully they are offering people like you the support that you deserve. A thriving community benefits them as much as it does us.

1 Like

@RBoy Do you experience this behavior?: Refreshing a thermostat returns incorrect setpoint

Basically if the heating setpoint in the thermo is different from the app, there is no way to refresh from the app to get the correct value. This is with every device type I have tried.

No I haven’t seen that happen, try rebooting your hub and see if that helps.

For some reason when the update occurs on my tstat it’s off by a day. For instance it will change the tstat to Thursday when it’s Wednesday. Time remains correct though.

Check the date on your hub. I think it takes the date from there

Two days ago I rebuilt the Device Type using the latest ST code and latest edits. Saved, Published. I’m still not getting any battery data, just “–”.

It’s not really a big deal to me, but I wanted to report it here. I see no mention of any battery poling in the Event Log for the device and no mention of battery status in “Current States”. Is that were I messed up?

I also don’t see Battery listed under Capabilities for the device type.

Give it a few hours, apparently ST has changed the way the devices are polled recently in their firmware and slowed down the polling to conserve battery life, so even a manual refresh can take some time (usually 15 minutes or so) to show up.

Updated code posted, updates the base code with Feb from ST
New features

  1. Added thermostatFanMode support
  2. Added sliders control for temperatures, some folks had issues with slow response of up/down controls - now it has both, up/down and sliders - more real estate but easy to use

Added capability “battery” to make it report the battery status better as well as be compatible with the ActiON dashboard.

For the life of me I cannot figure out why the day is changing on my thermostat. It looks to me that the hub has the right date and time. :confused:

See the logs for what date/time is being sent to the device. That might throw some light on it.

There’s something screwy going on with the stat itself because ST is sending the correct date/time according to the logs.

Can you post what you are seeing in the log here and also what you see on the thermostat.

I’m a bit confused. There are multiple threads that seem to be interconnected but It’s hard to tell which one is the one I should be following. I have a CT100 and would like to expose Humidity, Battery, and add up/down tiles. From the name of this thread, I’m hoping this is the correct one…

In @RBoy 's original post above there are a number of lines of code that need to be copy/paste/replace. I’m not a coder and have never done this before. Every other device type I’ve added in ST has always been Select All-> Replace. Additionally the stuff I’m supposed to replace doesn’t seem to match what I’m seeing in IDE.

Does this device type exist in its entirety somewhere? Is this the code on the RBoy premium apps server?