[RELEASE] Enhanced Z-Wave Plus Thermostat Device Handler - Honeywell, GoControl, CT, Linear, Trane, MCO, Remotec

That’s bizarre as I have tried multiple times live logging does not shows anything else. It always has the same error. I’ll try with “Cool”.

Your logs are showing you’re sending too many commands at once. The device is telling the hub to wait for 2 seconds before trying to send the next command.

This time I just set Mode to “Heat”. It turned on, but the error is still there. I am fine with it if it works this way, do I just set the Heating Temp and Cooling Temp and use automation to change the mode and off?

Enhanced Z-Wave Thermostat with Humidity, Filters, Lock Controls and Setpoint Limits - Version 05.02.04

  • (Fix) for some device settings Save button not working after SmartThings mobile app update
  • (New) Added support for ZXT-600
    • Set air conditioner IR code ( learning not supported , refer to manual )
    • Humidity reporting
    • Humidity offset correction
  • (New) Added basic support for Alarm.com z-wave thermostat
1 Like

Thanks @maddie and @RBoy for adding ZXT-600.

1 Like

Hi. Has anyone here managed to get this working on the ZXT-120? Mine doesn’t seem to be updating the Remote Code. Any pointers would be much appreciated. Thank you!

Checked my thermostat today and noticed two things. Since the last update, my thermostat doesn’t update idle/cool as often as it used to in the history. Typically only once or twice a day instead of the 30 on 30 off it used to. Second, it was in mode “vent economizer”. I’ve never seen that before. Any idea why it would automatically switch to that mode, and what is it?

Problems adding my CT101. It worked fine under the classic app, but that’s gone bye bye!

I just downloaded the RBOY code, added it to my Device Handlers and it shows up on the list as published.

For good luck, I did a reset of the device, holding the button down for 15 seconds and then waited for the Please Wait to go away. On the screen are Radio, the tower icon and Link.

I pressed Menu - nothing happened. Pressed Menu a second time and Mate appeared. R1 is displayed,

Pressed Mate twice and only Mate kept blinking - not Link. After a few seconds Mate stopped blinking.

I then went to the Android app - Add Device - scan nearby. It eventually timed out, not finding the device.

I then went into Add Device - By Device Type - Thermostat, clicked on Iris, then Radio Thermostat. The scan eventually timed out.

I also tried scanning again after pressing supported devices.

I have tried this with the thermostat on the wall in the next room, and also on battery power within 5 feet of my ST Hub v2.

What am I missing here?

That’s a soft reset. This device doesn’t support a hard reset. You will need to exclude the device first before trying to pair it otherwise it won’t pair. After a failed pairing you will need to exclude it each time before trying to pair it again. Also make sure it’s within 3ft if the hub when trying to pair it.

How do I exclude it?

Partial lock on my multiple CT101 thermostats completely locks out the thermostat controls. Is there a trick to getting the menu options locked out, but up/down arrow for temp control available?

PS: Sorry if this was mentioned earlier in the 600 replies, search option above is broken on iPadOS.

There no trick, it’s thermostat dependent. Not all thermostats work the same way. Some thermostats support partial lock, others don’t and even how partial lock works on those thermostats vary from model to model depending on how the manufacturer designed it.

Since the description lists partial lock under the CT-XXX family do we know which versions of that family support it? Not against replacing a thermostat if there’s more capability on models other than the 100/101 series.

Enhanced Z-Wave Thermostat with Humidity, Filters, Lock Controls and Setpoint Limits - Version 05.02.05

  • (New) Added support for country specific variants of Remotec ZXT-120 and ZXT-600
    • Set air conditioner IR code ( learning not supported , refer to manual )
    • Humidity reporting
    • Humidity offset correction

For the last week or so, I’ve been getting “A network or servor error occurred. Try again later.” message in ST app to control my Thermostat. It did it with @RBoy 's current v05.02.05 and v05.02.03. I rebooted the hub but that did not help.

I can see in the ST IDE that thermostat shows Last Activity updating so I can tell it’s connected.

Is this a known ST platform issue or something local? I really don’t want to exclude/include because I have multiple automations tied to the Thermostat.


What worked was resetting the thermostat on the device and it is now responding.

Do you think will have the learn code soon as we have it in old app?

I do not have your handler if I buy yours one of my air o dition work because have learn code in it

Do you know if I will lose. It if use yours?

Thank you keep your hard work

any plan for edge drivers?

1 Like

RBoy Migration FAQs

Thank you.! I will follow this page for news