[RELEASE] Enhanced Z-Wave Plus Thermostat Device Handler - Honeywell, GoControl, CT, Linear, Trane, MCO, Remotec

Update for the new SmartThings Mobile app

Enhanced Z-Wave Thermostat with Humidity, Filters, Lock Controls and Setpoint Limits - Version 05.00.00

  • (New) Custom UI for specific thermostat brands (CT, Honeywell, GoControl, MCO, Linear etc)
  • (New) Custom controls for thermostat locking (fully, partial, unlocked)
  • (New) Custom controls for filter replacement reminders and filter reset
  • (New) Report power source, AC Power (C-Wire)/Battery
  • (New) Report current thermostat fan mode - Auto (Idle), Auto (Running), On, Circulate
  • (Enhanced) Customized setpoint limits for GoControl, CT, Linear, Honeywell and ZTS thermostats
  • (New) Report humidity for Honeywell T6 Pro and more thermostat models
  • (Fix) Fixed filter reporting for GoControl and ZTS thermostats
  • (Enhanced) Enable Auto changeover (auto mode) for Honeywell T6 Pro, Honeywell T5 and other Honeywell thermostats
  • (New) Option to ignore low battery for thermostats connected to C-Wires


  • If you’re upgrading from version 4.x or older: the UI may not reflect the new changes due to platform caching. One way to force the cache to clear is to change the device handler to Z-Wave Device and then back to this Enhanced Z-Wave Thermostat device handler from the IDE, then sign out of the ST mobile app and sign back in. If nothing else works, you may need to exclude your device, delete the device handler and reinstall it if the UI does not update after 24 hours.

Enhanced Z-Wave Thermostat with Humidity, Filters, Lock Controls and Setpoint Limits - Version 05.02.00

  • (New) Added support for Remotec ZXT 120
    • Set air conditioner IR code (learning not supported, refer to manual)
    • Humidity reporting
    • Humidity offset correction
  • (Update) Added support to detect power source for all battery operated thermostats
1 Like

have you plan to fix the learning ir codes for ZXT 120?

thank you great work

Hi, does anyone know if this will work with MCOEMH8-FC4?

I see at the top that the US version was tested but just wondering if anyone had tried this with a EU version.
Thanks for the help

I’ve got a Honeywell YTH8320ZW1007/U Z-Wave Enabled Programmable Thermostat that should work with this. This DTH would allow me to change temperature, choose different modes (heat/cool, etc). These are all considered manual overrides to my thermostat’s regular programming. After setting the temperature to warm up to, say, 69 degrees for a few hours, how would I return my thermostat to “auto” mode so that it continue to do it’s thing?

I believe that when you use Z-Wave manual overrides it disable internal schedule. You can manage your schedules using custom apps to program the thermostat over Z-Wave (which also gives you many more options in terms of using remote temperature sensors, motion sensors, modes etc). Here are some apps which do thermostat programming over z-wave:

[RELEASE] 5-2 Day Programmable Thermostat Scheduler (Weekday, Weekend) with Remote Temperature Sensor for each Schedule

[RELEASE] Motion Sensor Thermostat with Remote temperature sensors, Presence detection and Schedules

[RELEASE] Mode Based Thermostat - Control Multiple Thermostats Temperature / Remote Temperature Sensors when Changing Modes

[RELEASE] Unlimited customizable thermostat

Can I assume that there is not a way via zwave to “resume program” or equivalent?

Does this work with Remotec ZXT-600?

It’s been tested with the ZXT-120, the ZXT-600 is similar so it should work. See the first post for a list of features:

The Off command works with ZXT-600, turning it on, setting to heat at 25 deg C does not work. See logs below.
2.35 PM sent Off command. It worked. Also heard the beep from the AC
2.40 PM sent On, Heat, Auto. Did not work.

The above are set using simple time based automation.

The fingerprint is below:
[zw:Ls, type:0806, mfr:5254, prod:0102, model:8490, ver:1.05, zwv:4.33, lib:03, cc:[5E, 98, 22, 5A, 59], sec:[7A, 72, 86, 85, 70, 73, 31, 40, 43, 44], endpointInfo:]


Your ZXT controller is busy and is rejecting the command

That’s bizarre as I have tried multiple times live logging does not shows anything else. It always has the same error. I’ll try with “Cool”.

Your logs are showing you’re sending too many commands at once. The device is telling the hub to wait for 2 seconds before trying to send the next command.

This time I just set Mode to “Heat”. It turned on, but the error is still there. I am fine with it if it works this way, do I just set the Heating Temp and Cooling Temp and use automation to change the mode and off?

Enhanced Z-Wave Thermostat with Humidity, Filters, Lock Controls and Setpoint Limits - Version 05.02.04

  • (Fix) for some device settings Save button not working after SmartThings mobile app update
  • (New) Added support for ZXT-600
    • Set air conditioner IR code ( learning not supported , refer to manual )
    • Humidity reporting
    • Humidity offset correction
  • (New) Added basic support for Alarm.com z-wave thermostat
1 Like

Thanks @maddie and @RBoy for adding ZXT-600.

1 Like

Hi. Has anyone here managed to get this working on the ZXT-120? Mine doesn’t seem to be updating the Remote Code. Any pointers would be much appreciated. Thank you!

Checked my thermostat today and noticed two things. Since the last update, my thermostat doesn’t update idle/cool as often as it used to in the history. Typically only once or twice a day instead of the 30 on 30 off it used to. Second, it was in mode “vent economizer”. I’ve never seen that before. Any idea why it would automatically switch to that mode, and what is it?

Problems adding my CT101. It worked fine under the classic app, but that’s gone bye bye!

I just downloaded the RBOY code, added it to my Device Handlers and it shows up on the list as published.

For good luck, I did a reset of the device, holding the button down for 15 seconds and then waited for the Please Wait to go away. On the screen are Radio, the tower icon and Link.

I pressed Menu - nothing happened. Pressed Menu a second time and Mate appeared. R1 is displayed,

Pressed Mate twice and only Mate kept blinking - not Link. After a few seconds Mate stopped blinking.

I then went to the Android app - Add Device - scan nearby. It eventually timed out, not finding the device.

I then went into Add Device - By Device Type - Thermostat, clicked on Iris, then Radio Thermostat. The scan eventually timed out.

I also tried scanning again after pressing supported devices.

I have tried this with the thermostat on the wall in the next room, and also on battery power within 5 feet of my ST Hub v2.

What am I missing here?

That’s a soft reset. This device doesn’t support a hard reset. You will need to exclude the device first before trying to pair it otherwise it won’t pair. After a failed pairing you will need to exclude it each time before trying to pair it again. Also make sure it’s within 3ft if the hub when trying to pair it.