[RELEASE CANDIDATE] CoRE (Community's own Rule Engine)

smartapp_misc
core

(Bobby) #22

Had to use emoji, cause it didn’t let me like it multiple times… :heart: :heart: :heart: :heart:


(Jason "The Enabler" as deemed so by @Smart) #23

Isn’t that a small security risk? If that transmission is intercepted? Can’t it be repeated right back to the lock to make it unlock?


#24

I believe those are just slot numbers?


( I hate Mondays) #25

The actual unlock code is not provided. What is provided is the index of the code, or slot, if you want. @eibyer is right.


(Michael Hess) #26

This would be perfect, I can have my kids chores list go over speakers when they come in. :slight_smile:


#27

Hi @ady624 and Everybody else

I took the plunge and upgraded to this version yesterday afternoon, and have have suffered corruption since then. Perhaps co-incidence considering the latest bout of DumbThings issues… Never the less, Core is showing the symptoms & I am suffering.

Here is good example what I am suffering. Notice the missing Condition data:

Yes, a REBUILD does fix it, as shown below:

Now for the interesting part… I REBUILT all my pistons yesterday. I didn’t verify them all, but they appeared to be functioning for the most part.

I did another REBUILD ALL this afternoon (out of necessity), several hours ago at the time of writing this, and the piston above, amongst others was still broken before I ran an individual repair…, which fixed it!

Anybody know what be a happening?

Thanks in advance
J


( I hate Mondays) #28

Hmmm… that is odd… will look into the rebuild all, maybe there is a problem there. Pistons keep two copies of the data, a running config and a setup config. It may be that the setup config was corrupted, while the running config wasn’t… was/is the dashboard working ok?


#29

Yup, the dashboard appears to working OK; at least I get a listing & I can go in to a piston to see stuff. The one thing I cannot confirm. but will in due course once I have worked through all my pistons is if a “corrupt” piston displays properly in the dashboard… I have only check post fix implementation.

One other possible tit-bit: after the upgrade, I saw for the for time, that 5 of my pistons read paused. Huh? That is how I discovered the corruption for the first time, although a corrupt state was not indicative of a corresponding paused state for all the affected pistons.

As a complete aside, is there any rhyme or reason why some pistons when clicking Done take you all the way out of the app to the general Smart-apps listing, while others simply take you back to the all pistons listing?

Thanks
J


( I hate Mondays) #30

Nobody knows why the Done takes you all the way out. Android?

The paused state is a clear indication of lost state. How did you update? Github integration or manual copy&paste? And from what version to what version?


#31

Yes, on Android.

I’ll ry to answer the other questions…

  • updated via “Update from Repo” button on the SmartApps web page
  • updated TO V0.3.151.20130920
  • updated FROM V0.2.14b.20160902

And as I am trying to access the Dashboard again, it took forever to load, progress bar almost complete at the top, and then rolls back to approx. 35% mark. Did this perhaps 7 times.

J


( I hate Mondays) #32

I think something is afoot with ST. Everything is very slow but I haven’t had any corruptions. And Inuograde and downgrade all the time


#33

Just found another:

As shown in the dashboard:

Again, keep in mind I did run an ALL PISTON recover this afternoon…

Can’t actually confirm if it is working - not dark enough outside yet!

Thanks
J


( I hate Mondays) #34

Could you please fix them all manually and then let me know if any gets corrupted again? Is your app logging you out much during config?


#35

Never been logged out since I updated to the latest version, although my phone has died a few times since (battery) which is I guess, indirectly, almost the same.

Will fix all & advise; gonna take a lot of time even with an Android emulator.

J


( I hate Mondays) #36

Oh and also, recover and rebuild are two different things. Recover kicks piston started should they completely halt due to missed events, rebuild is supposed to do the actual fixing of corrupted pistons. Which one did you run?

Oh and wait. Can you rebuild all and see if the corrupted one gets fixed please?!


( I hate Mondays) #37

Try a rebuild all first,see if it fixes anything…


#38

I did the REBUILD. Stands to reason :slight_smile:


( I hate Mondays) #39

Error 18326: answer too vague ;)))

Did it fix the corrupted piston, yey or nay?


#40

Yes, the INDIVIDUAL rebuild fixed it. If I come accross another corrupt one, I will run the rebuild ALL again & report back.


#41

Found another corrupt one:
Ran a REBUILD ALL. Completes in about 1.5 seconds.
Left the system alone for all of 1 minutes, perhaps 2…; its torture.
Checked both the dashboard and the “build screen”; both show OK

Soooo, now I have to question myself if I did actually run the REBUILD ALL or the RECOVER ALL. Unless I am going batsh1t crazy, I guess it is possible I did a RECOVER ALL, but both previous times??? I doubt it.

Will keep working through everything & report.