SmartThings Community

[RELEASE CANDIDATE] CoRE (Community's own Rule Engine)

smartapp_misc
core

(Jake) #408

@rontalley @Crussell

Thanks for the link to Host Pinger, although presence sensing is possible via pinging the IP, you will likely have 1 of two issues:

  1. The phone will put wifi to sleep, making it appear you are away
  2. The pings will keep the wifi active, but will cause battery drain because of this…

I think the short answer is that there is no single solution that is actually reliable for presence, android or otherwise… there are a few workarounds, IFTTT may potentially be an option, but probably no better than the native ST app presence…


#409

Does CoRE require OAuth? When I installed manually I enabled and now realizing not sure if it does. In fact not clear on when an app needs it and when it doesn’t other than install instructions saying so. If not, any way to reverse?


(Michael Hess) #410

To use the dashboard it is required. You can disable it in the IDE I think, honestly never tried.


#411

Right. . .forgot about the dashboard. That’s why I enabled. Thanks.


(Petro Dude) #412

I am having an issue with a possible bug in the following piston that controls a color LED light near my grill. I use it to change colors based on various events. At night right now, it should be changing back and forth between red and green for Christmas.

The variable is getting set correctly and the piston is firing as it should. It is also doing the follow up as I would expect. However, the combination of red and green is not working. The red comes on, but it won’t change to green. I am getting errors in the logs every time it changes to green.

Here is where it gets odd though. I have tried other variations of green (green, forest green, lawn green) and I get the same errors. I have tried replacing the red with green and the green with red. The red still works and the green is still broken. The odd thing to note is that the HSL values for the red as seen in the logs are correct. However, the HSL values that it is trying to use for green (33, 100, 25) are not correct and are not what are listed in the CoRE code (120, 100, 25 for green). I tried changing the color green to blue and it worked perfectly. Red and blue for Christmas just doesn’t fit as well! @ady624 Any ideas? Thanks.


(Bob) #413

You might like to post your query in the dedicated thread.


(Eric) #414

I disabled the LIFX scene integration (I wasn’t using it anyways) and it didn’t help. I recently added more automations, so I moved 2 pistons to another app instance and now it works. I guess I am pushing the boundaries of either the app or the platform.


( I hate Mondays) #415

CoRE uses degrees for Hue. ST (and your DTH) uses percent. CoRE divides the 120 by 3.6 and sends 33. Looks like the DTH has a problem with floats. Can you show me line 722 of your DTH?


(Joe Betsill) #416

I’m having real difficulty installing this App, but it’s exactly what I am looking for. I hope this question (plea for help, really) is appropriate for this thread.

If I install CoRE following the links in the wiki, I’m directed at graph.api.smartthings.com, and when I install the app there (from github) it does not show up in the Marketplace (under “my apps”) on my Android phone.

However, if I go to graph-na02-useast1.api.smartthings.com and install the app (from github) it shows up in the Markeplace (under “my apps”) on my Android phone-- but nothing seems to work. Making a piston gives an error that it cannot be saved, and variables appear to be saved, but do not show up in the variable list.

This multiple URL for the smartthings IDE is very confusing. I’ve been using smartthings for about a week, just so you know my familiarity level. Other SmartApps behave exactly the same way-- they don’t show up when installed on graph.api, but they do show up when installed on graph-na02-useast1.api; but until now, they’ve all worked on the latter.

Any help would be very appreciated! Thanks!


( I hate Mondays) #417

Install it in whatever your IDE is. If you are on the na02 shard, use that. In theory, going to ide.smartthings.com should redirect you to your home shard.

Any errors in the logs?


(Joe Betsill) #418

ide.smartthings.com only redirects me if I go to my locations and click on my home location. Any clicks after that are on the correct shard; any before are not. I recognize that this isn’t your/CoRE’s fault, of course.

How would I pull logs? I’ve pretty much wiped my smartthings account clean trying to figure this out, so I’ll need to reinstall some things to get logs.


( I hate Mondays) #419

Live logging in the IDE?


(Joe Betsill) #420

Well, making a piston seemed to work. I don’t have anything connected right now, except my Presence Sensor, so I just made a simple If Joe is present, wait 35 seconds. I’m not sure if my issue was specific to the lighting control Piston I was making before.

As for variables. I can get them to “stick” by naming them “dim” instead of “$dim” (I do not know which is proper.) but when they stick, I get the following error in the IDE:

java.lang.NullPointerException: Cannot invoke method containsKey() on null object @ line 2265

and in the App I get an error that states:

You are not authorized to perform the requested operation.

Thanks, again, for your help.


(Phil Panfili) #421

I’m getting acquainted with Core… Is there a way to be notified if something is left on for a certain amount of time?

Say if I have a space heater, and it’s on a SmartThings plug, can I be notified if it is on for over 2 hours… If I forget to shut off?


(Bob) #422

Here is something I use which tells me if one of my motion sensors is stuck on active for an hour.
Should give you an idea.
BTW. You might want to post this in the CoRE peer assistance thread.


(Adam V) #423

Is it possible to have CoRE running in one location trigger an event or condition change in a piston in CoRE running in a different location?


#424

Send a text message?


(Chris ) #425

Getting too much lag when I do it that way and can’t figure out why. My network is 3 Asus rt-ac5300s dual wan gigabit, cat 7 cables only ac devices connected over Wi-Fi with about 18000 square ft of blazing fast speeds, so I know the problem isn’t there. Probably the old Arm processor in hub is half the problem ( a friend in r&d mention a 3rd version of something may contain an 830 with minimum of 1gb of ram)…that would really help people like me who have well over 175 devices and too many pistons to keep track of


(Ron Talley) #426

As soon as I arrive on my block my iPhones jumps on my 2.4ghz band. My 5ghz sux and is unrilable even within the house.

You can set up the config file to ping at quicker intervals. Mines is set up for 60 second pings.

But honestly, my geofencing works great so I don’t have to use host pinger for my phones but it has worked flawlessly to automate all kinds of things using CoRE based on IP status.

I hope you find a solution. I was jealous of android users because they have tasker that should do the job.


(Chris ) #427

I think its too many devices, apps, pistons…and a wife that I swear intentionally screws it up or puts hub in faraday cage