Paid request - intergration with Elk M1 security panel


(cjcharles) #141

Try giving it a power cycle. Did you change anything to make it disappear?


(Brent Crotts) #142

Tried power cycling, I went to update firmware due to still not receiving responses in ST but able to arm and disarm. When I logged in and updated it show update success…rebooting.


(Brent Crotts) #143

I noticed the whole time I was showing another esp_c182ac.lan device but the MAC address didn’t match the Node. I tried logging in to it without success


(cjcharles) #144

The whole time what was happening?

Maybe give your router a restart aswell, perhaps it isnt allocating an IP address correctly or something funky. And which firmware did you use? EDIT: Firmware probably doesnt matter as if it says success then it has done some checks that the firmware is suitable.


(Brent Crotts) #145

I restarted the router. I was finally able to get the node to broadcast and I put in the wifi credentials again. Still not showing on the network. To answer your other question I was using the firmware from the new thread(found on your Github).


(cjcharles) #146

Very strange, I’ve just checked that firmware again and it runs fine on my test device. Given it isn’t coming back even after giving Wi-Fi details again I expect it is related to your network setup. If you turn off your router temporarily then you should see the NodeMCU broadcast it’s AP again (after a reboot of the NodeMCU). You could try getting it to connect to your phone’s AP temporarily then (though it clearly won’t find your Elk!)

In bed now but I’ll have a think in the morning about what else could cause it. Worst case I can send you some instructions to totally reflash it, but I’m sure it will be something network related


(Dale Lenard) #147

same here, once I flash the latest firmware, i loose all access to the device. Tried all the restart router ect but nothing works. If i flash back to previous firmware, everything comes backup as normal.


(cjcharles) #148

How strange, I wonder what has changed, as I think the firmware I put on Github is actually just a copy of the one on Dropbox. Does that one cause you the same problems?


(Dale Lenard) #149

Yeah same thing with the one off github.


(cjcharles) #150

Can you try the version on Dropbox again, Ive restored a previous version which was working, so that will help understand what has changed.
Thanks


(Brent Crotts) #151

Maybe dumb question but how do you reflash firmware when the update firmware page is not accessible. I did finally get to the device but it only shows the initial screen where you input wifi credentials. Sort of strange because it has the credentials already.


(cjcharles) #152

Reflashing instructions are:

  • Connect Node to PC with Micro USB cable and hopefully you will see a new COM port appear in Windows Device Manager.
  • Download this tool - https://www.espressif.com/sites/default/files/tools/flash_download_tools_v3.6.4_0.rar and extract it with WinRAR.
  • Open the tool and choose ESP8266. It should auto-detect most settings but just in case ensure 26MHz crystal and 40MHz SPI speed, 32mbit and DIO (to be safe). Select the firmware file from Github, and choose enter 0x0 in the @ box (which is the memory address). Choose the newly appeared COM port at the bottom (it is very unlikely to be COM1 and will probably COM2 or higher)
  • Press flash
  • Reboot and all should be good again.

Really not sure what could have gone wrong though… Did the old Dropbox firmware work? (I rolled back the firmware on Dropbox to an old one that was working, though it might not get the zone names so it is only for testing)


(Brent Crotts) #153

I have followed the above instructions and re flashed the node. I was able to get it back on the network (Fing shows it as192.168.86.25 which was its reserved IP) and when I go to the node with a webpage it takes me to the Wifi setup still. Which it did save the credentials because it is on the network.


(cjcharles) #154

Yes probably reflashing it will confuse it initially as it will have scored Wi-Fi credentials but maybe doesn’t know it has already completed setup. I expect after you complete the setup it should go away and then behave normally.


(Brent Crotts) #155

Not sure what else to do. It shows on the network. It seems like it used to show Bonjour and UPnP services. Now it lists no services in Fing. Fing will show it but not ping it. I can not set the device up with the web address because the device does not respond to the request.


(Brent Crotts) #156

FINALLY. I finally got back to the dashboard and then device goes offline and then back on after I reboot.


(Brent Crotts) #157

I know everyone is tired of my issue but I am back online and able to arm and disarm from Smartthings. I don’t think I am using the latest and greatest Firmware but at least back working…


(cjcharles) #158

Did you do one particular thing that brought it back? Or just tinkering and randomly it started working? Quite useful to know that if there is a random bug there, though if so it is probably in one of the Esp8266 libraries so might be out of scope/intelligence for me to fix easily! Either way it’s certainly rare as I’ve only ever heard of one esp behave similarly before.

Glad to hear that though, what firmware did you use in the end?


(Brent Crotts) #159

Mostly tinkering. I would see it on Fing and it would Ping it and then it would not. Then I would have to reboot every time I lost it. Finally I got to the dashboard after a reboot and updated firmware with the firmware in dropbox from an earlier post. Still not perfect but at least back where I started. I will tinker some more and see if there is anything I can do on my end to get the status showing correctly in the app. Thanks for all your help.


(Hemant Gupta) #160

Found the link and sent you money. Thanks for your help!