[OBSOLETE] ZWN-SC7 Enerwave 7 Button Scene Controller

The SmartApp has a software debounce in it to prevent the button presses from registering multiple times. Even though they show up multiple times in the notification feed, the SmartApp will filter them correctly. Just make sure you are using the debounce version of the app and you should be fine.

Thanks for the quick reply :slight_smile:

I checked and it does have the soft debounce. The standard debounce is set to 3000. I have tried upping it and lowering it but its still hitting the button multiple times. Any ideas?

Thanks! :slight_smile:

If it makes you feel better my SC7s drive me crazy too with the lag and frequent need to press the buttons multiple times. I’m going to try one or two on a local HA configuration thank to my Zwave usb stick to see if that helps.

Last I checked the debounce was working great. I’ll have to look into it. Now, are you actually seeing the lights turn on and then off (double toggle), or are you just noticing the multiple button presses in the notification feed? The presses will still show up, but they shouldn’t be processed.

My sc7s have not been very functional. They repeat the command 9 times out of ten but the debounce doesn’t pick it up. The timestamps often indicate the exact same time. On a different note I changed Rule Machine triggers to button held and there is almost zero lag on the actions. It still suffers from the repeat problem but only maybe one out of three presses.

1 Like

@SirAce135 Alright, so I did some testing tonight. Here are my observations:

  1. SmartThings latency is extremely high. The time between button press, to device handler, to event, to SmartApp, and then back down to devices is way above what it should (used to) be. This is most likely the cause of the problem you are seeing.
  2. I had a very difficult time getting duplicate presses. 1 in 50 I would say. It used to be a lot higher for me with the same Scene controller. I’m not sure why this is different now.
  3. On the double button presses that I did witness, the time between when the SmartApp received the events was extremely high. One was 6 seconds and one was 7 seconds. This is ultimately caused by observation number 1. Debounce was set to 3 seconds, so the app obviously missed these. I had one duplicate that was spaced out by 2 seconds and the debounce caught it.
  4. I simulated double button presses by pressing the same button twice in a row at different speeds. All of the events that were processed in the debounce time limit got caught. This seems to be working.

So, my conclusion is observation 1. You can try turning debounce up way high or hope that SmartThings can do something with the latency on their end. Or, we could really try to get this SmartApp and Device Handler to run locally. That would really help this device out.

If you want something more reliable that looks good on a wall you can get a Remotec button controller:


Hey guys,

I’m actually running into a similar, but maybe related, issue. I have two controllers running ~well. I’ve been experiencing the high latency and debounce issues that others have mentioned lately, but the controllers are still somewhat usable.

I installed another controller (the third) and added it to SmartThings. The issue I’m experiencing is that I cannot associate it with the Scene Controller app. It ONLY gives me the option of associating it with the crap SmartThings Button Controller smart app.

In the graph the controller is recongnized as the correct type. Is there a way to manually force the SmartApp association? Thanks!


@mattjfrank I’ve installed the device type and the smart app. I followed your instructions from one of the first posts. I add the device, launch live logging then hit configure. It will not register all 7 buttons. It is only registering one. These are the log messages:

f9f9c61b-b028-472a-a176-132f1f7a0b8f 7:12:55 PM: debug Parsing 'zw device: 0B, command: 7205, payload: 01 1A 08 01 0B 03 ' f9f9c61b-b028-472a-a176-132f1f7a0b8f 7:12:54 PM: debug Sending configuration: [7204, delay 100, 8505, delay 100, 2D01010100, delay 100, 2D01020200, delay 100, 2D01030300, delay 100, 2D01040400, delay 100, 2D01050500, delay 100, 2D01060600, delay 100, 2D01070700, delay 100]

Any idea on how I can get it to register all 7-buttons?


[EDIT] Seem to have gotten it working. After excluding everything, I had to kill the power at the breaker. Let it sit for a few then powered it back on. At that point it was truly excluded. I re-included it and it appears to be working!

Can anybody explain this in a way those of with lower IQ’s can understand?

Where do I past the copied code? I followed the link and got the “raw” code from GitHub but I have no idea where to past the code in the “create new device handler screen”.

This should help:


Once again, thanks JDR. I hope ST is paying you for all the help you give on this forum. I’m the guy that needs a picture of the screen he’s looking along with what you’re supposed to click on circled. Anyways, I got it installed and up and running.

In the mobile app, it shows which button is pressed (1-7) and teams up with smart lighting but the lights I have selected it to control don’t respond even though the app shows changes in which buttons are pressed. In other words, the hub is receiving/acknowledging the commands from the switch but for some reason isn’t sending out the signal to what I want to control.

I’ll figure it out but again, thanks!

When I go to pair up the smartapp with the device I get the message “an unexpected error occurred”.

So yeah, no dice. Can’t pair the smartapp with the device. Just get the error message and no option to add it during the setup process. Smartthings must have changed something during their updates.

Mine no longer works. I don’t know why exactly but don’t have the time or gumption to fix it right now until SmartThings gets more stable.

1 Like

Ok, so here it is on my computer screen. Shows the ap assigned to it.

Here it is in the mobile ap, responding to button pushes.

Here is the mobile ap screen where you would assign the ap to the device.

After that screen, it takes you to the next screen which is where I guess you would assign buttons to scenes. In that screen I get the infamous “an expected error has occurred”. It acts like the ap hasn’t been assigned to the device but when looking on my computer (as shown in the first pic) it has.

I tried reloading/re-pairing it 3 times with no luck. Pushing configure in the mobile ap wasn’t necessary and never did anything when I tried.

Lame. I got a good deal on these switches. I hope I can get them working.

In smart lighting it lets me assign the device’s buttons to devices but when you push the buttons nothing happens even though the hub is registering the presses.

When looking in the device screen and then looking in the device screen at which smart apps had been assigned to the device, it showed it as being assigned to the ap but then it disappeared.

Alright, I guess that means this device doesn’t work with Smartthings.

What’s going on over here? Yeah these work, sorry haven’t been keeping up on this thread. Lemme read your messages and I’ll see if I can offer some additional advice.

1 Like

So you have the DTH working it looks like, and this is just an issue with the SmartApp. You are using the one linked in step 5a of post 4 up top of this thread right? Does it say Published in the IDE:

If not, click publish, if so, go back to github, click raw, copy paste the whole thing back over top of the SmartApp in the IDE, resave and publish.

Then kill the ST app on your phone and fire it back up. As in go to settings apps, find it and kill it, not just close it. Tap contoller, tap the already (I presume) selected device, it will deselect it and go red, go back in and reselct it, then hit next, see if the error occurs again.

Also, when you did step 3, did the logging as indicated in step 4 show the 7 buttons getting stored? It’s absolutely crucial that works before moving forward, I went rounds with that and had to repair all three of mine more than a few times each to eventually get that to work.

Good luck!

Yes, published and in my apps.

When I go to the step where you would link the app with the 7 buttons, I get the message “an unexpected error has occurred”.

Ok, so back up a bit. No, I never see 7 buttons getting “stored”. What does that look like? As you can see in the logging, the hub acknowledges presses from all 7 buttons. Is there something else that should have happened that would have told me that all seven buttons are stored?

Thanks for the good luck wish, I need it and I appreciate you responding to my post.

Look at post 254. Bruce showed his log for what you should see. If you don’t get exactly what he did the second time in that post, nothing will work right.

Logs, shows 7 buttons stored.

Go into my aps, select ap.

After selecting which switch, you come to this screen where you can set the debounce time. No changes made by me. Now after selecting done you come to the screen below.

And in the above screen, it’s not showing because the message disappears when I swipe my hand to do a screen capture but I get “Sorry, an expected error has occurred”

A couple times, you could go into the switch screen and see the ap paired with the switch but then it will all of a sudden disappear. I tried copying and redoing the code etc etc. I would think if the ap and device manager weren’t installed properly that I wouldn’t have reached this far?

It doesn’t seem to me that It can be a faulty switch if it’s registering button presses.

I’m at a loss. It’s probably something easy but you know…

Well…um…out of ideas. Didn’t take long did it?

Oh did you do a z-wave repair after that, then try the app again?

This looks like a SmartApp issue and not the hardware but tbh I’m not really sure.

@erocm1231 or @mattjfrank or @JDRoberts have any thoughts?