[OBSOLETE ] Virtual Presence Sensor

Ah, I see. It works if I use the on/off capability. If I switch it to presence capability, it vanishes once I save and re-open it.

1 Like

I’m not sure of all the details, but I know engineering has acknowledged there is a problem. It may only be certain operating systems or exactly how you’re using it, but it is an ongoing problem.

This is the sort of thing we really need to know more about to allow ourselves to avoid the problem.

The descriptions we’ve had of Automations and Rules make it sound like Automations are saved as Rules and then mapped back. That sounds like an unnecessary complication to me. Doing it one way sounds fiddly enough but at least it can be a one to one mapping. Backwards it can be many to one. Hopefully I’ve got the wrong end of the stick.

1 Like

The latest SmartThings app allows the use of “Member location” (i.e. phone’s presence or absence) as an IF condition in the “Add routine” menu without custom device handlers.

See the instructions here.

Ralph,

What does the location-mode DTH do? Is it necessary to install along with the virtual presence sensor handler?

You may want to check out an Edge Presence sensor at this point (if your hub supports Edge). Groovy device handlers will be phased out at some point in the future.

Thanks jkp. How exactly do I invoke the Edge Driver for the Presence Sensor? I afraid that I am not to versed in doing this.

As far as whether my hub supports Edge Drivers, based on reading the Q&A concerning the first rollout of drivers, it need to be above a specified firmware version. My firmware version is 000.042.00007

When I tap on the ellipsis on my hub, the dropdown menu lists “Driver”. When I click on “driver” it list several drivers which appear to be installed on my hub. Included in the list is Zigbee Presence Sensor, 5 other Zigbee sensors, 5 Z-Wave sensors, - Virtual Devices. It also states that my hub is registered to the channel “TAustin Shared Projects” and "SmartThings Drivers (Beta) is also listed.

@Buds_Smart_Home

No you don’t need the location-mode to use the virtual presence sensor.
What it does though, is give you a tile in SmartThings that shows what location state SmartThings is in, such as Away, Home, Sleep, etc.

Thank you Ralph. I appreciate the guidance and the quick response :slightly_smiling_face:

Hi there - You’ll need to go to the channel invite for my channel (which sounds like you are already enrolled in) and chose to install the Virtual Devices V2 driver to your hub. It may take a little time to get installed, but once it is, the next time you perform an Add-device / Scan nearby devices from your mobile app, you’ll get a new device added in your ‘No room assigned’ room called vEdge Creator. You can then use this new creator device to create whatever types of virtual devices you are interested in.

1 Like

I just tried installing Virtual Devices V2 and I got an error: Request failed with status code 400.

Any ideas?

Hi, thanks for reporting that. Can you provide a bit more information: when exactly did you encounter this error? Did the creator device get created? Was this error when you were trying to create a virtual device? Which one?

Sorry for the lack of detail.

I just enrolled and went to available drivers and tried to install Virtual Devices V2. That’s when I get the error. I hope that helps.

  • Jeff

So you saw this error on the website? An http 400 error would indicate something went wrong with the SmartThings channel enrollment website. Did you try again a little later?

If that keeps happening you may need to report to SmartThings, since they control that process.

Right. I clicked on your channel invite link above, enrolled, and then tried to install. That’s when I get the error.

I just tried again and am still getting the error. I’ll try again tomorrow and see if it’s just a temporary issue.

Yea, that’s a strange one. Usually web page glitches sort themselves eventually, but if it doesn’t I would report it to @nayelyz

@nayelyz - It looks like there is an issue of some sort that I could use your help with…

I’m trying to install @TAustin Virtual Devices V2 using the channel invite link above (SmartThings. Add a little smartness to your things.). My account is associated with two different hub accounts, so that may possibly be causing the issue, however the one I have a problem with is the one that I own. Ironically I was able to successfully install on the other account for which I am just a member.

Here’s what I’m doing… I click on the channel invite link, accept the terms, then enroll. All is good so far. Then when I go to available drivers and click on Install for the Virtual Devices V2, I immediately get an error: Request failed with status code 400.

When I look in the debug console it looks like it’s failing to find a resource (logo192.png). Here’s a screen shot of the console:

Any thought on what might be causing the issue or steps to try next?

Thanks!
Jeff

Hi!
Yes, there’s a request to provide more info in the errors that are shown in that page.
For now, we need to check the error message from the ST CLI , have you use it before?

Once you enroll in a channel, you can install the available drivers there. Here’s an example:

Generally, this happens because your Hub doesn’t support drivers yet (Wi-Fi or Samsung Connect Home Hubs) or you have reached the limit of drivers installed (50).

I just installed the new beta because I had a really old version that didn’t support the edge commands. Anyway, there’s probably another step I’m missing to authenticate because this is what I’m getting.

Ooh, when you execute this code, do you see a web page where it’s asking you for authorization?
As you mentioned you had an old version that didn’t recognize Edge commands, it makes me think that you’re using the “manual” authorization which consists in using a Personal Access Token in a local file (specified here). If so, please change the file name to something like config_backup.yaml to trigger the automatic authorization.

1 Like