[OBSOLETE] Sonoff, Sonoff TH, S20, Dual, 4CH, POW, & Touch Device Handler & SmartApp ($5 & $10 Smart Switches)

Thats something totally different. I have newer have problem to set up Sonoff Basic that way. I have 19 of them, but with Sonoff 4CH Pro its not that easy, because as I sad i miss the lines for ip-address and port and user and password. It is there with Sonoff Basic, but not with Sonoff 4CH Pro R2. And that is missing in the Device handler. I am not a programmer, so I can do it myself. So please help me here.

@MacRoy The device handler in this post is meant to be used with the Sonoff Connect app (also in this post). The Connect app finds the device, adds it to SmartThings, and keeps track of it incase of an ip address change.

It sounds like you have the Tamota firmware which probably won’t work with the code in this thread, but some people have referenced other threads that may work.

1 Like

Hi erocm1231.

Thanks for you’re reply. So you mean that if I flash it with Sonoff instead of Tasmota, it should work?

Best regards

Thought you might try this process…go to message 23. Should work for all Tasmota devices.

Any chance that support for the Si7021 temp/hum sensor could be added to the DH for Sonoff TH or is this a limitation of the firmware?

Actually integration with hithub in Europe works, but it must be enabled.

@erocm1231 is it possible to change wifi settings (network and password) in an already configured device?

1 Like

Yes, easiest way is likely turning it on with your normal network not present and it will eventually offer the configuration network again (unless you have disabled that feature). Alternatively press and hold the button for a long time, I think 30 seconds or so.

1 Like

Sorry for a question counter to the purpose of the thread but, I’d like to restore the original firmware to my Sonoff POWR2.

I successfully flashed with this firmware and am able to interact with the switch via the http command page , but I only realised after I’d done this that I need the ST hub to really do anything (I have other ST devices but they don’t need the hub). So I really want to reverse this misstep.

I’ve found a site which hosts the original Sonoff firmware binaries and I’ve tried flashing these to no avail, using the ESP tool, among others but have had no luck. I’ve also tried to use the http firmware update function of the firmware in this thread, but this also fails. Each time, I’ve just reflashed the firmware from this thread, to at least be able to interact with the switch.

Can anyone tell me how to return the switch to its original state?

thanks in advance.


Have you tried to use this tool? https://github.com/tasmota/tasmotizer

It works perfectly for this.


I found sometimes you have to flash with a blank file to clear all memory. Do a search for blank.bin. I thought I bricked a unit and was able to get it back by flashing with blank first.

Hello all,

I have an issue with Sonoff TX switches and smartthings app. Smartthings not updating the status of the switch , if I use physical button to switch the light on or off in classic app the status is the same. Before everything was working fine , after few seconds status was updated.
I have tried to update tasmota but its the same. I am using arocm firmware and device handler.

Any sugestions?

The IP address on your SmartThings hub may have changed. You can set a static DHCP reservation for it and change the setting in the Sonoff to point to that IP address.


Thank you for the reply, I have static IP for hub also I have checked all settings for each sonoff device and everything is fine. I have 12 switches at home and only 2 are showing the status in the app.

@erocm1231 (or anyone else) would you happen to know why my Sonoff TH is showing unavailable in the ST app device list, but when I click on it, it’s correctly showing the temperature and can be switched on/off normally?

This might actually also be a problem where the SmartThings hub ip changed. If you are using the classic app you can hit the “Configure” button to update the ip on the device. You can also go to the device web interface and check the SmartThings hub ip address in the advanced settings.

I tried the Config button, but that didn’t seem to do anything. Where would I see the SmartThings IP address in the advanced settings? I see a “HA Controller IP”

Eric M
Community Master

    April 9

This might actually also be a problem where the SmartThings hub ip changed. If you are using the classic app you can hit the “Configure” button to update the ip on the device. You can also go to the device web interface and check the SmartThings hub ip address in the advanced settings.

That is it. There is also a port number that should be 39500 I believe.

Hi Guys, i would like to share with you:

Today i flashed over the air with SonOTA my first device with sonoff-pow-wifi-switch.bin and works right.

Am using Grafana and InfluxDB to do graphs of sonoff pow variables, but on data base are only recorded power and voltage.

Question: why amperage are not available on database?

And voltage is wrong value, alway something like 4294967296.

Thanks in advance.

Sonoff wifi and mobile presence sensor (up to 10 presence sensors managed)

First, I want to say thanks to Eric and all the other contributors, I have managed to build myself something useful from all this, I had help from my son also.

This project repurposes a Sonoff to detect the connection of up to 10 Wi-Fi enabled devices to your home router, without adding any other software/ Apps (not even SmartThings) to your mobile device. It also provides a solution for those that have a mobile that doesn’t work with SmartThings native mobile presence.

Additionally the Sonoff can still be used as a remote switch with a few improvements on the way.

The project instructions, device handler and the Smart App you are going to need are in my GitHub here: https://github.com/LeeC77/SmartThingsPublic

You will also need to use my updated version of Eric’s Sonoff-connect Service Manager also on my Git Hub.

Here is a screen shot to give you a taste.