[OBSOLETE] SmartThings Controls X10 Switch -- Demo

Here’s a preview of my X10 integration with SmartThings:

1 Like

Wait a minute… you’re doing this just via the transceiver?! No PLM.

Yes, I am confused as well. What are you using to send commands to the X-10 system?

I use CM19A RF transceiver to send commands to TM751 shown in the demo, but it will also work with CM15A which can send X10 power line commands directly.


1 Like

So SmartThings is connecting to this via a PC or other device communicating with USB?

Throw us a bone here.

Yes, you got it :smile: I’m using Mochad X10 gateway running on a Linux box.

LOL… I am not sure I would describe that as an x10/SmartThings integration, but I would like to see an example of your call to sendHubCommand. Specifically if a string like the one below could be received (note the trailing return).


Why not? SmartThings uses gateways to talk to many things, for example Nest, WeMo, DCS alarm panels, etc. Those are not “integrations”? What about IFTTT?

1 Like

I meant no offense; I would just categorize it as a bridge.

Now what about an example of that TCP call to sendHubCommand? (c;

None taken :slight_smile: Yes, it is a bridge (the is literally called “X10 Bridge”). And a bridge is a legitimate way of integrating two systems. :smile:

WRT your example, I don’t see a problem as long as it’s ASCII. The mochad command has a terminating carriage return and it works. I have not tried sending binary data yet though.

Oh… and one more thought. Have you tried terminating your command with '\r\n'? Some servers are very picky about line termination.

yes… this is working to Global Cache iTach gateway:

sendHubCommand(new physicalgraph.device.HubAction("""$theCommandString\r\nHOST: $ip\r\n\r\n""", physicalgraph.device.Protocol.LAN, "${deviceNetworkId}"))

Sweet! I hoped it would. :slight_smile: Now, correct me if I’m wrong, but I don’t the "HOST: ..." is part of the iTach protocol. Why do you need it there?

Cause I am specifying the ip:port there and not in deviceNetworkId? I figured out what I am using via the braille method.

So what’s wrong with deviceNetworkId? You pass it in the third argument anyway. It works for me.

I am passing ‘1234’ with it (meaningless). I was under the impression sendHubCommand required that param (even if it was nonsense), but after testing I see that it isn’t (lot of misinfo floating about).

I just didn’t want to bother with the hex conversion, however I will when I build my multi-A/V system device type. (c;

That’s fine, but I believe that “HOST: …” is being sent to iTach, which may be harmless in this particular case, but is generally undesirable.

Yeah… NC is showing it is. Ok… I’ll pull that and use deviceNetworkId.

So how are you specifying a port? In the DNI or the ip var?

I was setting ip to “”. It has always worked, but I was always sending to an http server. So now I’ll just pop ‘0A000029:1386’ into the DNI and lose the HOST param.

Seems to work fine.