[OBSOLETE] SHM Delay Version 2.0

Suggest turning on the Global “Mode Fix when system armed from Non-Keypad Source” to On if not already On (default), then update the Mode Fix Settings profile.

This app is stabilized as I have mostly moved to the Hubitat platform, however if you provide the module and line where you feel there is an issue, I will take a look.

hi @arnb,

Thank you for the reply. Sorry for the delay. I’m just getting into the ST universe and taking in a lot of information and learning some coding. I’ll dig in deeper and try to narrow it down to where I think the issue may be. What I’ve done to date is uncomment out some of the existing debug lines you had in there and then was following along in Live Logging and reading the code. When I started seeing more messages around the Mode Fix logic I admittedly got lost but thought I’d turn it off to see if it made a difference and sure enough it did.

It may take me a few more days before I have something more but I appreciate you willing to take a look.


I’m trying to setup some kind of beep/sound/something for my entry delay but I just can’t figure out what the steps are for using Lannouncer. I have lannouncer installed on my tablet and its set to auto start. But when I bring up the LanNouncer/DLNA list in SHM Delay, only my Amazon Echo’s show up. What do I need to do to make my tablet show up as an option as well?

The tablet must be added as a Lannouncer Alerter device

Should you be using an Amazon tablet, be aware that while Lannouncer is a good product, it does not play happily with the Amazon OS. Should you also be running the Fully Browser take a look at the Fully Kiosk Browser Controller.

Thank you. I am using a Fire HD Tablet. I got it added as a LANnouncer Alerter and added it to my SMH Delay. I now get chimes but no voice messages. Is that the issue with FireOS?

Have you setup and installed the Talker module and profile?

Yes. I created a test device to my Samsung tablet and i got entry speech, although no exit speech. Only got the chimes on my 9th gen Fire HD 7.

Hey Guys, Apologies for the silly question
@arnb - When setting this up i can only choose real contact sensors . None of my Konnected motion sensors are available. Is this app only intended to work with contact sensors?
Apologies for the n00b question. Still learning over here in Aus :slight_smile:

Installed new sensors to ST. Tried to add them to SHM delay but it gives “error bad state”. Unable to complete page configuration". Can’t also modify configuration with old sensors that are already insalled to SHM delay. What’s up with this?

EDIT. it’s not SHM Delay problem. IDE gives internal server error 500. So something is fu**** up in ST.

Konnected contact sensors are supported, however you may have to force them using the “When Real Contact Sensor is rejected as simulated” setting.

If they do not show in the selection list, perhaps a Konnected expert can help.

Thank you for your scripts these work perfectly!!

1 Like


Using the SHM 2.0 delay with KeyPad centralite 3400-c.

Using DeviceHandler for the keypad: Mitch Pond

It works perfect if I disarm on the keypad, then the entry beeps stops.

My problem is that the entry beeps dont stop after the SHM is disarmed. Just keep beeping until my EntryDelay time is gone.
I disarm my system with a routine, also they keypad gets disarmed, but continues to beep.

Have tried rboy Intruder with action, and the same problem.
Looks like the keypad device handler could be the problem?

Any great solutions?



My gut feeling is: keypad hardware (or firmware) issue.

However, before passing judgement try this:

  1. Using the app’s standard driver
  2. In the phone app go to My Home, select the device
  3. Click the top right gear icon
  4. Set “enter length of beeps in seconds” to 30 (usually set to 1), save it
  5. Tap Beep Icon, device should start beeping
  6. Tap Off icon, device should stop before 30 seconds. If not it’s a device hardware (or firmware) failure. No way to update the firmware AFAIK.
  7. Reset 'length of beeps in seconds" to 1


I’ve got most of this working now, but I don’t know if I’m missing something. Can it be set to have a delay when a motion sensor is triggered when in Stay Mode? If we are at home at night then we will trigger one or two motion sensors before we can get to the Amazon Fire tablet in the hall, so a 30 second delay and beep/TTS message would allow us to disarm using the tablet. Obviously, we will not be opening the front door, so can’t use the delay from that happening.

Apologies if this has been asked before!

Thanks, Neil

In Stay mode, motion sensors are controlled only by Smart Home Monitor’s Armed (Stay) Intrusion Sensor settings.

Generally in Stay mode, motion sensors in locations where traffic is expected during the night, such as a bathroom, are excluded from intrusion monitoring. SHM Delay does not have any settings that change this behavior.

OK, thanks for clarifying.

Under Entry and Exit Data I have the Alarm entry delay set to 30 seconds, but there is no delay before the alarm goes off after I open a door. Is there a setting somewhere else that I need to have set for the delay to work?

Usually this is caused by not removing the contact senor and optional motion sensors from Smart Home Monitor. If SHM is correctly set according to the documentation at the top of this thread, then try re-saving the delay profile.

Should neither of these suggestions clear this issue, please verify the intrusion is not caused by a motion sensor. When using standard Global Settings the device triggering the intrusion is found in a notifications log.

It is the motion sensor that is triggering the alarm. I can’t get to my tablet to disarm the system without passing a motion sensor. Is there any way for the 30 second delay to also apply to the motion sensor? Could I make a simulated sensor like I did for the door?

This is specified in detail in the documentation, Paragraphs 16 and 17!

Add the motion sensor to the delay profile, remove from SHM. No additional dummy device needed. When a motion sensor is specified in multiple delay profiles turn on Global “I have same motion sensor defined…in other delay profiles”