[OBSOLETE] SHM Delay TrueExit - Create a SmartHome True Exit Delay

I have shm delay published, shm delay child, and shm delay modefix both unpublished. I install smart app set only one contact on my desk at moment to app plus the virtual contact. . all as per your instructions, there are no device handlers needed using tablet to arm disarm . .but all I get is the system arms but even after the 5 secs delay in your app the contact will not trigger . .what is wrong?

You published in the shm true exit forum so I can only assume you’re using it.This app is designed to create a true exit delay only, using two ST routines.

Please check your SHM Delay settings and verify that you have created a shm delay profile, and added the simulated contact sensor to smart home monitor.

When this is completed please follow the instructions for testing your system at the beginning of the shm delay V2 forum

Hi, I installed your TrueExit app and it worked first time. However since then, it sometimes works when I activate the delay routine otherwise it does not trigger the routine to arm the SHM. Any help would be appreciated.

Assuming you are using the Classic app, have properly setup the dummy routine, renamed or created the secondary target routine that works as expected, Please try the following:

  1. Log into the IDE
  2. Start Live Logging
  3. execute the dummy routine
  4. wait for second routine to execute
  5. post any errors. The log also has debugging info that should verify proper execution
1 Like

I enabled the logging and there were no errors.
Not sure what caused the issue, but after not using the True Exit Delay for a day or 2 it is now working.
I will monitor and post any logs I find with error.

1 Like

The only errors I found were happening independently of the TrueExit:

52527570-8d1b-b9c5-c67b-55efe40547d9 10:07:54 PM: error groovy.lang.MissingPropertyException: No such property: throwable for class: physicalgraph.scheduling.AsyncResponse @line 147 (getInitialSpeedsHandler)
52527570-8d1b-b9c5-c67b-55efe40547d9 10:07:54 PM: debug in getInitialSpeedsHandler() method
52527570-8d1b-b9c5-c67b-55efe40547d9 10:07:34 PM: debug getInitialSpeeds called()
52527570-8d1b-b9c5-c67b-55efe40547d9 9:57:54 PM: error groovy.lang.MissingPropertyException: No such property: throwable for class: physicalgraph.scheduling.AsyncResponse @line 147 (getInitialSpeedsHandler)
52527570-8d1b-b9c5-c67b-55efe40547d9 9:57:54 PM: debug in getInitialSpeedsHandler() method
52527570-8d1b-b9c5-c67b-55efe40547d9 9:57:34 PM: debug getInitialSpeeds called()

Also, the TrueExit did not work again today - after having 2 successfull days of running. It was interesting that after running the delay routine it did not fire the Goodbye routine. When I ran the delay routine a second time it did fire the Goodbye routine. Perhaps this is due to the delay being too short (20 seconds) and a possible lag in smartthings causing the runonce to have lapsed?

Unfortunately I feel you are correct about the Smarthings Cloud having timing lags and occasional total amnesia.

For example: In Away mode I have a a siren chirp about 2 seconds after a monitored door opens. Yesterday about 15 seconds after disarming my system while I walked past the 105DB siren, it chirped, causing me to jump a few feet.

Have been looking at the logs.

When it is not working all that is logged is this:
1cd70cb5-b635-4a2e-a1b6-c2aba62088e6 9:56:37 AM: info HH execute(true, null, null), newMode: null

i.e. there is no “triggering a delay routine execute” or “firing target routine”

Even though there is a notification on the phone app to say the armed delay routine was executed, the execution is not entering the “routineHandler” (I uncommented some of the debug statements before the “if (evt.name == “routineExecuted” && evt.displayName == monitor_routine)” to prove this).

So the app works fine for about 3 times and then it stops getting into the “routineHandler”

When this happens, if I click the armed delay twice it seems to start up again on the second click of armed delay.

Why the routine does not trigger is something beyond my understanding, and I doubt using the Classic app you will get much of an answer from support, but that is a suggestion.

The next time this displays, please click on “1cd70cb5-b635-4a2e-a1b6-c2aba62088e6”. This will highlight issuing the app or device, hopefully pointing to something that can be helpful. However, newMode: null seems flatout wrong and may be the cause of the failure.

Hi,I’ve been trying to use the SHM Delay and TrueExit and have a few problems:

  1. Using Delay, I have a door contact sensor on the front door and a motion sensor in the hall with an Android panel in the hall. I want to delay the setting of the alarm when leaving or arriving. The delay seems to be OK, but it isn’t monitoring the hall?

  2. I’ve tried adding LANnouncer but it doesn’t seem to be working in SHM Delay? UPDATE: I found the section about LANnouncer not working when using Fully and Actiontiles on an Android tablet, so have changed this to the FullyTTS and BigTalker2 but still nothing sounding in SHMDelay.

  3. I’ve tried TrueExit instead to see if I can get that working. It seems to work fine including playing the announcement on LANnouncer/BigTalker2, but I only have the option of creating one delay. I’d like one for Good Bye, Good Night and I’m back to allow for getting in and out of the house?

I’m sure I should be able to sort these things out myself!

Thanks Neil

On entry delay should the motion sensor be activated when entering the home, it must be added to the Delay Profile and removed from Smart Home Monitor. Since the keypad provides a real exit delay, motion sensors are not monitored until the system is armed in Away mode

Is the SHM Delay Talker module installed and a Talker Profile created? SHM Delay does not use or need Big Talker, although it may be used and should happily coexist. When using any output speech device make sure it works before attempting to use it with any Smartapp

When using a keypad the True Exit module is superfluous and should be removed, the keypad provides a real exit delay.

The SHM Delay documentation has complete and detailed setup and testing information.


My profile is below. Front Door motion is removed from SHM open/closed sensors and Delayed Simulated sensor used instead. Hall is removed from the Motion Sensor in SHM.

I don’t have a keypad, just a Amazon Fire tablet, so I’m not sure whether I need the True Exit or whether everything I want should be achievable with just SHM Delay?

SHM Delay Talker module is installed and a Talker Profile created. I didn’t use BigTalker initially I just used FullyTTS, but that didn’t play the chime sound either. FullyTTS and BigTalker seem to work on their own OK.

I’ve been through the documentation several times and it is very thorough, but I can’t work out why these parts aren’t working?

Sorry, I’m sure I must have missed something obvious!



True Exit is not necessary, SHM Delay should work with or without a keypad.

Lannouncer has built in sound files, including chimes. To get chimes with the Fully Kiosk Controller app, a sound file must be placed onto the tablet as explained in the documentation, then tested to be functional prior to attempting to use it with SHM Delay Talker.

Moving away from my sole Iris keypad and putting tablets near each door and discovered the need for your TrueExit app. Core SHM Delay doesn’t work (at least I am missing it) with the door locks. As soon as I hit the actual Goodbye routine it locks the door. Issue I am seeing is that there are times it never fires the actual Goodbye routine, and if it does it is never close to the time set. Below are some logs I pulled based on what you asked previously in this thread. This one it fired the Goodbye routine, I just tested it again and its been four minutes and it still hasn’t fired it. Any thoughts are greatly appreciated.

For my “delay” profile
8:31:56 PM: info HH execute(true, null, null), newMode: null

SHM Delay TrueExit
8:33:03 PM: error java.lang.reflect.UndeclaredThrowableException @line 134 (execute)
8:32:11 PM: debug firing target routine Goodbye!
8:31:56 PM: debug triggering a delay routine execute
8:31:56 PM: debug triggering a delay routine execute

The likely issue is whatever is coded at line 134 in your version of TrueExit. Version 1.0.2, Jul 04, 2018, shows line 134 as a comment.

Thats unfortunate to read. I’ve been trying to get it running with my Fully and Actiontiles setup. What did you end up doing instead?

I have a need to make the delay longer than 120 seconds. Can I extend that time by changing lines 66 and 67 or is it more complicated then that?

Yes it’s simple, change 120 to whatever you want

Can you utilize SHM Delay True Exit by itself, or does SHM Delay have to be installed also?
Thanks, J.Knox

It works by itself. However it uses the now deprecated Classic routines. If you already have routines you should be OK,