[OBSOLETE] Remotec ZRC-90 Scene Master - Button Device Supporting 24 Unique Button Commands (see post 177 for 2021 app version)

OK, I really don’t understand what do do about this. In the SmartThings app, adding a SmartApp only has the standard Button Controller app. How do I find/pick another button controller app that can control 8 buttons?

This is my First Post. I’ve used X10/Insteon in the past, but, am just discovering the AMAZING ecosystem of smartthings. Wow!!!

Up to this point, I’ve done some very basic things, such as

  • Setup the hub
  • Connect and properly interact with relatively basic things like
  1. Smartthings-branded Multi-Purpose Sensors
  2. Smartthings-branded Motion Sensors
  3. Smartthings-branded Plug in Outlet
  4. Kwikset ZWave Smart door locks

This ZRC-90 was my first device that, as I understand it, needed two additional steps beyond the Inclusion/Pairing/Adding step. So, I thought I’d explain the steps I took to get it operational for other noobs.

  1. Add the ZRC-90 to your house
    In the mobile SmartThings app on the phone, go to “My Home”-Things (I’m using the Android app, so maybe iOS/Apple is different?)
    Click "Add a Thing"
    On the ZRC-90, hit the “L” button which is near the batteries
    It should be found and then added to your list of things. Rename it if you want.
  2. Add the device type handler kindly written by @erocm1231 to your house
    The howto for adding device type handlers AND smartapps can be found above, titled “FAQ: An Overview of Using Custom Code in SmartThings” (I’d have included the link again here, but, as a Noob poster, I’m only permitted two URLs per post)
    At this step, you will want to following the section for adding a device type handler, “USING A CUSTOM DEVICE TYPE HANDLER”, (though you should read that entire post to absorb and understand what’s there).
    At the “DT1) Copy the code from the author” step, the code can be obtained from here
  3. Change the ZRC-90 “thing” to use the just installed device type handler
    You should be still logged into the IDE from the last step. Go to “My Devices”-click on the device
    Scroll to the bottom and click "Edit"
    In the “Type” box, select "Remotec ZRC-90 Scene Master"
    Click “Update”
  4. Add the “Button Controller - Enhanced Lighting” SmartApp also kindly written by @erocm1231 to your pool of available SmartApps
    Now that you have the Device Type Handler installed, you can’t do much with it (as far as my experience goes), until you add a SmartApp to allow for Configuring/Using the device.
    Return to the howto above for adding device type handlers and smartapps
    This time, you will want to follow the section for adding a “Custom SmartApp”.
    The code for the “Button Controller - Enhanced Lighting” SmartApp can be found here
  5. Next, add the SmartApp to the ZRC-90
    Now that you’ve added the SmartApp to the house, you want to have the ZRC-90 use it.
    In your mobile app, Click Automation-SmartApps-Add a SmartApp
    Scroll to the Bottom and click “My Apps”
    “Button Controller-Enhanced Lighting” should be an option. Click on it.

You should be good to go from here.

2 Likes

You can also use the SmartThings recommended “Smart Lights” SmartApp that will let you use a button devices to trigger lighting.

1 Like

Thanks! The “Smart Lights” SmartApp is just what I needed and works great.

1 Like

Thanks for this summary and thanks to erocm1231 for the DH and Smartapps.

This works great!.

One question - sometimes the button presses don’t seem to register or there is significant lag.

I guess this is the downside of using Z wave technology?

KR,
Sanushan

I have never had a button press not register on this device. There is a little bit of lag which is caused by a couple things. The first being that the device has a timeout that it waits for to see if the user is going to do a double press or a press and hold. I’m not sure what this is, but it may be a second or two.

The second is that SmartThings relies a lot on its cloud infrastructure . . . which can be slow at times.

Unfortunately, there isn’t anything that can be done about those two things.

Hi Eric,

I went into the button controller and made a few tweaks in “advanced” which seems to have brought the lag right down on most of my smart bulbs. They don’t all go off at once which is odd but not a big issue.

Thanks for your help!

1 Like

Thanks so much for the step by step instructions. I was overwhelmed by level of detail being discussed on this thread. Oddly, I could not select the ZRC-90 under the default marketplace /lights and switches /smart lights until after I created the custom smartapp…I then went back on a whim and could then select the ZRC-90 under buttons. thanks again

Thought I’d share my little project I completed for this to control my zigbee in canopy fan controller. I used the label printer at work to make button labels, which I clear coated. l Can share more details if anyone would like.

3 Likes

That is cool
I like the idea… Might get a bit of WAF
:grin:

Very cool, I’m definitely interested in having more details

Icons HERE

I took the remote completely apart, but probably isn’t required. The buttons are just glued to the rubber pad underneath. They can probably be carefully pried off without taking it apart. I printed the icons, placed them, then trimmed with an razer, then super glued them back on.

Most of the buttons are just toggles, except the timer and power.

1 Like

Excellent, thanks for the details :slight_smile:

1 Like

Big thanks to @erocm1231 for this DTH. Just got one this weekend and it works perfectly.
I updated my Advanced Button Controller app with icons and usage details for this controller as well.

1 Like

Which label printer and where did you find the images?

Images:

1 Like

Made the images from the device handler from him ^ they’re linked in my above post. Label printer is a Primera color label printer 400.

Yes how did you do this?

That is one very expensive label printer.

It is! I didn’t pay for it lol