[OBSOLETE] Iris Smart Plug (3210-L) Zigbee Plug with Z-wave Repeater

I missed that somehow.

Thank you for showing me where that information is.

Seems to be graphing great now, didn’t set it back to the SmartThings device type, just left as the Iris modified one. Been graphing great since I reset it last night, don’t even have Pollster refreshing it:

And here’s the SmartThings one for comparison:

I figured out that when I first added the outlet it was before I had created the custom devicetype for it. When you add it using the devicetype it sets up the energy usage properly.

sorry i am new to the forums… i have created and published the device handler in the first post. i was able to pair the zwave portion no problem. however i can not get it to find the zigbee switch. i have tried to reset the switch, reset the hub, reset the mobile app and nada. anything i am missing? i have it within inches of the hub as well. any help or suggestions are appreciated.


In order to reset the switch, hold the button on the front while plugging in the module. Don’t let go of the button until the light comes on. Once the light starts blinking, the zigbee switch will be in pairing mode. At that point you can “Configure new device” on the ST app and it should find it. You won’t need to re-pair the z-wave repeater as it shouldn’t have been reset.

1 Like

I did try holding the button while plugging it in. The led will turn on then off. But it doesn’t constantly blink. I have gotten the led to blink after its already been plugged in and pushing the buttons many times. This is when the hub finds it as a zwave device. Does your blink constitanly when you unplug and hold the button down as you plug in? Or is it just one blink? Could I have done something wrong with the device type?


It should turn on, at which point you let go and then it will start blinking. Pressing the button quickly 8 times while it’s plugged in is how you get the z-wave device to go into pairing mode.

As for the devicetype, it should still try to pair even if the devicetype isn’t installed properly, it would just show up as a ‘Thing’ instead of the ‘Outlet’ device.

I kept trying, kept unplugging and plugging in and it finally got paired up. I had to keep holding it for awhile for the light to blink.

Thanks for the help!

1 Like

I had two devices labeled as “Thing” and deleted them. They did not seem to be connected to anything!

If something gets paired as a ‘thing’ you need to assign a device type in IDE to make it work. Devices are added as a thing when the hub can’t find a device handler with the correct fingerprint to assign it a device type automatically.

1 Like

Thanks @blebson . I will remember that next time.

I am guessing that these “Thing” devices were the result of an interrupted or incomplete pairing with the Iris 3210-L power outlet (which was tricky). The “Thing” install date were close to when I had to pair, pair and re-pair the Iris outlet, and the “Thing” devices never communicated with the hub from what I could tell over the next few days.

Hence, I deleted the “Things” from the IDE and it appears that they were just ghost devices and inactive because they did not have a valid device type assigned…

Hey Smart ST Folks, wanted to give you and others who visit in future an update on my attempt with these - it was a SUCCESS (with the need of a reset). (To keep things in perspective, I am a 2 month old tech savvy newbee to ST.). And very happy camper, for finding out a cheaper Smart Outlet (with the bonus Z-Wave Repeater) :blush: . Shout out to @blebson !!!

@blebson 's instructions and DH absolutely helped and worked. For pairing instructions, refer @TanquerayG’s detailed post. That is what worked for me with some trial and error.

Some notes:

  • After installing DH, I tried to pair. But, by default the outlet didn’t go to pairing. And when I tried to put in pairing, ST detected only the Z-Wave side. So, had to reset the whole unit per the instructions in the posts.
  • After reset, it was a breeze - ST identified the ‘outlet’ and straighway got it working with switch and energy monitoring. So, didn’t bother changing the device type to ‘SmartPower Outlet’ from ‘Iris Smart Plug’. (Not sure if I am missing something by keeping it the Iris one. Didn’t feel like it).
  • Then I put the device in pairing and got Z-Wave repeater added.

From MileHigh @ Denver. Go Broncos!! :smile:

I got this working thanks to all the good posts here. Question, does the button for the ZWave repeater portion have to be in the on position for that to work? It always catches my eye that it is on when I scan down my device list.

Those buttons really don’t do anything. You can try switching it off but on mine it doesn’t stay that way.

I see what you mean. It switched off but after I relaunched the app it was back on again.

@blebson, exactly how do I do this?

"First: The Zigbee Outlet

In order to pair the Zigbee Outlet, first add the devicetype at the bottom of this post to your IDE. Once you have the devicetype added and published, open the SmartThings app and hit ‘Connect New Device’ within the Marketplace. After SmartThings starts searching for a new device, plug the Iris Smart Plug into the wall, and wait for it to be discovered by the hub. It should pair as an ‘Iris Smart Plug’."


What part are you having issues with?

This one:

Thanks Ben

Check out this guide:

Thanks Ben, again.

This is exactly what I am looking for to start. I will spend this evening to study it, and will report my grade later.