[OBSOLETE] Foscam Camera Device Handler Universal DTH with Motion Detection - SD (FI89xx), HD Ambarella FI98xx, FI99xx, Cx, Gx, Rx, Ex, Zx, Fosbaby

Are you using the new contact address book feature or do you need to enter the number separately and select the push option separately.

Forgive me, I am trying hard to understand how the detection table works.

In the example, areas 1-9 are set to 1023. Does this mean that the area where detection is taking place is comprised of the 1st 4 columns on the left of this table? What does "when this bit is set to 1 it means motion detection is effective in this area?

For instance what squares specifically are set for motion detection by area1=1023

Yes, each area is represented by a bit and a 1 means motion detection is effective in that areas Use binary maths to calculate the net value of the bit positions. Not the easiest way but that’s how Foscam has set it up. 1023 mean the whole area is being monitored.

1 Like

Thank you very much!

In an earlier post you mentioned that the detection area defined in the app takes precedence over the Foscam Web Interface.

Is there a way to have the Foscam web interface with its simpler click and drag to create a detection area take precedence?

I have tried to leave the field in the ST app blank but it keeps reverting back to being filled in with the default area definitions.

Again, thank you for taking the time to answer my questions. It is greatly appreciated and speaks volumes to your dedication to this platform.

I have always been a big fan of supporting independent developers and will continue to do so as long as I can.

No, it’s a Foscam API limitation, it needs to be provided with the API otherwise it defaults to no/blank zone (i.e. no detection)

By design, see the point above. If you leave it blank, it auto fills it to take full screen/all zone detection.

1 Like

Has anyone integrated the F3104W-B4 cameras yet? I’m looking at these as a replacement for my Blink cameras that will be returned this weekend.

Two days ago I started seeing issues with the device handler with my C1 camera. (It has been working great for months) It was no longer able to take pictures and settings could no longer be changed within the SmartThings app. I have updated to the latest device handler, changed the port it uses, and all troubleshooting outlined above. Anyone else seeing this behavior? Any additional suggestions?

Yes ST’s broken pictures last week with a platform update, have requested them to patch it up and will update the DH as soon as the new API’s are released.

We are using the second one on both phones, “entering the number separately and the push option separately”

Both phones?

You should have one only instance of the SmartApp installed.

Does anyone know if this device handler will work with Amcrest cameras. I think it’s the same US based company that previously handled FOSCAM. They dropped phone support for Foscam.

I am thinking of buying a few of these:

###Foscam Camera Universal Device Handler - version 03.04.02

  • Updated DH to work with new ST snapshot API’s (ST broke the Take button due a security deployment)
  • Removed capability Alarm to avoid confusion, use the Switch capability to turn motion detection on / off

###Foscam Motion Alarm Monitor SmartApp - version 02.07.01

  • < no change >
1 Like

That was fast, thanks!

1 Like

ST made a new update to the platform today which requires another patch to keep snapshot working.

###Foscam Camera Universal Device Handler - version 03.04.03

  • Updated DH to work with new ST snapshot API’s

###Foscam Motion Alarm Monitor SmartApp - version 02.07.01

  • < no change >


Having done nothing since the Hub firmware upgrade, snapshot still works consistently and now VIOLA streaming works on the ST app with my Samsung Galaxy Note 4 consistently each and every time without issue…still no luck on the iphone6S.

Hello, has anyone notice hub performance problems beginning sometime early this morning? I heard some noise outside and picked up my phone to take a look at my cameras. I keep getting the “There is a problem retrieving the livestream” error and the app is very slow to respond, my hub even went offline for a few minutes. I had just set up the Camera Motion Detection SmartApp. I removed it and all was back to normal, except I really wanted to use that app. Just now 11:57AM CST I set it back up and all the previous issues are back. Live logging doesn’t show any errors except for one (12:02:56 PM: warn Motion detection hasn’t been run a long time, calling it to kick start it) and in events I see where the hub goes offline as soon as I enable the SmartApp, it comes back

I am at 02.07.01 of the Foscam Motion Alarm Monitor and 03.04.03 of the RBoy Foscam IP Camera device handler. Hub FW is 000.016.00013. Cameras are a FI9900P and an R2 with latest FW.

Could I have the check interval too often? It is 5 seconds.

*** Update*** Maybe third time is a charm? So far all is good after a third reboot…
*** 2nd Update*** Nope, back to doing the same thing.

Im new to this so excuse me, been researching, got everything setup, device handler etc as Im moving from my Vera to the smartthings, on the mobile app I get Alarm:Error and a message saying Camera cannot be found. We are trying to connect, the camera is online the IP user and password are all correct not sure what the issue is with my foscam pan tilt outdoor.

Any help would be appreciated

The camera cannot be found is the default text shown by the ST video tile.

The Alarm:error indicates that your hub cannot communicate with your camera as your camera returned an error message. See your logs to find what error message the camera is returning. Most likely username password error or configuration error.

after the latest smartapp update I have lost live video streaming and snapshots do not show up in my “recently” tab. The only thing that is working is when I click “take” the preview photo is updated. I have verified all ports are correct. Ive tried with and without the RTSP port. before the update I did not have the RTSP port filled out and it worked, although my camera does support ONVIF so I tried that also but no luck. I have my pubilic IP entered and port forwarding enabled for my HTTP port and ONVIF port. Is there something Im missing or did the new firmware update break all of this? Model- FI9831P V2

-edit- I opened the HTTPS port for my camera and now live streaming is working, but now all of the camera controls do not work (ie pan and tilt, NV mode…)

That’s an issue with the ST app/platform, the new API’s have something to do with it, the snapshots show up on iOS but on Android. It’s been reported to ST but do report it to the BETA forum if you have access to it or to ST support so they can prioritize fixing it.

NOTE: You cannot use HTTPS, ST does NOT support HTTPS for local communication. You need to use HTTP only for local camera communication. Again we’ve submitted an issue to ST but you can report it to ST support requesting them to enable HTTPS communication for the hubAction API