[OBSOLETE] Foscam Camera Device Handler Universal DTH with Motion Detection - SD (FI89xx), HD Ambarella FI98xx, FI99xx, Cx, Gx, Rx, Ex, Zx, Fosbaby

Figured it out.

I had to delete everything. Even setting up a new device using the existing device handler code, it would still reference an old device ID that was deleted months ago. I removed the DH and the smart APP and then reinstalled it all with a new device entry.

The other issue was the username i created for the DH to use didn’t have enough rights. I setup the account as an “operator” and not “administrator.”

Request: Is it possible to set up the debugging/live logging so that it doesn’t show your username/password in clear text? I’m not sure if smartthings or others can see the logs, but kinda disconcerting that it’s seen in clear text.

Question: is there a way to disable the debugging or the constant message of the Foscam Motion Alarm Monitor constantly checking and leaving a log every 5 seconds in the actual DH log?

Thanks again.

You’re welcome.

  1. Only you and the ST authorized can see the username/password.
  2. No, we don’t have control over it, that’s inserted by the ST platform
    and we’ve requested for an option to disable it but no response yet from
    the ST crew

Thanks for your reply.

I did however see a bug possibility?

So with this testing and doing things quick, i gave my named my camera something stupid and unique. “cam cam”. Did all my tests and it seemed to work. Now I wanted to give it a real name that make sense. “living room camera”. So now i renamed it and I started to put “living room camera” into SHM to notify me of motion. That notification works, but it refers to the camera still as “cam cam”. Checked live logging and some of the entries from the Alert app still references the camera as “cam cam”.


ST has 2 names for each device, device name and display name. Depends on
what app you’re using and what name they’re using in their notifications.

When I went to change the name, I did change both Device and and display name to be the same but different from the original.

Both SHM and the Push notification from the Foscam motion app still referred to it as “cam cam”.

Contact ST support. Maybe the system is caching it or something.

I just added a C1 camera today, cut/paste the DHL from RBoy as well as the SmartApp.
Every once and a while it will look perfect, but most of the time the live stream on ST is green and not even full resolution.

There seems to be a lot of variables… not to mention all the foscam are not identical on the configuration within the Foscam App. Wonder if someone has any write up for the C1 cams?

something like… UPDATE --> See next post I wrote
In Foscam App, set this and that (can DHL use an Operator User… or does it need to be Admin account user)
In DHL, set this and that
in SmartApp, set this and that…etc…etc


After reading some more of the thread… decided to wipe and start over on this project
Foscam C1 -> Factory Reset
DHL -> Deleted
SmartApp -> Deleted
Device -> Deleted
Hub -> Rebooted, verified everything was gone before I started.

This time I did not use the Foscam Android App to configure the C1.
Did the following:

Initiated the WPS software button on router (R7000 Nighthawk), then pressed WPS button on C1 for a couple seconds, it paired up.
Used Equipment Search Tool to find the IP Address, using Safari, went to http://x.x.x.x:88 (username = admin, passwd = blank/empty)
Logged in, updated admin user/passwd
When through 1-5 step wizard

Clicked Finish, it reconfigured the C1 network and redirected me back to the login.
Logged back in, made the following settings (NOTE: I have not yet configured the C1 to the Device Handler in ST yet)
Basic Settings > Status Light = Yes
Network > UPnP = Yes (Default was No, can this be changed to yes??)
Network > Port (HTTP/HTTPS ports were changed from defaults). Redirected back to login on save, logged back in
Network > Mail Settings (Configured/Test/Verified email) Oddly enough, it was successful, but never received an email.
Network > Onvif = Enabled (Kept all Defaults for ONVIF/RTSP ports)
Video > Video Settings > Enhance Night Vision Definitions = Enabled (Kept all Default settings)
Video > Snapshot Settings > Enable timing to capture = Unchecked (This is the Default… Should this be Enabled??)
Detector > Action Detection > Enabled = Checked (Kept all Defaults) Should these be changed??

Detector > Sound Detection > Enabled = Unchecked (This is the Default)

Rebooted C1 after making changes.
Launched ST, located Device in “Things” tab, configured DHL
Set ipaddr, cam port, username/passwd, rstp port (554), enabled for HD model.
Lastly, click the refresh tile.

When I launched the livestream, it worked this time! Also noticed the IR Led tile, Motion Alarm tile, Snapshot, and Reboot Tiles are working. TO answer my own question in previous post, I can now understand why the connected user account MUST be at an Administrator level to allow a reboot.

BUT… BUT I did still get a green screen on my Android. My Ipad has not.
Android = Galaxy S5
Ipad = Gen 4/Retina

Also looks like the C1 does not support MJPEG streams: (this does nothing)


Other issues:
Once I had everything setup, I logged back into the Foscam WebUI to see how things looked (since the DHL is supposed to override settings). In the Video Detection section, I saw where it changed the sensitivity from Low To Medium… I selected it back to Low in the WebUI (but did not “save” the setting). However, the settings did not go back to Medium when I refreshed the settings… its still on low. And now when I make changes in the DHL options and refresh them with the “Refresh Tile” nothing happens other than seeing the IDE logs show the “tobe” changed settings. Something is now preventing the DHL from updating the foscam.

I have tried rebooting the camera and restarting ST app. No dice! Then I tried turning off emails and the annoying camera alarm. They show unset in the DHL and I saw the change go through the IDE logs, but the Foscam UI is not showing the change being made.

0e4e0e08-3aae-4a17-a56e-xxxxxxxxxx 12:09:14 AM: trace Refresh called. Settings -> [ip:192.168.x.xxx, port:xx, username:xxxxxxxxx, password:xxxxxx, rtspport:554, hdcamera:true, mjpeg:false, mirror:false, flip:false, motionLevel:High, soundAlarm:false, motionEMail:false, motionSnap:true, motionRecord:true, motionRing:false, cruisename1:Horizontal, cruisename2:Vertical, lightCompensation:true, detectionArea:area0=1023&area1=1023&area2=1023&area3=1023&area4=1023&area5=1023&area6=1023&area7=1023&area8=1023&area9=1023]

WebUI still shows Low Sensitivity, Camera Sound enabled, and Send Email enabled.


BUT… BUT I did still get a green screen on my Android. My Ipad has not.
Android = Galaxy S5
Ipad = Gen 4/Retina

Tested this some more this morning on another Samsung Galaxy S5 and a Samsung Galaxy S7.
Only changes made was to hook up a ethernet cable to the C1.

All 3 devices threw a GREEN screen on the video stream at random occasions. If this is indeed something to do with codecs installed on the Samsung devices, I would think Samsung (maker of the SmartThings hub) would be more than willing to spend some time to make this better/right. Especially since their rival/competition “Apple” doesn’t have this issue.

One another note, I have noticed the DHL is somewhat slow to respond at times, just when accessing the Foscam device tile page.

More on this (after several several several hours of trying pretty much everything.
The best outcome I was able to produce for an externally connected webcam (Foscam C1) was:

  • I could toggle the IR LED, Take a Snapshot, Turn the Motion Detection on/off
  • I could NOT get rstp to work via port forwarding (Cam feed would show it streaming in the IDE logs, but the phone/ipad would not connect.)

Perhaps just using a generic webcam would allow the stream over http/https, but then I lose the ability to use @RBoy DHL/SmartApp.

Everything works great on my LAN, just not liking the WAN piece.
Kinda bummed, think I have over 20hrs troubleshooting this.

I can get the stream to work fine. I have it working here and SmartTiles. But I cannot get the PTZ control or anything else to work. When I input the hubaction command for a preset into a browser, it’ll will move to the right preset. But it just doesn’t work in the app. I think it’s sending the command somewhere but the camera isn’t receiving it.

I have video setup to record thru the FOSCAM app, how do you setup the recording on your DTH? when I turn off the recording feature in FOSCAM and turn it on in your DTH it does not record. Or if it does where are they stored, please assist.

All the video configuration (storage duration etc) needs to done on your camera through the GUI or app. The ST will only enable/disable the video recording on motion alarm through the DTH settings, it won’t affect the settings.

Is this work with any IP camera or just the brand Foscam?, I own 3 cams very similar to the Foscams, the brand is WinBook in the US and vstarcam in other countries actually I am thinking probably is the same manufacturer because they look very similar. Have anybody tried this with another camera brand?


I have been experiencing a couple of issues with both my Foscam FI9810W and FI8918W.

  1. The “mirror and flip” option doesn’t seem to work consistently, as it randomly still shows pictures and video streaming upside down.

  2. Email notifications on motion alert stopped working. I tried almost every option available on smart app, device handler and Foscam web interface.
    Rebooting or using a different email didn’t work either.
    I’m able to successfully send test emails from the official Foscam web interface, and images are correctly uploaded to FTP.

Yesterday, I was able to get it working for about 2 hours, after upgrading both cameras to the latest firmware, but now I’m out of luck again.

Also, the “sound detected” notification emails are being sent normally.

Any suggestion?


  1. Reboot camera and st hub
  2. Am working on a patch to be released. Some of the third party services
    are not 100 reliable which maybe causing the issue
1 Like

#FOSCAM C1 VIDEO CONFIGURATION (and cameras using Onvif RTSP)
FAQ: Folks using the Foscam C1 camera need to do the following steps to enable video through the ST app:

  1. Login to the Foscam Web GUI
  2. Click on Network -> Onvif
  3. Enable Onvif and set the RTSP port to 554
  4. Open the ST Camera settings page and enter 554 under the RTSP port
  5. Click Done AND CLICK REFRESH (if you don’t click on Refresh the settings won’t take effect. Anytime you change the camera settings you need to click Refresh thereafter).
  6. If you’re using an external IP make sure you enable port forwarding to port 554 to the camera (avoid UPnP)

gave up on the C1’s… sent back to microcenter. might revisit this later in next house…else will be looking at keeping video feeds contained within zoneminder.

It’s working fine here, I suspect something in your network config is blocking your RTSP port (firewall etc).

Just bought the code for my Foscam FI9826P. I can get the stream working perfectly from OUTSIDE my network with tinyCam pro. Obviously for this to work, I’m using DDNS and port forwarding.

For whatever reason, in Smartthings it says, “Camera Unavailable” on the live stream and “Active” in the top corner. I’ve entered the same credentials as in tinycam Pro. What could be causing this? Any ideas?


could be… Until my next house I am stuck with a century link POS modem. I have most of the features disabled so that I can use my Netgear R7000 wireless router. I will hopefully be moving into a new house this year and going with Cable Internet which will completely eliminate the DSL/modem/router combo. Will also be upgrading to an AC wireless router, hopefully with DD-WRT based. Think this will help smooth out the junk I have right now.

as Arnold says… I’ll be back, for this thread…