[OBSOLETE] Dome Water Main Shut-Off (Official)

Thanks for the DH. I have it up and running and it seems to be working spot on.

On a side note … is there a way to change the reporting on the “my things” screen to still say open but be white? I ask this because, I frequently check my apps (both IOS and Android) looking for lights left on and problems. When this shows up BLUE it draws my eye and makes me think something is wrong. Maybe I’m the odd ball out, but I would rather only have some type of notification if something is wrong meaning the valve is closed. Otherwise when it is open I’d rather it just blend in …

Just swap these values in the code: “#00a0dc” and “#ffffff


Thanks! That worked.

You’re a good guy … no matter what people may say about you! :grin:

Is there a post or topic about me that I missed…?

Trying to be funny … thanks again! :+1:

1 Like

in smartthing app i don’t see the status changes.
It’s ether open or no status at all.

Opening and closing works fine.

I am having the same problem with the status on the app. No indication of it’s open or closed, but hitting the open or close button in the smart things app will actuate the unit correct. Just no indication of open or closed in the status window.

Attempting to attach a screen shot of what it looks like on my iPhone.

Just tested mine - working fine w/ a brief (maybe 2 sec) delay. Also on iOs with this DTH. Showing ‘CLOSED’ when closed, ‘OPENING’ while opening, ‘OPEN’ when open, ‘CLOSING’ while closing. Also when it’s open the ‘CLOSE’ button is highlighted, when it’s closed the ‘OPEN’ button is highlighted.

I seem to remember seeing this though - I know I had to pair a couple of times when I set it up a few weeks ago to be sure it was working smoothly.

1 Like

Based on that screenshot you’re not using my DTH which explains why you’re having problems. (see the first post of this topic for screenshots of what this DTH looks like)

If you didn’t install and publish my DTH before adding the device to ST you need to open the device in the IDE and change the type to this DTH.

Another iOS/Android issue I believe. I don’t get the colors on the smaller tiles like you have in the first post (and I can’t see in the code where you have anything but white and blue for those tiles btw so not sure if things changed at some point) although my icons match yours on my iPhone. And then on my iPad the icons are as Andrew posted … The icon difference between iPhone and iPad has always made me wonder as I do not see that on any other handler/device. I cannot figure out how that can happen.

EDIT: I see now you updated the color scheme in December so ignore my comments about the colors.

All that said, Andrew’s main tile is odd showing grey and no text.



Thanks guys for the responses. I did load the device handler prior to adding the unit. I’ll remove/delete everything and start over again to see if that works this time. Won’t be at the unit again until next weekend, but will let you know how it turns out either way. Thanks again!

i have it added as in type as:

krlaframboise : Dome Water Shut-Off

and it still does not update status in smartthings.

Following up, removed the device handler and the Dome Shut Off device from SmartThings and re-installed. Everything is working now. App shows Open, Opening, Closed, Closing all at the appropriate times based on the actual physical state of the unit.
One odd thing. I only get the refresh icon below the main status indicator. No Open or Close icons to press. If I press the main indicator (big blue/gray box), it toggles between open and closed, which works just fine for me. It just doesn’t match what I think is was intended in the device handler?

Screen shot of open state…

Closed state looks the same except the status box is gray and says closed. Status box also shows “Closing” and “Opening” at the appropriate times.

It looks like you are not running the custom device handler. This is how the stock ST handler looks I think.

If the custom handler is not already installed when you include the device to ST you need to go in to the Device in the IDE and update the handler to the custom handler.

Has anyone tried this on an econet shut off?

Went in and looked at it and you are correct, I was using the generic z-wave water shut off handler. So I went in and forced the valve to use the Dome device handler. And… I go right back to the original screen I posted. Everything is grayed out, valve will work if I hit open or close, but no status indication of opening or closing, open or closed.

Attached a screen shot of my settings of the device in the ide. What am I doing wrong?

When I pulled the valve up originally in the IDE, Type = z-wave water shut off, Version = Published

SmartThings Classic app for iOS, version 2.15.0 (Build 1434)

Tried using both published and self-published settings in the Version pull down. Same resulting screen in smartthings app.

Dang, sorry to hear that. I really don’t know what to suggest beyond what you have already tried. Maybe there’s something wrong with the device.

After changing the type did you open the device settings in the mobile app and save?

Can yous end me the Raw Description so I can verify that it’s the same version that I have? It’s displayed on the device screen in the IDE.

Thanks for the response Kevin. Device settings and save in the app didn’t have any effect.

Here is the Raw description data…

zw:L type:1006 mfr:021F prod:0003 model:0002 ver:0.02 zwv:4.05 lib:06 cc:5E,86,72,5A,73,85,59,25,20,27 role:05 ff:9500 ui:9500



I originally paired the device before installing this DTH - what worked for me was to go through the exclusion process (it’s in the manual - don’t have at hand) and do a fresh start - pairing after my DTH was loaded. YMMV - but just in case it’s useful. I found it’s a little touchy to pair.

Also - have you tried manually opening and closing it w/ the button on the device? I seem to remember that causing an update/sync for me once.