[OBSOLETE] Denon Network AV Receivers

We’ve been playing with these receivers in our labs, unfortunately the discovery and some communication has broken as due to a bug in the platform for SOAP/UPnP/UDP protocols response being stripped out:

i would like to control my denon AVRS920W with ST and alexa. it looks like this WAS the thing to use to do that but no longer works. Does anyone have something new?

This is working perfectly for me. I have just set it up as a “My SmartAPP”, and then went on to add it into SmartThings classic app, and then hit my app, and chose it in discovery, boom it showed up. With all the inputs, controls, etc. Works perfect.

Hey man i’m confused what code did you use to create a smart app? I’m really trying to set this up but i’m getting the same problems that everyone else described.


Thanks - your smartapp works great for my AVR-S940H! Id love zone 2 but hey, beggars can’t be choosers. :slight_smile:

FWIW, with the latest SmartThings Android app…the UI works in-app again! Hooray!

Classic app? Or the new one?


Which app are you referring to in your post? I have both an AVR-S730W and a AVR-X2200W receiver I would like to control with ST.

I was meaning the “new” SmartThings Android app, and the sbdobrescu/DenonAVR device handler.

The new Android app. (Which I don’t really like, but it works)

if this is obsolete, which thread is the actual one ?

Btw, I tried the DTH from @billsq nd it works fine.
I just added sound modes (pure, direct, auto, stereo, game, movie, music)

Found the related commands from here:

Hi @billsq - (or anyone else still using this), is this app still working as far as you know? After adding the SmartApp and DTH in the IDE, when I go to install the SmartApp the first time and go to the discovery page, 0 devices are found. I have 2 compatible receivers [X2400H & X4300H] that do show up on my network and in the Denon remote app (on the same phone) trying to install the SmartApp , but neither show up when doing discovery in your smartapp. Thanks for creating this and for the help!

How is this installed?

Did anyone get Internet Radio working? Its not a standard option in this app.
There is a net option, but its different. The net option brings up a menu where i need to remote to pick something from the menu.
The remote has a button ‘Internet Radio’ (also works from harmony app), when i press that music just starts playing, and thats what i want. Ive tried adding IRP and IRadio to the source code, but with no luck.