[OBSOLETE 1.1.6 5/25/16] Big Talker - Talk when events occur

Hi Brian

I have installed the new beta but I can’t find where to put the zip code…

When typing out your custom phrase, type in the custom variable you want


this from live logging

28ea622a-3d19-41e3-b4fa-03825dc46227 22:44:02: error java.lang.NullPointerException: Cannot invoke method contains() on null object @ line 2857
28ea622a-3d19-41e3-b4fa-03825dc46227 22:44:01: error java.lang.NullPointerException: Cannot invoke method contains() on null object @ line 2857
28ea622a-3d19-41e3-b4fa-03825dc46227 22:44:00: error java.lang.NullPointerException: Cannot invoke method contains() on null object @ line 2857
37d25569-d71b-4eb6-a163-332703c9196a 22:43:58: trace getPhrases(), state.welcomeIssue = null

and this is the place I would like to get forecast for

so it seems that I have two problems here

  1. get my zip code (if you see below 23030 is getting data for Charles City, VA (23030) and not Valfurva Italy 23030)
  2. have my speakers saying something in fact I get this message

The Weather Underground API uses US Zipcodes. I just tested the following and it seems to work:

I have not tested all of these, but it looks like you could possibly use any one of these in place of the zip code:

US state/city: CA/San_Francisco
US zipcode: 60290
Country/City: Australia/Sydney
Latitude,Longitude: 37.8,-122.4
Airport Code: KJFK
PWS id: pws:KCASANFR70

ie: %weathercurrent(KJFK)%

Hi Brian

I added country/city but I can’t hear the speaker.
As soon As I click done to save the smartapp settings I get this notification “BigTalker cound’t announce…”
Can you help me undestanding what is wrong?

What brand/model is your media player? (Sonos? VLCThing? MediaRenderer? or something else?)
Are you in the United States or UK?

When BigTalker calls on the SmartThings function textToSpeech(), normally SmartThings processes this on the backend and returns an MP3 file that is then played. If SmartThings returns an error from its failure to convert the text to audio, BigTalker tries a second time. If the SmartThings still doesn’t convert the text to audio, then BigTalker gives up and sends you a visual alert so that you still receive your event notification “BigTalker couldn’t announce…”. This was added in 1.1.4-Beta due to a known issue with the SmartThings platform that started several months ago where it has trouble converting text to audio. It seems to be better lately, although I still see others report the issue still exists.

Hi Brian

I use MediaRenderer and I am based in Italy, therefore Uk server.
I use notify with sound app and I get voices and play music on my speakers therefore MediaRenderer works fine, there must be something else


@ule @tslagle13 , any insight to @sballoz issue in the UK? Any specific issues that you know of regarding calling textToSpeech() there? I am also using MediaRenderer in the Central U.S. with gmrenderer-resurrect on a RaspberryPi (I don’t remember the article I followed, but here is one http://blog.scphillips.com/posts/2014/05/playing-music-on-a-raspberry-pi-using-upnp-and-dlna-v3/) **I do have to forcefully reboot it every once in a while. **Edit, add @jody.albritton

I am not completely up to speed on the UK differences but Tim is actually @slagle now

1 Like

There shouldn’t be any reason it doesn’t work on the surface.


I read more and understand better now. I have to ask around. On their surface their shouldn’t be a difference.

1 Like

@slagle, I wonder if the UK data center has the same phrases cached as the US datacenter(s)? Perhaps being new to the scene they do not have near as large (if any) cached phrases prior to the textToSpeech() platform issue.

Or perhaps, the UK datacenter / foreign IP range is being blocked from using the TTS service that the SmartThings platform relies on?


unfortunately (as of a week ago) it looks like Sonos has gotten worse. All I now get from big talker (reinstalled 6 weeks ago) is “BigTalker couldn’t announce…” as a mater of fact all of my Sonos items no longer work, even the ones that have always worked… ie “mail has arrived” :frowning: @slagle

I can confirm that the TTS function in the UK does not work - Only cached messages from other people seem to work.

ITs really annoying as I have loads of things I want to be broadcast out through my speakers.

EDIT: I did start this, but got no reply’s. Was only to help me really find out what ones should be working.


I agree it is frustrating. It is one of my favorite parts of ST. However I do have hope. I know @slagle is working hard on it, and I have every faith his ability to get this working for us… and when he does, he will be my hero forever!!! :grinning:

1 Like

Just got this in response to sending in a support ticket.

Hey Dean,
Thanks for getting in touch.
The TTS has been temporarily pulled from SmartThings, this is due to our engineers working on making it more reliable and more customizable than it previously was. Best thing to do would be to keep an eye on the Blog and Community pages for further updates.
Unfortunately at the moment we do not have a concrete timescale on when it will be making a comeback but we are chasing this up on a daily report with the engineers.
If you have any further questions please get back in touch.
Kind regards,


try media renderer events , it has a TTS alternative and works great for me, you can try too the wheater app with external TTS

or you can change the function in yours smartapps

@ule I’ve just tried the solution, signed up and got an API key - But it don’t seem to work. I cant get any of the weather conditions to sound?

Hi @deano12,
1- Are you using the last version?
2.- What speaker do you have?
3.- The speaker can stop when press the stop button from device interface in smarting app (to verify is connected to hub)
4.- What zipcode are you using (to test information)