Not sure what the best solution is - any thoughts or advice is welcome! (Bulbs)


(Ken) #1

Not sure if this is the right forum to ask but I’m having a senior moment on this. Sorry for the long read but I wanted to be thorough.

I’ve got SmartThings working great - not just well, but great! I have several bulbs, switches, outlets and even a couple of flood sensors, smoke/CO alarms and some dry contacts/relays in my mix. I even have one of the MIMO boxes that controls both of my electric gate openers. To top it off I have it all working great with Alexa!

A little background - I live out “in the country” on acreage. Most of my neighbors (with one exception) are clueless about technology so there’s no interference. I recently built a big ranch entrance to my place (I have a big circle drive in front of my house) and put up gates, which I put Osram RGB bulbs in. Obviously, they’re Zigbee and at 2.4ghz they somewhat interfere with my WiFi (or more likely, the other way around.) The main visitor entrance is a big heavy thing and the bulbs are in outdoor fixtures protected from the elements but still additional material for the signal to go through. Some of the time they will get enough signal to at least receive a command, most of the times not. I had an automation setup that when someone triggered motion at night on my Ring doorbell I’m using at the entrance keypad, it would brighten the bulbs from 50% to 100% and go back to 50% after 5 minutes of no motion (which worked awesome when they’re connected.) Problem is, all four bulbs - two entrances - can barely connect if at all. They all show “offline” if I turn device health on. They are approximately 50 feet and 75 feet from my hub, but the hub is inside and behind a brick wall and a few layers of drywall and the bulbs are behind wooden boxes or the entrance itself.

I’ve been on a bit of a witch hunt trying to figure this out - first I’m going to narrow my WiFi (802.11n) down to a 20MHz bandwidth and put them on channel 1; I listed out all my WiFi devices and with little exception almost none of it needs high speed internet. All my PC’s or devices that need high speed are wired ethernet (1GBs) and the few that are wireless, can be pushed into the 5GHz spectrum where they won’t interfere with the Zigbee devices. (Primarily my Ring doorbells.) The SmartThings API says my hub is on channel 20 for Zigbee.

My question is - am I wasting my time trying to get these bulbs to work at that distance, through heavy material? The big visitor entrance is basically a big box tube made from 2"x12" pressure treated lumber. The other two are made from 5/4"x6" pressure treated lumber.

I’ve been thinking about four options:

  1. Crack open the SmartThings controller (I’m sure mine is out of warranty, it’s V2 hub and I got it back in 2015) and add a UFL connector for an external antenna. I’m no stranger to soldering or making mods and since Zigbee is in the 2.4GHz range, any WiFi antenna should do the trick. Anything has GOT to be better than a PCB antenna.
  2. Make my own WiFi bulbs from one of the controllers I’ve seen an integration with on here and strip light wrapped around a short piece of 2" PVC. I already have the strips, controllers and power supplies for this.
  3. Get an Osram RGB floodlight bulb and put it mid-way to the entrance hoping it will act as a repeater/router for the other bulbs (which would likely involve complex scenario of deleting and rejoining the bulbs so they’d create a proper mesh?)
  4. Just wire the four fixtures up to the existing Zwave switch that I installed instead, and use plain-jane LED bulbs (doesn’t allow dimming or color changes so to me this is a failure.) The Zwave switch is already in-place and working, and controls the top outlet of the outlets I put on the backside of the entrances to run Christmas lights. Doing this option just means I’d remove the fixtures and change from the black wire to the red wire for “hot” on the fixtures.

I’ve already tried one of the Digi XBee router/repeater units and it seemed to help to a small degree - but I have no way of knowing/testing to see what it really does or where I should even put it. Again, on the back of the entrances I built weatherproof outlets; top outlet is switched by the Zwave controller and bottom is hot at all times. I’ve put the router/repeater in each of the boxes and seemed to work better but then it didn’t. I’ve tried unplugging the hub for 20 minutes (and removing batteries, which were corroded a little) with no luck.

Part of the other problem is I’m not sure if I’m joining the bulbs correctly; if I bring them in the house and plug them in near the hub, they work fine (I even got them to upgrade their firmware!) but once I take them out… they lose too much signal. My understanding of Zigbee is that if it’s a constant-power device (plugged in vs. battery) then it should repeat the signal. Either that’s not the case, or there’s simply too much material for the signal to go through (hence my idea about an external antenna.) These bulbs aren’t the only Zigbee devices I have either; I have a couple of Cree bulbs and a few sensors as well in the house, and they work fine.

If it helps, I can post pictures.


#2

( i’ve moved this to projects so you can get individualized responses based on your own needs and set up.)

I’m too tired to go into details right now, but The short answer is yes, the bulbs are just too far away given your current set up. So option three or four are your best bet.

It’s super easy to get devices to recognize a new repeater with zigbee. This is called “healing the mesh.” Once all the devices are on your network in their preferred locations , all you have to do is take the hub off of power (including taking out any batteries) and leave it off power for at least 15 minutes while leaving all your other zigbee devices on power. This will cause the end devices to go into “panic mode” because they can’t find the hub. Then when the hub comes back online, all your zigbee devices will rebuild their individual neighbor tables, and they will now recognize the new repeater as a neighbor.

That’s all you have to do. Zigbee was designed to minimize the need for human intervention in routing. So you don’t have to do anything individually with the other devices, you don’t have to change your smart apps. Just power down the hub, wait, power up. You may not see all the results until the next day, but it’s easy.

Short answer: there’s too much distance and too many barriers to reach the bulb in their outdoor location, so the simplest thing is just add another repeater midway. Another bulb should be good. Or change over to the Z wave switch with dumb bulbs if that’s already working well. :sunglasses:

The following article from the community – creator wiki night also give you some ideas:

http://thingsthataresmart.wiki/index.php?title=How_to_Automate_an_Outbuilding


(Robin) #3

As @JDRoberts suggests, your first thing to try should be a Zigbee heal… every time you move a Zigbee device from one location to another you should perform this procedure (i.e. You’re setting up indoors and then moving them out to the gate, so do a heal after the move).

If that doesn’t work and you don’t have a suitable spot in the middle for a repeater, going down the Zwave switch route will be one of the few options remaining.

If you go for Zwave plus you will get greater range over the older Zwave devices. Also, using a Zwave switch won’t cost you the dimming ability if you go for a dimmer switch or micro module + dimmable bulbs, instead of just using the simple on/off switch you currently have… maybe that switch could be used elsewhere?

I’ve been known to solder wires into individual battery devices before (for mains power), but I don’t reccomend breaking open the hub itself and soldering in a bigger antenna! Not only do I doubt it will help but bear in mind that there is no way to restore a new hub with the settings of an old hub. You break it and you’re back to square one and by the sounds of it you’ll have a lot of devices and automations to reset.


(Ken) #4

Thanks for the replies guys, I’ve already done the hub reset (remove batteries, unplug, let sit for 20+ minutes) and didn’t seem to help any. What I’m wondering is if I put the Digi router I got Digi Wall Router in an ideal location - will it repeat well enough to touch all four bulbs (and eventually, my mailbox for a dry contact sensor?)

Note that all my Zwave stuff works just fine (the Fortrezz MIMO, the GoControl relay, etc.) and all my indoor Zigbee stuff works fine.

I added a pic that might help, this is the main entrance with the other entrance (exit) off to the left. The one on the left has two boxes on top of the posts with the light fixtures in them. Pretty much all of them face away from the hub (meaning they have to go through the structure for signal.) Not to mention that behind the two on the left, there’s an outdoor outlet with wiring in it. The hub is almost directly behind the right pillar of the main entrance; so not only does it have to go through the structure, it has brick (and drywall/studs) to go through. Probably several layers at least for the far right bulb. The only one that’s truly “exposed” is the furthest one (far left in the pic.)

That being said, I have two Keen bridges (from my Keen SmartVents) and the Digi router (just a plug-in wall-wart.) Keen claims their bridges work as repeaters (routers?) but I don’t know how to even tell if there’s improvement. I’m tempted to get the Digi USB stick and see if I can map out my devices (if at all.) $49 isn’t much considering my mailbox is off to the left (just out of picture) and I want to put a battery powered switch in it to know when my mail comes.

I also read somewhere where the Osram bulbs work on ZHA protocol rather than ZLL when connected to ST? Is that true? If so, and the Keen bridges repeat ZHA, I should be able to put a small enclosure outside somewhere with one in it?

I was going to put another Osram (floodlight) bulb over the peak of the window off to the right, but debated doing that vs. the little ground light kit they have. The “repeater” part of the ground kit of course is the wall-wart so I’d have to strategically place that as well.

Being that I’ve got issues with multiple devices that are related to structure penetration - that’s what led me to the idea of going with an external antenna on the ST hub. If I can see that the Digi router is working in my system (or even one of the Keen bridges) then I wouldn’t be opposed to hacking one of those (especially the Keen, as they were practically free.)


(Ken) #5

Just discovered there are a couple of Zwave RGBW bulbs out there - considering Zwave is working great (I have the MIMO controller and the GoControl relay working just fine) on the entrance, and the Zwave bulbs say they have repeaters; maybe that’s a better route since it’s a much lower frequency and has better structural penetration?


#6

Better range in clear air, but many more problems with signal dispersion in rain or high humidity conditions. Most outdoor devices are zigbee just for this reason. You can try them and see how they work for you, but you need to try them on a rainy day.

The zwave bulbs are repeaters, but so are almost all mains powered Z wave and zigbee devices, including zigbee lightbulbs. So nothing special there. :wink:


(Ken) #7

Well I spoke to a vendor who is sending me a test bulb to see, considering this is just on/off during dawn/dusk and a color change during holidays (with the occasional brighten/dim command when motion is detected) I’m not as worried. Not to mention - it can’t be any worse than Zigbee bulbs that AREN’T working anyway.


(Ken) #8

Well, so far so good - my server (DHCP/DNS/etc.) crashed last night and everything was offline so I don’t know if they worked properly or not, but…

I now have six (6) Inovelli bulbs; two at my front patio (which are mere feet from my ST hub, and in return, repeat signal) along with the other four at the entrances. Now I can actually touch all the bulbs and they respond within a few seconds. I can see their status pretty quick as well (unlike the Osram/Sylvania bulbs which work fine indoors.)

My simple lighting connection between my Ring doorbell at my visitor entrance brightens the bulbs within a second or so of seeing motion, and 5 minutes after the motion stops, the bulbs dim back to their original 50% I have them turn on at.

Of course the real test will be how well they perform in more humid conditions.

I tried an additional Osram bulb (a spotlight) before I bought the Inovelli bulbs and it didn’t make a lick of difference even after resetting the hub and letting the mesh rebuild itself for a couple of days.

Best part is, I forgot that my mailbox dry contact sensor is Zwave plus as well so it should benefit from the bulbs being Zwave plus (repeaters.) Now if I could just find time to put it in!