No such property: type for class: physicalgraph.group.cassandra.Room


(John Rucker) #1

Is anyone else seeing this error when they try to load and run an existing custom device type in the IDE? Also happens when I create a new custom device type from scratch.

groovy.lang.MissingPropertyException: No such property: type for class: physicalgraph.group.cassandra.Room
Possible solutions: name

I cant find any information on this I bet I need to define a new parameter for the new Room feature. My device types ran just fine up to yesterday?? Also my list of physical devices is gone I cant select a device to run my custom device type against. @Dianoga

Screen shot of the error from IDE


(John Rucker) #2

I also get a “DataTables warning” when I try to view “My Devices”.


(Brian Steere) #3

A fix for the datatables issue should be going out today. I’m working on getting an answer for the room property.


(Patrick Stuart [@pstuart]) #4

I am having this issue as well:

groovy.lang.MissingPropertyException: No such property: type for class: physicalgraph.group.cassandra.Room
Possible solutions: name

Can’t update any devicetypes.


(John Rucker) #5

The database error is gone (Thanks!) but I’m still getting the room property error. Looks like others are seeing it as well.


(Jjhamb) #6

I am also getting this error. And IDE does not list physical devices in the simulator.

groovy.lang.MissingPropertyException: No such property: type for class: physicalgraph.group.cassandra.Room
Possible solutions: name


#7

I’m still getting the error as well. Any updates on when this will be fixed? I understand a patch is out but it didn’t appear to have accomplished anything.


(Patrick Stuart [@pstuart]) #8

Can confirm same issue. Simulator seems toast. But shouldn’t stop you from using the mobile app as a simulator.


#9

Actually its worse now. I can’t even do polling or refreshes. :frowning: No development for me tonight.


#10

I’ve never even seen these options before.


(Patrick Stuart [@pstuart]) #11

Yeah, I haven’t been able to use the simulator since before Thursday. I gave up and just am using my phone to test.


#12

Seems about right. I was on a plane trying to update my custom device (Thursday) and I thought the errors were due to a crappy connection. The only way around it was to keep going back out to the “my device tab” and then click back on the device. That was the only way for me to run the sim.

This trick isn’t working tonight. errr.


(John Rucker) #13

Ahh good suggestion Patrick! So it still works if you save and publish? I guess I can assign it to a device by editing the device under the my devices section and assigning it there. Thanks!


(Jjhamb) #14

/has anything changed?? I cannot refresh or use any physical device ion IDE.


(John Rucker) #15

no improvement from my point of view. Just checked my smart app and still getting the same error!

I don’t know if anyone has submitted this as an official problem. I haven’t contacted tech support or anything.


(Jjhamb) #16

Im on chat with support right now…


(Jjhamb) #17

No Joy… Support has seen this thread and they are working on it but there is no timeline. However @JohnR, for me smartapps are fine but device types, none is working,


(John Rucker) #18

Thanks for checking with support!


#19

Still no updates? I’m not getting errors anymore but instead I can’t get past the install part… just hangs if I try to connect to my “real” physical devices. Virtual devices install and work fine… but the real devices show the spinning donut :frowning:


(김도형) #20

Still no updates??

I have same issue…
room property error and … Physical Device not appear in my device list.
“install” does not working…