[NEEDS UPDATING] Assistant Relay V3.3 Beta

Meanwhile in Terminal - all this is happening:

0|www | Assistant Relay Server Initialized
0|www | Visit in a browser to configure
0|www | GET / 200 28.789 ms - 3159
0|www | GET /static/js/main.a3431f03.chunk.js 200 158.115 ms - 60122
0|www | GET /static/css/2.3a86971d.chunk.css 200 153.408 ms - 259521
0|www | GET /static/js/2.1e09be87.chunk.js 200 157.664 ms - 1755595
0|www | OPTIONS /server/userCount 204 0.471 ms - 0
0|www | POST /server/userCount 200 246.320 ms - 10
0|www | GET /favicon-16x16.png 200 12.792 ms - 1152
0|www | GET /android-icon-192x192.png 200 15.931 ms - 3331
0|www | GET /favicon.ico 200 3.981 ms - 1150
0|www | GET / 304 0.678 ms - -
0|www | GET /static/js/2.1e09be87.chunk.js 304 0.547 ms - -
0|www | GET /static/js/main.a3431f03.chunk.js 200 3.863 ms - 60122
0|www | GET /static/css/2.3a86971d.chunk.css 200 6.202 ms - 259521
0|www | OPTIONS /server/userCount 204 0.099 ms - 0
0|www | POST /server/userCount 200 7.010 ms - 10
0|www | GET /android-icon-192x192.png - - ms - -
0|www | GET /favicon-16x16.png 200 2.141 ms - 1152
0|www | GET / 304 0.304 ms - -
0|www | GET /static/js/2.1e09be87.chunk.js 304 0.419 ms - -
0|www | GET /static/js/main.a3431f03.chunk.js 200 1.100 ms - 60122
0|www | GET /static/css/2.3a86971d.chunk.css 200 1.462 ms - 259521
0|www | OPTIONS /server/userCount 204 0.169 ms - 0
0|www | POST /server/userCount 200 12.738 ms - 10
0|www | GET /favicon-16x16.png - - ms - -
0|www | GET /android-icon-192x192.png - - ms - -

LOL Still there this morning. So I see on Google’s site the “Dashboard” but there is definitely no Configuration tab. Or am I looking at a wrong dashboard?

^^ 10 char.

Ok, maybe I should give this up and write off as something I’m just not able to do.

I visited that in my browser.

I followed to step 5 and went back to that first setup page.

I finished all of those bullet points. Remember? I clicked “next” to go to the second page when I shouldn’t have (the client secrets thing), but I didn’t do anything.

I downloaded an OAuth2 JSON file from Google. It’s sitting in my downloads folder. It’s called "Client_Secrets… " with a whole bunch of letters and numbers after that, .json.

I DO. NOT. SEE. A configuration tab on the Dashboard of the API’s & Services webpage.

Is there a different way you can explain how screwed up I am, or am I just beyond understanding this?

So you can see - when I go to that link in a browser, here’s what I’m looking at - the stuff I did already:


I tried entering that web address (192.168 etc) without the “setup” but it always goes to the website with the “setup” there and the screen you see above.

Got it all set up and running as a test. Created a piston to turn off my living room tv when a switch turns to off and it worked! this is awesome.

1 Like

Follow the wizard. Click next and then add your user and you should be good to go

Ohhh. Click next. I definitely misunderstood you earlier. Thanks I’ll do it!

So I am proud of myself. This is the first time I did anything like this. I installed it on my computer and it worked fine in the sandbox. It took me a while to figure out why it wasn’t working from webcore, until I remembered that when I installed json on my computer, the firewall asked what should be done for public profiles and I said to block it. By allowing this connection, I got it to work. Maybe you can add to your instructions to ensure the firewall allows all for json. Furthermore, my test piston says "Broadcast from Joey… [text I specified]. How can I just say the text without it saying “broadcast from Joey”?

Complain to Google until they remove it :laughing:

It’s coming from their side not mine unfortunately

OK. Thanks! I also noticed that I can send commands (like turn off lights) and it still works even though all google devices have been unplugged! This is great for devices that don’t have smartthings integration, but only Google home!

Before I do this - I want to check on a few things with you…

  1. I have a “client secret” json file in my downloads folder. it’s got lots of letters/numbers after client_secret" in its name. Is it in the right place, or does it need to be in the assistant-relay folder? And - do I rename it?

  2. When I hit “next” as you instructed, I have:
    Setting up your account
    With your client secrets, you can import them into Assistant Relay below
    Users Name"
    I’m not quite sure what to put here. Do I just make up a name that I want to use for assistant-relay? Do I need to rename that client secret json and use that name here? Or is it my user name for my google account? Or something else I’m not thinking of?

  3. For the “select file” button after the user names field, I’m guessing it’s that client secrets json file they want, correct?

  4. Just curious, why is it userS name, not user? Hmmm.

No and no

The name for the user your setting up in AR


Can this be run on Linux?
If so, it would be real easy for me to spin up another Linux VM for this on my primary vSphere ESXi Server.

Yes, should be fine.
You can check compatability here

1 Like

OK, great! Thank you! :slight_smile:


First I want to thank the author for such a great piece of software. I’m relatively new to the raspberry Pi ecosystem but was able to get everything installed and it is running (I think).

However I am having an issue and was wondering if you could assist me in fixing it. While I hate to bother you I really would like to get this to work. Any assistance you could give me would be greatly appreciated!

With that here is my issue-

I cloned the git repository which contained the V3.0.4 version. I followed the install and created the OAuth secret file etc.

I got the initialized announcement from my Google Home device when I finished the “Relay” configuration.

However when I try to send ANY commands for broadcast (sandbox, webcore, etc.) I get the following announcement “Broadcast from user Assistant Relay Initialized” and that is the only message it announces. The terminal also shows the following when anything is sent for broadcast:

> 0|www | [Error: ENOENT: no such file or directory, open ‘bin/audio-responses/1573763246229.wav’] {
> 0|www | errno: -2,
> 0|www | code: ‘ENOENT’,
> 0|www | syscall: ‘open’,
> 0|www | path: ‘bin/audio-responses/1573763246229.wav’
> 0|www | }

What could be causing this and how to fix?

Another issue is that the client start (npm run start) produces the following error:

Failed to compile.
Module not found: Can’t resolve ‘lottie-api/dist/lottie_api’ in ‘/home/pi/assistant-relay/client/node_modules/lottie-react-web/dist’

When I installed both the relay and client I used “sudo npm i” which after doing some research I found I shouldn’t have probably done that. Additionally I can only start the relay with sudo (which makes sense of coure) Could this be my issue?

While I hope I don’t have to do a re-install what would be the best method? From what I have read would deleting the “assistant-relay” directory (minus the OAuth file) and recloning the git repository be sufficient? I of course would need to run through the setup process again without going through the OAuth process and just reusing the file previously created.

Thanks again for any assistance and have a great day!

Hi - did you download the release.zip or the source?
You need this:

I used the following Terminal CMD.

git clone https://github.com/greghesp/assistant-relay.git