Need help with SmartRules for Monoprice Garage Door Sensor

monoprice
garagetiltsensor

#1

I recently purchased a couple of Monoprice Garage Door sensors and am having a hard time using them. Both show up as devices and correctly reflect their open/closed status. However, I have been unable to set up a SmartRule to use them.

I want a push notification to be sent if my system enters Night or Away modes and either one of the doors is open. I created the following

If any of these happen:
Night is activated
Away is activated

While any of these things are true:
Garage2 is open
Garage1 is open

Then do this:
Send push
Message: Garage Door is Open

To test this, I opened one of the garage doors and forced the system into Night mode. While the individual conditions are correct, no push message is being sent.

Any ideas?


#2

What specific automation did you use to set up the rule? Can you post a screenshot?


#3

i used the SmartRules IOS app. The rule is entered as listed in my first post.


#4

Sounds straightforward enough. I don’t see any problem with the logic in your rule. You might try asking your question directly to SmartRules. In my experience they are very helpful and responsive.

http://smartrulesapp.com/contact-us/

Also tagging @obycode on this thread.


(Robin) #5

I think you need to reverse the logic:

If
Doors open

While:
Mode is x or y

Then:
Stuff


( I hate Mondays) #6

Yep, that’s it :wink:


#7

I will try it, but it doesn’t seem to match the condition I am trying to capture. I am not looking for a push notification if the doors open while in Away/Night mode. Instead, I am trying to prevent us from leaving the door open at night. Will this logic capture this situation?


(Robin) #8

No, but your existing logic will only fire when Mode changes so it won’t work either.


(Robin) #9

Perhaps try:

If
Happens every 5 minutes

While:
Mode is x or y
And
Door is open

Then:
Stuff

I’m not sure if Smart Rules has a timer capability though?


( I hate Mondays) #10

It should, provided you change the mode when going to sleep. @obycode can explain more.


#11

The reason I asked for a screenshot, is what you have written in the first post looks like it might be an “and” condition, not an “or” condition. So that it might be it would only work if both garage doors were open, not just one.

Because of what you’re trying to accomplish, you could certainly split this into multiple rules, one for each messaging condition, and that should solve it.

So if it changes to night while door one is open is one rule.

If it changes to night while door 2 is open is a different rule.

And so on. :sunglasses:

But it may also be possible to put all the conditions into one rule, it just depends on the exact set up.


#12

Just tried some additional experimentation…

  1. Tried simplifying the original logic by reducing it to a single door, but it was still not working.

  2. Tried reversing the logic to:
    *If this happens: Garage2 is Opened
    *While this is true: Night is Active
    *Then Push

This does work as expected, but it isn’t the situation I am trying to cover. Again, I am trying to alert us if we have left the garage door open when we go to sleep (Night mode is triggered) or leave (Away is triggered).

  1. Then I tried removing the Garage Door sensor from the equation and made it:
    *If this happens: Night is Activated
    *While this is true: Outlet1 is Off
    *Then Push

This didn’t work…making me think that SmartRules is not processing the Night triggered If statement correctly.

  1. So I changed the Night mode trigger from the equation, making it:
    • If this happens: Outlet1 Turns Off
    • While this is true: Garage2 is Open
    • Then Push
    This works. So it does seem that the issue isn’t with the Garage sensor but with the If statement using the Night mode trigger.

  2. As a final test, I removed the While statement.
    • If this happens: Night is Activated
    • Then Push
    I ran my night routine and verified that Night mode had been activated, but no push message was received.


#13

Well, that is strange. I agree with what JD said earlier, this may take 2 rules, one for each door, but what you are doing isn’t that different from what I do with my ceiling fans. My rule says if “Home” is activated and the temp is above X then turn on the fans. I don’t see any reason you can’t do the same with your doors.

I think, like JD said, we need to see a screen shot of the actual rule to see what it says.


#14

I tried modifying it to the opposite trigger logic (like PhilB is using), and this worked.

  • If this happens: Home is activated
  • While this is true: Garage2 is open
  • Then Push

Very odd. I can only get it to work with the “Home is activated” trigger.

Unfortunately this is the opposite logic that I am seeking.
“Home is de-activated” would be usable for my case, but this doesn’t work for me, and any permutation of Night and Away activation triggers won’t work either.

I’ve sent a note to SmartRules support, so hopefully they will have some ideas.


#15

I’m sure they will be able to help you figure it out. I’m sure there must be a simple explanation somewhere. If it works with one mode it should also work with another. Right this moment the only thoughts I have are that the mode isn’t actually changing to night, or there is some other scenario/rule keeping this rule from executing.


(Brice; SmartRulesApp.com) #16

This rule looks correct to me. To clear up the confusion from the comments above, let me explain what that rule means. The “if any of these” section is the triggers for the rule. These are the things that can start the rule running. Since you want to know of the garage door is open when you switch to Night/Away mode, the mode switch is the trigger, so that is correct. Now the “While any of these things are true” section is the conditions. These are checked after the rule is triggered. The “ANY” indicates that it is an OR, that means that if any of those conditions are true, the action will run. The rule looks good and actually, I have basically this exact rule running at my house.

Could you try opening live logging (https://graph.api.smartthings.com/ide/logs) hen change your mode with the door open and let me know what shows up. I wanted to reply here to clear up the logic, but it’s best to continue the discussion via our help channel instead. I’ll reply there as well.