Motorola Scout/ Hubble integration


(Realy Living Dream) #1

I ordered a Motorola Scout 5000 GPS tracker and Scout 66 IP camera.
http://www.samsclub.com/sams/motorola-c-gps-bun/prod19310074.ip?navAction=push
Has anybody experimented with integrating the Motorola Hubble app with ST ?


(Chris) #2

I’d also be interested in this. We have 2 Motorola cameras that we have to use Hubble for, it would be good to have them integrated


(Scott G) #3

(ᵇᶥᵍ ШΞΒȘГẬŚ (Webstas)) #4

i had no idea that hubble had an api, my device type gets data directly from the camera


(ᵇᶥᵍ ШΞΒȘГẬŚ (Webstas)) #5

I think that HubbleHQ-API doc is for acquiring images from space with the Hubble telescope, i maybe wrong i just did a quick google search.


(Chris) #6

Hi, thanks for the reply

The link is broken. Does this make it so that you can use the motorola cameras with smartthings? Apologies if I dont sound like I know what I’m doing, I’ve only just got smartthings


(Chris) #7

Hey, can’t get it to work, anyone any idea how to do it?


(ᵇᶥᵍ ШΞΒȘГẬŚ (Webstas)) #8

Sorry i was attempting to organize my repo’s


(ᵇᶥᵍ ШΞΒȘГẬŚ (Webstas)) #9

Yep this should make it so you can use your Motorola cams in smartthings


(Chris) #10

Hi this is great, I manged to get the cameras onto Smartthings, only problem I have is its not showing any video feed, the box is just white. Would the camera IP be the same as my PC? thats all I can think could be wrong.


(Realy Living Dream) #11

No the cam IP will not be the same as computer IP. Every device on the network has a unique IP and MAC address.
Log into your router and find the IP address of the camera. The camera’s MAC address is listed on the camera. Look for that MAC address and it will show you the associated IP address.


(Chris) #12

I’ve found the IP address, still no video feed though :frowning: the camera in the list of devices on the app shows ${CURRENTVALUE}

Could this be whats wrong?

Thanks for your help


(Chris) #13

Hi everyone,

I’ve had a bit of a play around, deleted everything, put it back on and I still get the $CURRENTVALUE for the camera. I can see the layout Big_Webstas posted earlier but mine has no video coming through. Any ideas?


(Gary Bernardini) #14

Same here. The melodies all play but the camera box is white with no video.


(ᵇᶥᵍ ШΞΒȘГẬŚ (Webstas)) #15

I have updated the device type to include multiple models and temperature units C or F.

about the video streaming thing, we currently don’t have a way to stream video just a static image :frowning:
they are working on it though (check this out https://community.smartthings.com/t/video-monitoring-v2-hub-intergration-with-existing-camera-systems/)

Currently i’m just using burst images to capture events like movement or a contact opening/closing

you can also use pollster to take images at timed intervals, i have a few of my cameras doing that. this device type will capture an image ever time its polled and will update the temp and wifi strength during refresh


(ᵇᶥᵍ ШΞΒȘГẬŚ (Webstas)) #16

@J88uk - did you get your both your cameras figured out with the new change?

@gary.bernardini if you hit the take button do you get a still image? if not can you send me logs?


(Realy Living Dream) #17

I haven’t gotten around to even trying the old type yet ( still working with Hubble to even get the scout5000 to work at all,so not too concerned with the 66 since it’s working in their app )
That said, if you can pull stills, would it be possible to just grab the stills the camera sends to hubble cloud/app on motion detection alarms ? I’m thinking that might be simpler than polling the camera for your own pictures.


(ᵇᶥᵍ ШΞΒȘГẬŚ (Webstas)) #18

unfortunately they are using an encrypted api call to talk to their servers and they dont have an open api that developers can use :frowning:
I wish they did cause that would open up all kinds of cool smartthings integrations


(Realy Living Dream) #19

Ya, from my dealings they don’t seem to willing to work with anybody about anything. I actually asked them about scout66 integration with other IP camera app like Tinycam when trying to get scout5000 working and they just brushed it off. " they may consider it in the future" . So if they won’t open it up for other camera software I doubt they are interested in opening it up for HA hacks.
Scout5000 is still stuck on Mobile network and won’t connect to Wifi , can’t activate the camera or GPS and after 2 months of " just restart it and it should connect" replies from them, they stopped replying to my emails.


#20

Hi,

I am trying to import this device type but am getting the error below:

No signature of method: script1455485150734402621827.metadata() is applicable for argument types: (script1455485150734402621827$_run_closure2) values: [script1455485150734402621827$_run_closure2@f15bcdb] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

Could you help translate

Thanks in advance!!