Monoprice 10761 Multizone Audio and iTach IP2SL

So is the IP address the address of the iTach?

Thanks for this. Which iTach device have you tested with this? Can you post a pic of what it looks like in the classic app?

I have the Global Cache iTach Flex IP.
Yes it’s the IP of your Itach device

@randper @Its2loud Were you able to set this up on your end?

I did. But I’m torn because I also have Redloro’s Integration working on my RPi, which offers more control through ST of sources and volume. I’m going took into using Redloro’s smart app with this device handler, but that’s going to take some time.

I did too and it’s nice and simple, but I was hoping to get explore the Redloro integration too. Couldn’t get it to install, anyone have a true step by step tutorial on how to setup?

It wasn’t easy and I had a lot of trouble shooting I had to do.

I could copy my RPi disk image for you which in theory would work for your Pi. You would just copy the image onto your SD card and boot it up and change what you’d need to in some of the config files for serial port, zone names and IP address.

PM me if you want to try this. No guarantees it’ll work though.

I got the ST node server running solid now for 4 days straight with no issues.

It’s great that Ilya was able to get the DH made for the iTach unit since I think that’s a more stable approach. Now we just need to make the SmartApp for it.

Redloro’s Smart App looks like this in the classic app. It doesn’t work in the new STSC app

This looks great, and I appreciate your help! I’ve PM’d you.

I got the Redloro smartapp approach working. Now I just need to ensure it’ll always start when/if the RPi reboots.

I’m on that mission myself. Glad you got it working. There’s a post in the Russound forum about getting it to restart on reboot. Try this

Thanks for sharing. This is the approach I used (that worked for me), 2 steps:

  1. Create a scripts in the home folder of the pi user “/home/pi” by:

vi nodep.sh
#!/bin/sh
cd /home/pi/smartthings-nodeproxy
node server.js

  • Save the file, then chmod 777 nodep.sh
  1. Then modify the /etc/rc.local file, you have to do this as root, add this line before the exit 0:

/home/pi/nodep.sh

  • Save the file.

Thanks. Is everything running smooth with the RPi?

Yes, seems like it! I haven’t tried doing any “automating” with webcore yet, but in terms of control via SmartThings, it’s alive!

My first attempt (so be gentle) at writing a device handler so I swung for the fences. :smiley:

Probably was a cleaner way to write it all but it works for me and my use case. I use the ios “Monoprice Whole Home Audio” app when I’m home since it’s full featured, but for remote or Webcore control, I rely on this handler.

I do have to fix the volume/bass/treble control for levels under 10, it sends the command as 5 instead of 05.

To label your zones, just replace the ZONE1NAME with your own and replace the SOURCE1NAME, SOURCE2NAME, etc with your source labels. I don’t think I can use a variable for this.

Set your IP and Port of the iTach under settings

This is awesome! Thanks poelock. I may switch to iTach if my Pi becomes unreliable

This is great… I will test it out tonight when I am home. I’ve been wanting to update my DHT and yours definitely has a lot of great things! +1 for Webcore integration

@poelock I tried setting this up tonight, but couldn’t get it to work.
I copied your DHT, added a device with that type, added the IP:PORT in the settings, but couldn’t get any of the items to work. I even put debug statements in your code to see what was calling and I can see it being executed, but none of the commands were working. I don’t see anything in the hub console. No errors are thrown or any other info statements.
Can you point me into the right direction?
I also used an android app (similar to your IOS one) and that one works.

@oyzerskiy - What do you have for the Device Network Id. I can’t recall if i hard set mine or if it pulled in from the handler but I pretty sure the Device Netword ID needs to be the IP:Port in hex of the IP2SL. ie. mine is set to C0A80028:1387.

Unfortunately, my IP2SL seems to have died or is being a bit finicky lately…I can’t even connect with the app. Also helpful to have Serial-TCP free from Comm-Front running on a PC to monitor the IP2SL and the commands it’s receiving

I dont think you can use the physicalgraph.device.Protocol.LAN protocol. From what I remember reading, there’s a bug in the Smartthings hub where it strips some of the things needed. (see this TCP Commands not transmitting with HubAction?)
You may have to rewrite it to something like this…
new physicalgraph.device.HubAction(“body”: “$theCom\r\n”, “headers”: [ HOST: HostAddress(), “Content-Type”: “text/plain; charset=utf-8”])

Well it was working without issue for me the other day. WebCore turned on zone, selected a source and then played “welcome to the jungle” as I pulled in the driveway. :slight_smile:
It wouldnt accept any responses from the iTach to have proper status updates. But since I was using the “Home Audio” app locally, I didn’t need the current status to be valid in SmartThings anyways. Just wanted to send commands to it.
Unfortunately my IP2SL no longer is accepting commands from anything for some odd reason.

Has anyone had luck with this using either the IP2SL or the Flex lately?

I’m wanting to switch over to the globalcache hardware away from running the pi and redloro’s implementation.

I’ve gotten the android app working fine, so I know the Flex is working. However, I’m not able to get this to work at all.

I’m not exactly sure what the previous post about “new physicalgraph.device.HubAction(“body”: “$theCom\r\n”, “headers”: [ HOST: HostAddress(), “Content-Type”: “text/plain; charset=utf-8”])” means; so any help would be much appreciated!