[Migrated to Custom Capabilities] Rooms Manager: Smarter Rooms: Personalized rules based home automation with rooms Occupancy sensing from devices you already have in your home

Ah, I see what you’re saying. OK, unfortunately still not getting anything even with debug logging.

Steps I took:

  • Create new room “Test Room,” Save it
  • Go back into “Test Room” > General Settings > Turn on Debug Logging, Save it
  • Go into “Test Room” > Asleep Settings > "Set room to asleep at time” to 11pm, Save it
  • Go back into Asleep Settings > “Wakeup room at time” to 8am, Save it
  • Go back into Asleep Settings > Fail with “Something’s Wrong” error screen.

I also tried setting “Wakeup room at time” BEFORE “Set room to asleep at time” and the problem did not occur. So the issue appears to only be when BOTH of these times are set.

This is the only logging I got in the IDE:

  • For Test Room:
    1:14:24 PM: debug Test Room updated: 3185 ms
    1:14:22 PM: info updateRoom Test Room

  • For rooms manager - v1.0.1:
    1:15:07 PM: debug perf scheduleNext: 54 ms
    1:15:07 PM: debug [[type:time, time:Fri Jun 26 20:30:00 UTC 2020, timeS:13:30], [type:next, time:Fri Jun 26 20:30:00 UTC 2020, timeS:13:30, options:[time]]]
    1 1:15:07 PM: debug {“option”:"[time]"}

Anything else to try?

@bangali

I’m getting the same thing with “Something’s Wrong” when I set asleep settings.

@bangali did you get a chance to look at this yet?

Hi, will will we have this working on the new app? currently I only see the room virtual devices only show the on/off option, will it be possible to see and set all the other options (i.e., set to occupied, sleepping, …)

4 Likes

honestly i don’t know. i last looked at them end of July and the new CLI/capabilities etc weren’t quite working.

now getting notification that SmartThings classic app will be shutdown October 14th and i need to migrate to the new app. not sure how that makes sense given the device’s new custom capabilities weren’t quite working as of a couple months ago. but here we are.

going to tryout creating a custom occupancy capability and updating the DTH with it to see how it goes. but since i haven’t done it before and not knowing what works or doesn’t not sure if i will be able to get it working with the new app.

also anyone know how hard the October 14th migration date is and if there is anyway to get an extension to see if i can get the occupancy device working in the new app?

thank you.

1 Like

It’s happening… no extensions.

1 Like

terrific :slight_smile:

couple more questions:

  • is the deadline by end of day the 13th or on the 14th?
  • what happens if one doesnt click the migrate think by then?

thank you.

1 Like

Well, watching ST and their set dates over the past few months… probably a week or so later. But if they do meet their deadline… I would assume at the end of the 14th. It is anyone’s guess though.

1 Like

knowing how deadlines go … someone at HQ is going to lay down the edict that they meet this deadline to make up for all those other deadlines :wink:

1 Like

update: followed the steps on the CLI and custom capabilities thread to update DTH but so far the occupancy capability is not showing up in the new app screens. there are no errors being logged that i can find and the rules seem to continue working.

though not sure it will keep working if i were to migrate.

We are all waiting to see how it does for you.

1 Like

a) dang you’re fast.
b) the beta of the CLI has so many issues with it not showing the custom presentations we’re all waiting on it right now. The least of which is that darn caching issue

Happy to help if you need testing.

1 Like

not going well. i am continuing to see developers who have been building on ST, some even professionally, much longer than i have and they are frustrated with CLI/custom capabilities. so i am currently not holding out much hope for myself.

we have all dealt with bugs in software and know how to mostly work around them. but predictability is the key when reliability is absent. currently both are missing.

2 Likes

a) ehh … don’t even know what i put together is even supposed to be right because there are no errors or warnings but shows no changes on the dashboard or detail view.
b) yeah that makes it near impossible to tell what’s going on.

counting on it :slight_smile:

have you migrated? the classic app is supposed to be turned off tomorrow but i can’t see a way of using the new app with CLI/custom capabilities being in the state it is today.

I have - mostly stable. Ping me in the DM for details - I’ll spare everyone the details. :slight_smile:

1 Like

update: haven’t had any more luck getting the occupancy presentation to show up though the custom occupancy capability does seem to be available. naturally unless the presentation works doesn’t matter if the custom capability is there or not.

i have not migrated my location. this is the second time in the last couple of days i have asked this question. hoping there will be an answer this time:

update: little bit of progress … no longer sees it as a switch … but doesnt know the occupancy value yet …

1 Like

bit more progress … but the latency in capability or presentation change propagation is frustrating … it often creates the impression that whatever change you did last didn’t work … when it simply hasn’t propagated yet …

1 Like

scratch that last post … some serious progress … like i said the propagation latency is frustrating … i had last updated the capability and presentation yesterday evening … followed by cache busting but the details weren’t showing last night.

1 Like

the bad news:

  • manual occupancy changes from the app are not working from the new or old app

the good news:

  • automated occupancy changes from the room devices and app rules are working fine
  • room’s temperature and humidity now shows on the detail view (still haven’t worked on what will show if there is no temperature and/or humidity sensor specified in room devices settings)
    – purpose is to have an unified view of at least devices in a room like in the old app. but because of the new app presentation format not going to be able expose much of the settings like i did in the old app

1 Like