Meross msg100 garage door opener

I just bought 2 msg100 devices. I am not even being able to add them to my smartthings.
@NickSpender, how did you manage to add?

I used the new smarrtthings app -> add device -> searched for meross -> selected outlet -> selected Meross (Devices available in other countries) -> Selected location and room -> Step One (Meross Authorization) -> Next -> Step 2 (End of Configuration) -> Done -> In your Home, meross would like to: Install your device profiles dropdown. But there is nothing in the drop down. Pressed Allow -> Its back in the meross outlet. If I go to check for the device, its not there.

If I’m honest I have exactly the same issue as @ad_me The meross app is ok and works pretty well and is stable. Works with Google assistant too. But with the smart things app meross is useless

After you pass the first authentication. Just keep going next --> next -->
Then when they’re is no more option. Just go back to the home screen and you will see the garage door there in the smartthings device icons.
Your will never get any feedback that it has been added successfully.
Really terrible integration.

@add_me Same issue here. I had been using it via IFTTT with virtual Smartthings switches and everything was working great with Smrtthings, then I decided to simplify things and just use the native Meross device, but like you in only works for a few days then stops. I’m going to go back to using it through IFTTT again as that is stable.

I have exactly the same issue that Manu_George is having. The first time I tried to add this it took no problem. However, it then started showing the door as open when it was closed. I decided to delete and re-add. I reset the Meross Garage Door Opener to factory and tried to add it, but ST wouldn’t just keep looping as Manu described. Anyone figure this out? I have written to both ST and Meross. It got escalated with the ST customer service, but haven’t heard back from Meross yet.

Josh, can you please outline the IFTTT applet you are using to control your Meross MSG100 garage door opener.

I created a Virtual Switch in Smartthings, then in IFTTT I created 4 applets

The first two update the switch status if the door is opened manually (outside of Smartthings)

If open garage door, then Switch on Garage Door Virtual Switch

If close garage door, then Switch off Garage Door Virtual Switch

The next two allow Smartthings to open/close the door

If Garage Door Virtual Switch switched on, then open garage

If Garage Door Virtual Switch switched off, then close_garage

Seems to work well for me

1 Like

I will try this. Meross should be sued for their misleading claim of Smartthings garage door native integration :frowning:
They don’t give a crap about Smartthings. They only care about Google Home integration. It is relatively stable even though the asking for PIN thing is no longer really working with Google Assistant to open the garage door.

1 Like


@Josh_Schadel, I cannot find the meross garage sensor device on IFTTT.
How were your able to do it?
I connected to meross but nothing shows in the selection menu.
See attached image.

Never mind @Josh_Schadel, I was able to add the applets as you suggested via virtual switches and IFTTT. So far so good.
It looks like I will be able to finally use voice as well via Google Assistant.

Hi, i try to configure SCENE in smartthings but the settings only allow to close the door. Any suggestions ?

I installed the Meross MSG100 garage door switch and followed the instructions for connecting it to the new ST app (Ver. and Alexa (Echo Studio) device. I installed the door contact sensor as instructed and connected the trigger wires to my door opener switch contacts, then plugged in the USB power adapter. The setup process was confusing and there were a couple of times when the setup procedure would not proceed due to inability to find the device, yet the device somehow appeared in my ST app after I aborted installation, so I tried to use it. When I asked for the garage door status on Alexa, she replied with, “The garage door temperature is 74.4 degrees.” So there must be a temp sensor in the MSG100 somewhere. When I asked Alexa to open the garage door, she replied, “Garage door does not support that.” I asked her if the garage door was open, and she accurately replied, “Garage door is closed.” So I spent time trying to reinstall the ST skill from Meross, but this time I used the plain Meross skill instead of the Smart Meross skill. Now I finally got the whole mess working, after going into ST app and adding a PIN number to allow Alexa to open the door with voice commands. For those of you frustrated with trying to get this to work properly, I feel your pain, but wanted to share that finally everything works as expected including voice commands to open, close, and check status of door. The one thing I cannot do now, is get the temperature from the MSG100, which was available when I first installed it, but probably not supported by my subsequent reinstallation. My install was in USA on Oct. 14, 2020. Sorry if this post is not very helpful, but mainly I was trying to convey that installation was a confusing mess with mid-installation errors and lack of confirmations, but after a few reinstalls and adjusting settings in the ST app and the Alexa app, finally it all works.

Wow, I just added the Meross a few weeks ago since the Genie Aladdin doesn’t work with ST.
I downloaded the meross app on my phone and then added that to ST. Works perfect. The open and close is instant compared to the Genie. I had an automation to open the door as I arrived home but the geofence reaches out too far and I don’t want the door open that far away.

1 Like

@LonS, @tsummers7008,

Let us know how long this lasts.
In my experience it lasts for about 2 days.
Then you need to delete meross and install
It to smartthings all over again.
I have up after about 5 reinstalls.
I now use virtual switches and IFTTT to make it work
somewhat reliably.

After my installation of the Meross MSG100 on Oct. 14, 2020, it has continued to work flawlessly so far. Today is Oct. 26, 2020, so almost two weeks. I am able to open/close the door five different ways: Meross app, new ST app, Alexa voice command, vehicle transmitter, and hard-wired button in garage. For the Alexa integration, I chose the “Meross” skill, NOT the “Smart Meross” skill. Not sure if that makes any difference, but someone else commented the Smart Meross did not work for them. Alexa requires me to speak a 4-digit security code to OPEN the door, but not to CLOSE. Otherwise anyone could holler at your Alexa to open the garage door. I’m happy so far and hope it continues to work. I have had a couple power failures (thanks PG&E), but once power came back on the door opener and integrations continued to work normally.


I will check-in again in a month.
If it still works without having re-enable it in SmartThings I will try it again.

It’s been 3 or maybe 4 weeks now and haven’t had an issue. In one car the Genie remote quite working so I use the ST app to open the door. I love how quickly Meross opens the door compared to the 10-15 seconds of lag the Aladdin app had. Not to mention how quickly the whole Meross app works compared to the Genie one.

Just to update my experience with the Meross MSG100 garage door switch, it has continued to work flawlessly since installation on Oct. 14, 2020 and today is Nov. 30, 2020, so my confidence rating is high. The software setup and install was a hassle and definitely not intuitive, in my opinion, but somehow I got everything working eventually after an hour or so of attempts and retries.

Thanks for the update!
I will give it one more chance this weekend :slight_smile:


Did you remove the meross integration since late August and perform a fresh install? They released a new integration that fixed the frequent disconnects but it required removing the old version and performing a fresh install of the new one.

One weird inconsistency I have discovered with Meross’ Alexa integration. In the US you can use “open/close” the garage door. In the UK sold version, the command is “unlock/lock” garage door… and open/close doesn’t work (sigh). And of course this is documented nowhere.