Manual works but schedules don't


#1

I just setup my hub and picked up a leviton smart switch. I can manually turn the light on and off from the app. I setup a schedule to turn it on at 8 am off at 11:59 pm. It always turn on as schedule but never turns off.

Amy ideas why?


(Eric) #2

it happens. I have a few devices that I added to mode-based routines years ago, they worked 100% for a couple years, then stopped turning off as scheduled, every time. Even though they turn on by other mode-based routines.

Putting the device in a new routine usually works as expected. Leaving the device in the old routine and trying to modify the old routine, never worked.


#3

I deleted and created a new one and still no go
any other ideasa?

As you can see its set Togo off st 10:36 it’s 10:37 and they are still on.


(Eric) #4

second approach, the failed/lost commands are usually triggered by time schedule. If you convert them to event (e.g. presence fob has departed) then that may workaround. In my case, event-triggers do not fail.


#5

Second test. Deleted it all re started. Did on and off in one task. Saves. Remotes smartthings hub. Still didn’t turn off. I do t have any other devices to trigger events. Just the hub and a single switch so far

[image1.PNG]

Cheers,
Deven


(Michael) #6

Smart Lighting needs your homes location to download time zone and sunrise and sunset data. Did you set your location using the map in the app?

I’d also email support and they can help get you squared away. I have several time based smart lighting rules that work every evening.


#7

I did not… however I told it do turn on a at a certain time (not sunrise). But you may be right as I have not found a spot in smartthings to set the time! So that may be it!! Thanks. I’ll try that today!

Cheers,
Deven


(Michael) #8

You,can also login to the online IDE, click My Locations, choose yours and verify the time zone and sunrise and sunset times there. If they aren’t correct then that is why the schedules aren’t working because it doesn’t have your correct time. The only place to set these is in the app, click the More button at bottom, the the gear at the top, use map to set your correct location and save.