Lightify contact sensor not using Zigbee repeater

I have several of these that are working fine. Yesterday I added one that is about as far from my hub as is possible in my house and it has lost it’s connection (I connected it while closer to the hub).

I added a repeater nearby and removed the battery, but it didn’t connect. I also removed and tried to connect again while close to the repeater, with no luck. I also tried with a peanut plug which I think is also a repeater.

Is there a trick to this? Or does the contact sensor not work with repeaters?

The repeater I started with is this one: Control US/CA 3A Smart ZigBee 3.0 Plug / Outlet with SmartThings

Thanks for any suggestions. I’ll continue to experiment

The first question is how far away is the repeater from the next repeating device?

The repeaters don’t have a longer range then the battery operated devices. They just have the ability to pass a message on to the next guy. So you need to build a chain out from the hub with at least one repeating device about every 40 feet.

Did you test to make sure that you could turn the repeating device on and off from the app?

If the repeating device does work OK, then you need to force a network heal.

Just unplug your hub, including taking out any batteries if it has them from the hub, and leave it off power for about 20 minutes. Leave all your other devices on power, including leaving your battery powered sensors on.

This will cause all of the other zigbee devices to go into “panic mode” because they can’t find the hub.

Then when you put the hub back on power, everybody will rebuild their neighbor tables and find out who their true nearest neighbors are.

This process can take a while, so you may not see results until the next day. But it should clean up all of your routing tables and enable your distant devices to reach the hub as long as there is a path of repeaters available.

Read the range FAQ, it should clear up a lot of questions. Start with post 11 there, then go back up to the top and read the full thread.

( and to answer your specific question, all zigbee devices which are compatible with the smartthings hub are able to use repeaters, that’s part of the specification. :sunglasses: )


Can you try to reset the plug, then add it again?



It appears to be an issue with this specific sensor. I had another unopened sensor and I was able to successfully pair it to the hub with no issue. I reset the first one, paired it while close to the hub, and it is still behaving oddly. I get sporadic readings from it and they seem to bunch up, I can run the magnet across it several times and get no change, then 5 minutes later I get a burst of open/close messages in the log.

I’ll chalk it up to a bad sensor and move on. I got these things cheap so no big deal.

1 Like