Latest advice for virtual 3/4 way switch setup w/o hub?


#21

Understood. It’s not an easy question right now, the entire DIY industry seems to be in flux. Good luck with your project! :sunglasses:


#22

JD, simply put…I don’t know how you do what you do. With just the little that I know of your situation I can only say that you’re an amazing person. As many people before me said, you are the heartbeat of this forum/community, and without a heart we’d be doomed.

I know this isn’t necessarily the place for this post, but just seeing your involvement in this post kind of struck a chord and I felt a need to tell you, and every other member how lucky we are to have you.

T H A N K S

Happy holidays and may all of your automation wishes be fulfilled…and by the way, don’t wear yourself out, we need you!


(Adrian Garside) #23

Indeed. You’ve been providing comprehensive advice in every post I’ve ready while researching this! It’s clear you’re an integral part of this forum and have helped many people get their automation on.


#24

If you truly just want a wireless 3 way switch, why not just use a device like this:

http://www.amazon.com/SK-8-Wireless-Anywhere-Lighting-Control/dp/B0052ROEB2

Provides wireless control of a switch from a remote that is directly linked to the receiver. No hub necessary, no programming required.


(Adrian Garside) #25

Well, I was able to use the minimote to include the WS15Z5-1 and the Eaton RF9500 into the minimote network with it as the primary controller. However the instructions to direct associate the two by hitting the top of the WS15Z5-1 4 times rapidly and then the RF9500 once or twice didn’t work. The LED behavior that was described in the WS15Z5-1 manual didn’t trigger. And later in the manual it says a quadruple tap actives firmware update mode and describes the same led behavior (two flashes / second that didn’t occur).

This was the bit from the WS15Z5-1 manual that I hoped against hope would work once I had a network set up using the minimote:

Creating Associations

  1. Learn all devices into the Z-Wave Hub.
  2. Tap the paddle of the WS15Z5-1 four times quickly to enter Association mode.
    The LED will begin to blink quickly (twice per second).
  3. Follow the instructions for inclusion or exclusion of the device to be associated.
    For GoControl devices, tap the button one or two times.
  4. Repeat Step #2 and #3 for up to 5 total dimmers and / or switches within 60
    seconds of entering Association mode.
  5. Association mode will turn off after 60 seconds or when a node has been
    associated.

(Adrian Garside) #26

I gave up trying to get the RF9500 to play nicely. Instead I wired in the WT005Z-1 that I’d also purchased. I was able to get that to associate with the WS15Z5-1. Quadruple tapping either top or bottom of the switch did start flashing the LED twice a second as the manuals say should occur. And then some number of taps (supposed to be 2, but I think I did more) on the WS15Z5-1 got them associated. Now both switches turn the power on and off.

The one minor niggle is that the LED on the WT005Z-1 doesn’t go on when the lights are off if the WS15Z5-1 was the switch used to turn them off. I thought I read somewhere, not sure where now, that I’m supposed to be able to associate in both directions to get the LED to be properly synchronized but I couldn’t get that to work. The WS15Z5-1 continues to refuse to enter association/firmware mode with a quadruple tap as the manual claims it should.

For giggles I tried to associate the RF9500 with the WT005Z-1 since the latter seems to be behaving itself but I still wasn’t able to get anything happening there.

Still… I now have a 3 way switch configuration for the kitchen which is a huge step forward. And my wife changed my mind about the RF9500 anyway. She’d have preferred that where I was going to put the WT005Z-1 and wanted the WT005Z-1 instead put on the other side of the wall (next room) to where I was going to put the RF9500. So I think at this point I need to just give in and do it right - replace the existing old construction boxes with new construction boxes that are one gang wider and have WT005Z-1’s in both of the locations without having to permanently remove a switch there.

Or I replace a pair of the existing switches with a single gang double switch of some kind. I’m not sure what options there are for that or if I’ll like any of them.


#27

There are no All in one double gang switches in the American style. Instead, you just get a doublegang face plate and put any two single gang switches you like side by side underneath. :sunglasses:

41e5fe4d3f2e87be

Read the user manual for each Switch: you may have to trim the heat sinks to get them to fit, and if you do, that reduces the load capacity.


#28

Sounds like you’re making progress! :sunglasses:

As far as what happened based on your last report…

1st secret of Home automation: the model number matters.

2nd secret of Home automation: read the manual.

19th Secret of Home Automation

Almost all Home automation manuals are poorly translated into English, but if it says “one or two taps,” it doesn’t mean you can do either: it means tapping once will produce one result and tapping twice will produce a different result. Be precise in your own actions.

Everything you saw was expected behavior.

EATON RF9500

The Eaton RF9500 is a battery operated remote. NOT a master switch. You can’t turn it on from a network command the way you can a wired switch: it sleeps most of the time to save battery life. So it can never be the target of association.

In a virtual 3 way, the RF9500 substitutes for the WT00Z, the accessory: not the master. It is a trigger, not a target.

It was “behaving itself” just fine. :wink:

The WS15Z5

This is a load bearing Switch that can act as either a trigger or a target for association.

In the case of the WS15Z5, one tap associates binary on/off switches into association group 2. Two taps associates dimmer (or multilevel) switches into association group 3.

Four taps does a firmware update on that model. Associations are stored in firmware. That’s why four taps starts the association process on that model.

I can’t tell from your description just what you attempted (the exact number of taps do matter), but I believe it, too, was acting as intended.

But you should not be using it as a trigger in your setup. That’s because (read the manual) the tiny LED light on the accessory is governed by internal parameters on these specific models.

Moving forward

At this point, you probably need to use the tweaker to determine exactly how you’ve set the “night light” parameter on each device. It would be a good idea to check the association groups as well to make sure they’re right. :sunglasses:


(Adrian Garside) #30

I’m pretty sure the WS15Z5-1 is not behaving correctly. Even the factory reset steps don’t work. The LED doesn’t behave as described when performing those steps, nor does the factory reset actually work.

Ah yes, that makes perfect sense for the RF9500. Note that I was able to associate the WT00Z5-1 with it successfully but all that did was introduce delays as the WT00Z5-1 started trying to talk to it whenever I clicked it and it’s not going to respond since it’s in battery saving mode. The same steps (pointless as they are) didn’t work on the WS15Z5-1 as it’s not behaving correctly - the 4 taps to enter firmware mode / associate on that has no effect. But I am able to remove and re-add it to the minimote network so it’s not completely misbehaving, which is odd.


#31

It could just be a bad device, it happens. It could also be that all of the various tapping has set the parameters in a strange way. If it was me, I would first factory reset it, then do a general exclude on it, then start all over following the procedure in the manual exactly and noting with the LED does it each step. Including the initial joint. But if you don’t want to go through that you can just exchange it.

Good luck!


(Adrian Garside) #32

That’s the thing - I can’t factory reset it. The steps listed in the manual do not have the effect that it describes and it doesn’t get reset. So either I live with it - the only real downside I can think of is that the led on the accessory switch won’t be synchronized or I probably have to return it.


#33

You’re sure it is a WS15z5, not a WS15z-1, right?

If so, what happens when you reset exactly as follows?

In the event that your primary Controller is lost or otherwise inoperable, to reset the WS15Z5-1 and clear all network information, follow these steps:

  1. Tap the top of the switch five (5) times.
  2. Press and hold the bottom of the switch for 15 seconds. The LED will increasingly blink faster to indicate that a Reset is taking place.

If you don’t want to do that, and I understand if you don’t, what settings does the tweaker show for the mains powered devices?


(DavidK) #34

For the regular zwave linear switches I do not think there is a way to always ensure the indicator led are in sync.

At least with the old models I have there is no way.

The no load switch wirelessly controls the other switch witch in turn physically controls the load. But the switch that physically controls the load cannot wireless control the other switch in order to keep the indicator led in sync.

Also, you really should purchase a hub, and use zwave tweaker, much easier than minimote association.


(Adrian Garside) #36

As I stated before, the WS15Z5-1 I had was clearly faulty as nothing initiated by the load switch itself worked. So I could add it into the minimote network and associate it as the target of the accessory switches because those actions were not initiated by the faulty switch. But I couldn’t associate it to target the accessories and couldn’t even do the factory reset.

I got a replacement and returned the faulty one. The new one works perfectly and now behaves exactly as described in it’s manual (and exactly the same as the accessory switches). I can now associate it successfully with the accessory switches as targets which means their LEDs are now in sync with it. And since I added a second accessory to create a virtual 4 way, that meant I also had to also associate each of the accessories with the other accessory (both directions). That means any combination of switch usage still has the correct LED state on all switches as every switch is notifying both the other two switches when it triggers a state change.

So to summarize, here’s what I did once I had the working replacement:

  1. Removed the two accessory switches from the minimote network. This also removes all the associations with the older faulty load switch.
  2. Re-added the two accessory switches and the replacement WS15Z5-1 to the minimote network.
  3. Direct associated every pair of switches in both directions following the instructions in the switch manuals (it’s the same steps for both accessory and load switch). So 6 associations in total, all performed the same way.
    With that I have a working and near instant virtual 4 way circuit with the LED states on all switches always being correct (on when the light is off and vice versa).