SmartThings Community

Kasa switches and outlets

(Joe) #21

Tyler, I found my issue.

I pasted the wrong thing in the service manager code area. Now its working, thanks!

(Dave Gutheinz) #22

Thanks, Tyler

( #23

Thanks for your work on this - just did it without any issues (took about 2 minutes) other than a minor “You are not authorized to perform this function” on the install, but which doesn’t seem to have meant anything.

(Joey) #24

David any chance of adding the New TP Link HS 300 Surge protector power strip?? Thanks.

(Dave Gutheinz) #25

I do not have the technical details. Would love to add.

Have you tried to install? If so, can you identify the plugs that are identified during the install process (will probably fail after this step). This will help me in identify if the plugs are independent WiFi entities or a single WiFi entity. May be as simple as adding a line to the Connect app.


(Joey) #26

Hi david thanks for quick response. Yes when I try and add devices it shows the power strip but when I hit save I get an error message. In the app you created it does show it as one device but the strip itself has 6 individual plugs ! I attached some photos for you


(Dave Gutheinz) #27

Sadly, it is a different command structure (may be same commands, but different packaging) that I do not currently know. I will not be able to get to until after the first of the year. Will revisit then. Please remind me.


(Dave Gutheinz) #28

TP-Link / Kasa Bulbs and Plugs Control now supports the new SmartThings phone application.

Update instructions:
A. Replace the device handlers with the new ones from the link below.
B. In the CLASSIC App, exercise each device (run a refresh).
C. Go to the NEW App and see if you can control the devices.
D. If not, Remove the devices using the IDE. DO NOT remove the Smart App. Then re-install using either the New or Classic App.
Note: To delete individual devices, you will have to use the My Devices page on the IDE or the CLASSIC app. The new app can not delete.

HUB Version

Cloud Version


Is this possible to add the repository to the IDE so we can update it there? I have been trying to add the repo and it does not give me any results.

Thanks in advance.

(Dave Gutheinz) #30

Do not know what you mean?? The SmartThings does not support repositories. Are you talking about GitHub integration?


Yes, sorry that was what I mentioned. I use the Github integration to follow when updates are posted and automatically update the local version I have being used. I didn’t know if this was available with this app.

BTW, this app is fantastic and I can not tell you how much I appreciate your work on this. I have two types of switches and with this, I was able to integrate the two to control my kitchen undercabinet LEDs.

Also is there any issue if I mention this app in a review on Amazon? I wanted to ensure people who purchased this switch knew it could be compatible with SmartThings. Thank you in advance.

(Dave Gutheinz) #32

good. github is available. My name there is davegut. I am in-process to updates to the Device Handlers (Samsung Connect) plus a co-developer update to the Smart App (more bells and whistles, improved maintenance). Should publish on Sunday.


Awesome, thank you very much for your help. Great app.

(Mark Goldstein) #34

I was able to get to the TP cloud app in smartthings classic and when adding my four TP Link outlets, hit save and says automating but then a red banner with ‘unexpected error as occurred’ comes up. I have tried several times and also one by one outlet and still the same. Any thoughts?

(Srinivas) #35

I am having the issue while adding he devices. I have installed the handler and the smart apps in IDE. Downloaded Smarthings Classic for Android, went to myapps, i can see the TP-Link app there. I tried to login using the TP-Link account but i get an error saying something went wrong.

This is what i see on hte live logging
java.lang.NullPointerException: Cannot get property ‘id’ on null object @line 660 (getToken)

Any help is appreciated

(Dave Gutheinz) #36

Line 660: " def hub = location.hubs[0]"

I believe the error is indicative that the application is not connected to a hub. In the IDE, you must first go to My Locations and select your hub, then to My Smart Apps and install the Smart Application.

If this is not the case, please let me know.


(Dave Gutheinz) #37

Did you get your issue resolved. I missed the post.

(Srinivas) #38

Thank you Dave that resolved the issues


Hi. Thank you for creating this link to TP Link Kasa.
I’ve successfully installed it and can see my bulbs in the app.

I thought I’d be able to create a routine to set all my bulbs to the same brightness as the one bulb I have that uses Cadence setting.

I can’t find a way to do this. Are you able to offer any help to get this working please?


I’ve sorted it now. I use The Big Switch template to set the brightness of other bulbs when the Cadence one changes, then used Power Allowance to turn them off after 3 minutes (because it turns them on when the brightness is set)