Kasa devices suddenly offline

On Friday all of a sudden my Kasa devices showed up offline in the smartthings app. It’s not wifi or anything since when I go into the Kasa app they all show up online. I can turn the lights on and off from the Kasa app. I tried re-adding Kasa without deleting first but that didn’t help. If I have to delete Kasa altogether and then re-add, I’ll have to re-do all of my automations. Which is a pain, but if that’s the solution, I’ll try it.

Any other ideas before I take the nuclear step?

Do you have a SmartThings/Aeotec hub, and if so, which model?

Yes, a SmartThings hub. Not sure which model and I’m not seeing that information in the app anywhere.

two things to try:

  • go to Menu > Settings > Linked Services and tap on the Kasa integration (don’t select edit, simply tap on the linked service) and tap Done on the screen of your Kasa devices. But since you tried adding the linked service… that should have accomplished the same but this method is simpler.
  • reboot your home router

contact ST and TP-Link support if you continue experiencing the offline status

for the model info, look on the label on the bottom of the hub.

Since you have a hub you can use the following Edge Driver for your single end point Kasa devices.

Wow, rebooting the home router worked. That’s really weird since the Kasa app works through wifi and that was always working.

Thanks for the suggestions!