Is it possible to Stop Alexa from making that little acknowledgement sound when Triggering an Alexa Routine by Voice Command?

[TL;DR: see the title of this thread :slight_smile: ]

Disclaimer:
I know this is the SmartThings forum, and NOT the Amazon Alexa forum, but I’m posting in here, because I know a lot of you here in this Community use Alexa in ways that a lot of ‘regular’ Alexa users might not ever get around to. :slight_smile:

Background:
I don’t like the fact that Alexa is not consistent in how it responds to me saying ‘Thank you’.
If it responded with ‘You’re welcome’ all the time, this admittedly quirky project I’m working on now probably wouldn’t have ever come up. However, the fact that it comes back with things like, “No problem”, “Anytime”, and “You bet!” is annoying to me, personally. So, I set out to see if I could change that behavior.

Viable Solution:
At some point, I discovered ‘Blueprints’, and ‘My Questions’, and was able to use that to get Alexa to just say ‘You’re welcome’ as its only response to me saying, ‘Thank you’. So, that was really cool, and it satisfied me for a while, but then…

Added Complexity:
I recently discovered that I could programmatically cause Alexa to say things with other accents through using Echo Speaks and webCoRE. So, naturally, I set out to create an automation for my ‘Thank you’ -> ‘You’re welcome’ exchange in Alexa. lol

How:
To do this I created a simulated switch in SmartThings (the mechanism for passing the activity off from Alexa to SmartThings), a routine in Alexa (that acts on that switch when said routine is triggered by voice command of ‘Thank you’), and a piston in webCoRE (that monitors that switch in SmartThings, and fires off an Echo Speaks command to the Alexa-enabled device of my liking to say, ‘You’re welcome’ in a British voice; Emma, in this case).

Results:
Now, when I say, ‘Thank you’, Alexa runs the appropriate Alexa routine (which, in turn, fires off the other stuff, and it’s pretty cool).

Problem:
However, when it runs the Alexa routine, it always makes that little acknowledgement sound.
So now, the exchange goes
Me: “Thank you”
Alexa: *acknowledgement sound
Alexa: “You’re welcome”

Not a huge or important issue, but one I’d like to modify if at all possible.

Attempted Mitigation:
I turned on ‘Brief Mode’ in Alexa, but that only appears to work for other stuff.
i.e. even with Brief Mode on, it still makes that little acknowledgement sound when running Alexa Routines that are triggered by a voice command.

Question:
So, do any of you have any idea whether it’s possible to stop it from making that little acknowledgement sound when triggering an Alexa Routine by voice command?

Hmm, I don’t recall hearing Alexa say anything in brief mode. I say this and that and she just do it while acknowledging in a short tone.

I guess I am only asking simple stuff. :rofl:

1 Like

Haha, thank you! :slight_smile:

Doh!
I just tested again, and now, it’s only making a sound, and NOT saying ‘OK’.

I guess it must have just taken longer than I was OK with to change the system after I turned on Brief Mode.

Still, I’d rather not have it making that sound every time either.

Any ideas on that?

p.s. OP edited to reflect these details :slight_smile:

Interesting…I tell Alexa to “tell sleep sounds brown noise” and no other sounds other than the brown noise starting.

1 Like

Correct.
Same here.
However, unless I’m confusing things, I don’t think that’s what I’m talking about.

I’m pretty sure you’re talking about commanding Alexa to access and use an Alexa Skill.

I’m talking about when triggering an Alexa Routine (i.e. the user-built automations within the Alexa Routines area of the Alexa system) by voice.

DOH! My bad. I am also interested in silencing the entire confirmation response on a case by case basis.

1 Like

I’ve played with this a bit and if you were to silence the ding-esque sound then you’d not know if the action you’ve directed to be achieved was in fact completed successfully. The brief mode essentially only does two things and only in the event of what thing (not to be confused with a classic “thing”).

If you tell your Echo to do something like turn on your TV, Play something, tell you something or run a blueprint it shouldn’t make a sound (in most cases). BUT, if say you tell it “Turn on Front Lights” then it will make an audible and distinctive successful sound. If however you tell it “Turn on Front Lights” and it understands you to be saying “Turn on Fight Lights” (and you don’t indeed have fight lights…which you should) then it makes a distinctive almost disappointing different sound all together.

The distinctive sounds can be HUGELY helpful if especially you have a device named something fun like “You Turn Me___” then the echo will almost rarely get that accurate or if you try and teach your kiddos stuff using tech because, why not so we named our bathroom vanity (his/hers), “Daddy Potty___” and “Mama Potty ___” . Those names only taught our kiddos 4 letter words in frustration from the disappointment sound. Still I did say helpful, and yet no aid yet given so…you take the stuff that most often doesn’t work successfully, then go to your Alexa App==>Settings==>Alexa Privacy==>Review Voice History and select date range. Now you can see what your “Alexa” thought you said and make decisions to rename devices or learn to enunciate the repeat offending words better going forward. I’m often tired and chose to rename devices to “Mommma Pottee” and “Daddee Party” to see which variation worked best and both have worked without disappointment dings since.

If you use your Echo to lock doors, close garage, arm alarms and more important stuff than lighting your commode then those sounds could be vital to making sure you stay safe. Even if you are the person who always double checks the app to make sure that your night mode scenes, IFTTT, etc always work because it just takes the one time you didn’t check. Though I suppose if you set up a If you Didn’t check Then something sprays you awake. I digress.

I find the sound to be excessive at night, when the roommates (children, dogs n other half) are asleep so rather than eliminate the sounds altogether I’ve been trying to make a blue print that changes the sound to something less, or nothing for the “success” ding and only a ding when it didn’t work.

Follow me down that rabbit hole and lets race for the cure as a team. I’m sure someone has already sorted this out and is just chewing on their humble pie.

1 Like

Thanks, @OldDog_NewTricks

Ya, that’s the thing. I guess I wouldn’t mind so much having it still do the FAILED ding, but the SUCCESS ding is just redundant in my world.

If the automation doesn’t fire off, then, ya, I will need to look for where it broke down, and having the FAILED ding right there might be helpful for troubleshooting.

However, I don’t need the SUCCESS ding, because I will know that it worked when the rest of the automation fires off.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.