Is IKEA 304.883.63 supported

I just bought a new switch from IKEA, but I have so far not been able to connect it to my ST hub. Is this not yet supported?

The app says I should press the pairing button four times, but the manual says I should press and hold the buton for 10s. Neither works.

If you mean the new Styrbar four button switch then there is a custom handler for it. Styrbar 4 button remote

Sounds good, but how can I use it?
Skall I install it in my hub ? How?
Will it show up in my SmartThings app?

There are several tutorials how to install custom device handlers. It is done in Smartthings IDE. Basically it is a copy and paste type of procedure. :blush:

Is it the web based SmartThings Groovy IDE you are referring to?
Shall I add the device handler by clicking “Add one” on “My Device Handlers” tab?

Yes and yes. And there is tab “from code”, just copy paste code of the handler. Then press create and finally press publish from top of the page and it should be working. :thinking:

Thanks a lot for your help.

Now I have created and published the driver and it is listed on the tab “My Device Handlers” as Published. But when I open the handler I am getting the following warning:
DTHs set to run locally, when used with incompatible devices, may cause local rules to not behave as expected. If this occurs, remove the local flags, re-publish the DTH, and re-save the rule.

When I open my SmartThings app and try to add the device, I still can’t find it in IKEA supported devices.

Do I have to do something more or how do I proceed?

This is copletely normal.

Just put Styrbar in pairing mode and scan nearby. I’m pretty confident it will be found. :thinking:

No, I have to activate listening to pairing in my app, and for that I need to tell the app what device I want to add. I’ve tried to press the pairing button on the device but the indicator lamp will not light up.

Styrbar manual says pairing button has to be pressed for 10s to get in pairing mode. Have you tried that?

Yes, but I don’t khow to set the hub in scanning mode unless I have a device to look for.

Add new device,

Scan nearby option sets your hub in pairing mode. When Styrbar is in pairing mode hub will scan and find it.

No, it only finds my Sonos which is already connected and is a LAN Device.

Pressing the pairing button for 10 s while the hub is scanning do not activate the LED on the device.

Previously I actually tried to connect my device as a Samsung button. Then the LED was turned on, but the resulting button in my app acted very strange and only detected the battery indicating 50% for the new batteries.

How can I get the Device Handler show up as an IKEA Remote/button?

If the button has already been added and shows up in the app

  1. Go into the IDE.
  2. Select My Devices tab.
  3. Locate your button and click on the name.
  4. Scroll to the bottom and select Edit.
  5. Scroll down to Type and use the drop down menu to select the device handler you created. (It will be toward the bottom of the list.)
  6. Scroll to the bottom and select Save .
  7. Go back to the app and see if your button works.

If the button is NOT already in the Smartthings app,

  1. Go to the + to add device.
  2. Select Scan Nearby.
  3. Put your button in pairing mode. You may have to try a couple times.
  4. Once the button is added, follow the steps above to change the device handler in the IDE.

Since the button didn’t work, I immediately removed it from the app and then it also disappeared from the “My devices” list in the IDE, so my button is not connected to the hub.

I have now tried numerous times to connect the IKEA button but to no avail.
I have repeatedly pressed the pairing button for 10 sec but the LED do not turn on and the button is not found in the app.

The only device found by the app is my Sonos and the app says it is connected directly to my phone. I suppose this means that it is not found via the hub.

This is really interesting. Something is not right here, I might even go to Ikea and buy one just to see can I make it to work :thinking:

I know it is a new button but have you tried replacing the battery since the LED isn’t lighting up?

Yes, I have tried two sets of batteries, but I guess sometimes a product could be faulty from factory.

Do anyone know if the LED always should be lit after pressing the button for 10 sec or if it is required that the hub responds in some way before it turns on the light?

I have no idea. Other Ikea buttons need to be pressed four times to get in pairing mode. You could try that. :thinking:

No I’ve tried that (see initial post).