Iris Smart Button

I’m assuming that’s where you can change temperature reporting intervals. If I’m wrong, how do I? Is this a CORE device interrogation function?

Let me get some more info first, how are you currently getting temperature data? Through what device/app? And may I ask am I addressing a basic user or advanced user? Hard to tell without talking :slight_smile:

I’m not a programmer, I would assume the device only wakes up to send data if the temperature changes?

You might have to look into something that polls it, to wake it up since its battery powered.

how do you update a custom device handler?

where do you enter the code at?

Ken, you might try this and see if it helps Using Custom Code.

1 Like

Thanks a lot got it

Hi All,
I have just got one of these Smart Buttons, have managed to pair it with smartthings - it showed up as Iris Smart Button without any DTH.
However I am now unable to use the button as it doesn’t report temp, or any of the device presses or holds.
When I hold the button I see a red light on the device but no presses reported anywhere.
Any ideas here?

That sounds like it’s not paired correctly. Did you try removing and resetting it?

Yes I did try to reset following the instructions - maybe it hasn’t reset correctly - are there any tips to the process of reset and then pair?

I have now managed to get this reset and paired correctly - battery and temperature are reporting but device presses arent working. i see a red light on each press - is this right?

Have you made a rule?

Doesn’t sound right but maybe try to set a rule up and see if it executes properly.

I had a couple of Iris Buttons just stop working. Pulled the battery and popped it back in and then it works. This was more prevelant when I had a weak zigbee mesh. Now both my zigbee and z-wave meshes are solid. Try doing a zigbee mesh repair by unplugging the Hub and taking about batteries for a couple of minutes. This will force a repair of the zigbee mesh.

Hi rontalley,
Yes i have made a rule and it doesnt do anything, I may just have to use this as a temp sensor!
I have tried the zigbee reset and also use the button right next to the hub.

I’m new to posting on ST. But I just ran into a complete headache with Iris Smart Button v2. I paired it initially just fine. Then removed them and reset my ST account to separate work and home better. I tried to reconnect and no luck. I looked everywhere and tried everyone’s advice and even called Iris help; no luck. So I ran across one post and thought I’d spread the info because it worked. But the button is EXTREMELY finicky as to the timing and order you do things. I just had to do it 3 times for 3 buttons and this process worked like a charm.
You do have to remove the battery for just a few seconds, then press the button while reinserting the button. But you only hold the button down until you see the red light turn on. Everyone else says hold for 2 seconds. Wrong. You have to release it immediately. It will start flashing blue instantly and then green and reconnect. If you hold that button at all it just flashes red forever. The other poster said to then push the button 12 rapid times. I found it connected with this step and without. But if you’re superstitious, you can press it to make you feel better. If it turns red at any time, just remove the battery and restart. It does take about 1-5 minutes for the hub to connect it.


I keep getting this error when trying to add this smart app in my IDE;

No signature of method: script_app_metadata_c07981fc_2ef0_499a_8080_548ca7f2801e.metadata() is applicable for argument types: (script_app_metadata_c07981fc_2ef0_499a_8080_548ca7f2801e$_run_closure1) values: [script_app_metadata_c07981fc_2ef0_499a_8080_548ca7f2801e$_run_closure1@1b27ad34] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

I am very new to this and not sure what I should do to solve this issue. Any help would be greatly appreciated.

That’s because this isn’t a smart app, it’s a device type handler. :sunglasses: See the FAQ: it should clear up the confusion about the difference between these. (The topic title is a clickable link)

1 Like

Thanks JD, that is what I needed to know. I got one of the Iris smart buttons to work. It was an older beta test version. For some reason I can’t get the other two, newer version, to go into paring mode. Any ideas?

Hey Mark…I came over form Iris…I had the second generation of smart buttons by iris…I got them paired and operating just like under iris…when pairing choose iris devices and I selected motion sensor. it paired much easier than with iris…it takes a few seconds but it paired.

Once you get it paired, go to the device on your dashboard and bring it up…in the middle of the page there are three choices…pressed, held and one other…choose which action you want to do and it takes you to another screen. “if” - should have what you selected…pressed, held. etc. “then” - select the device you want to control and then turn on power state to that when you press or hold it either turns on or off like it did under iris… has been working great!

you might also have to check the batteries to make sure they are working…that might be the issue with pairing…i had to change some of mine out to get them paired.

Hope this helps!

Thanks Nancy, I finally got all of them to pair. I had to plug the Iris hub back in and pair them to it then force delete them one at a time, then they would pair to the Smartthings hub. They work OK, but sometimes are slow to actuate the commands. I have used the Smartthings smart buttons and they work immediately when pressed. I guess this is something I will have to live with since they were not designed for the Smartthings ecosystem. Thanks again for the advice, it is greatly appreciated.

1 Like