iPhone presence sensor not working anymore

Anyone have any clue how to get this up and working again?! Was fine for a year or so and now boom my phone and my wife’s phone presence sensor doesn’t work at all… can’t use Life360 anymore either… how are you all triggering your routines?! Thanks!

As of approx 5 days ago the presence detection for my wifes iphone stopped reporting so all Home/Away automations stopped. Have tried deleting her app, reinstalling, renabling the location services etc to no avail. Even went into IDE and tried to delete her placeholder and still no change. looking at my working placeholder and her faulty one their seems to be slight differences.

Were you using Life360 previously and then it stopped working when ST shown groovy smartapps 2 weeks ago and now you are trying to enable the presence sensor through the ST app on the iPhone? Or were you using the presence sensor through the ST app and it stopped working and you never used Life360?

If you are trying to use presence through the ST app, go to Menu > Settings and enable “Get location for this iPhone” and ensure you have given it the proper permissions under iPhone > Settings > Smart’things.

Consider creating a virtual presence sensor for both iPhones so you can see the correct status for each in the ST app. You will need to create 2 Routines for each; one to set the virtual presence sensor to “Present” when your presence arrives Home and another to change the virtual presence to “Not Present” when the iPhone presence departs. below is the link to a good virtual presence sensor you can use:

[ST Edge] vEdge Creator: a virtual device generator for end users

Another possibility: if you have an Apple TV or one of the homePods at home:

How to Use a Meross Plug to Use HomeKit Presence to Trigger ST Routines

yet another possibility is to install an Edge driver that detects when you connect to your wifi network:
[ST Edge] LAN Device Monitor - #47 by TAustin

and finally there is IFTTT should the integration get fixed so at the time of this post, IFITT is not functional and they are working on restoring it.

best method I have seen:

  • screenshot any Routines that contain presence before starting
  • disable "Get location for this iPhone:
  • remove ST app
  • reboot iPhone
  • check IDE (while still available) to ensure old presence sensor was removed
  • reinstall ST app
  • enable “Get location for this iPhone”
  • rebuild your Routines

Presence can be tricky so there is never an easy fix. I am just pointing out the best steps “I have seen” to try and get it working. May or may not resolve any non-working presence for anyone :slight_smile:

1 Like

Very true. I just happened to notice this morning that I went down a device, but I didn’t delete anything recently. It turns out that my daughter’s iPhone is no longer a presence sensor and all the automations using that iPhone were no longer available.

I can’t get a hold of her yet, but when I do I’ll look through these steps. Timely post, thank you.


alright… so I deleted the iphones from the IDE… removed the apps and re-enabled use location. The phones showed up in the IDE as “placeholder” i changed the type to mobile presence. These phones do not show up in the smartthings app. I made simulated presence sensors for each phone however in the app they show as offline. Actually quite a few, but not all of my simulated devices are showing up ass offline now…even though they are working… not sure what is going on with ST lately.

You can’t change them in IDE. They need to stay as Placeholder.

Ah ok thank you… changed them back to placeholder. Any clue how I can get my simulated devices not be offline? I am trying to see if the presence works now but cant make a routine because the simulated switches for them are offline. I should mention that on the IDE page they all show up as ONLINE…

I would recommend switching simulated over to virtual Edge Drivers. I posted a link above to vEdge.

Also under the IDE for the iPhones I see there is no data and no states found… so I am going to assume they are not working sadly

IDE is in the process of being phased out. It does not reflect data for any devices using Edge drivers or the new architecture.

start using CLI or API browser:

1 Like

Ok thank you! I will give this ago for the simulated stuff that is not behaving. Thank you!

I have a lot to catch up on… everything was just working great before… and now… its all messed up… I see what I can figure out. Really appreciate all your help!

Just changing the word back to placeholder won’t fix the integration. You are probably going to have to delete the device and add it again and from then on don’t make any changes through the IDE, and don’t expect the information there to be accurate.

As @jkp said, you’ll have to get the information in other ways now.

See the following:

Life after the IDE: Questions and Answers

Got it all sorted and working… thank you all for your help!

1 Like

When my daughter’s phone updated the ST app this option got disabled, so it was as simple as toggling it back on again. Does the iOS app update usually turn stuff like that off?

I have never experienced it before.