Iphone presence not working unless Smart-Things app left open all the time

I had the pop-up issue too, but I uninstalled the app then reinstalled it. So far so good… keeping fingers crossed.

So I upgraded to the 15.3 beta and presence has been working for me BUT the constant sign in issue is not resolved which is impacting presence if I don’t confirm log in prior to leaving or arriving. Frustrating to say the least. :frowning_face:

How do you get the beta?

I’m not saying the following is a good option, but it is a possible option for people who don’t want to wait around for whatever this issue is to get fixed…

Meross makes surprisingly good quality inexpensive WiFi devices which can work simultaneously with both HomeKit and SmartThings. Available for both the US and UK.

When used with HomeKit, the integration is local. When used with smartthings, it’s cloud to cloud.

So you can get a Meross smart plug for under $20, have HomeKit geopresence turn it on and off, and use that as a presence proxy in smartthings.

As I said, I’m not saying this is a good solution, but it’s quick and easy to set up.

You do need to set it up with the Meross app to get the smartthings integration.

I use a few of these in my own house for locations where I wanted Wi-Fi devices and I’ve been very happy with them.

These are often sold in multi packs, and there is sometimes a checkbox coupon/voucher in the product description that will give you another 5 or 10% off.

Personally I only buy from listings where the seller is either Amazon.com or Meross Direct to make sure I get the right model.

They have a slightly cheaper model line which does not have HomeKit support, but for this trick to work you have to get one that works with HomeKit as well.

They also have a four socket power strip which you could use if you have multiple family members and you want to have each socket represent one. Again, just make sure you get the one that works with HomeKit as well as smartthings.

US:

UK:

If this is an iOS problem then how does Life360 continue to work without problems and accuratly report departure and arrival without the app running?

I don’t use Life360 to know, but I am suspicious that we are being too hopeful in thinking it’ an iOS 15 problem, and that Smartthings is just BS’ing us by blaming it on iOS. The latter wouldn’t surprise me because they’ve got no control over many other fundamental problems with the iOS app.

I will say that since switching to Hubitat their app appears to have the same issue from what I can tell. I have switched over to an option that uses HomeKit and is 100% reliable. I am grateful to have that fix. My point though is that it does appear that iOS 15 is at least partially responsible for the issue. That’s not to say ST and Hubitat don’t have their own issues contributing to the problem.

1 Like

https://beta.apple.com/sp/betaprogram

I have app developer status with Apple but I believe that this version is public now so I don’t think you have to be a developer to test/use it.

1 Like

I can confirm that everything works 100% if you switch from ST presense detection over to Life360. Should be a good fix for those having an issue.

My observation is that this is a ST issue, not iOS

Based on what I’m seeing on other forums, iOS 15 changed something and not all app creators updated their apps to handle that change. So it’s a combination, but at this point apparently ST has to be the one to fix it. :thinking:

Not everyone wants to use Life360 because of their practice of selling user location data to commercial brokers, bu5 obviously that’s a personal choice.

1 Like

For me i dont care if an advertiser knows my location. Advertisers know already so much. This is just one more data field. It is far more serious that with life360 my wife knows were i am.

For me, the advantages far outweigh a possible negative.

This is not to say that ST should not fix the issue, and the life360 should be a temporary fix.

2 Likes

I think I found the solution. At least it works again as of a few days ago after these settings.
Please see the attached pictures.

Basically, all you have to do is go into Settings->Focus->Do not Disturb and under ALLOWED NOTIFICATION (for apps) add the Smarthings app.

Repeat this also for the Sleep menu.

Settings->Focus->Sleep and under ALLOWED NOTIFICATION (for apps) add the Smarthings app.

iPhone 13 Pro Max ios 15.2.1

1 Like

Worth a try.

1 Like

It may be a coincidence: without trying this, I’ve noticed that location tracking seems to have improved over the last 72 hours. My wife’s phone has properly registered location presence by both SmartThings and Webcore 3 days in a row!

Didn’t work for me…but thanks for trying!

2 Likes

From the facebook group - user Jeff Gallagher suggested the following - in desparation, I gave it a try - and - IT WORKS.

Change your default browser to MS edge (something else like chrome might work too but we know edge does).

Uninstall the ST app.

REINSTALL the ST. app.

We believe the culprit keeping presence from working is that darn popup … you open it in the safari browser and agree - but have to do it again every day or so - and if you don’t - presence won’t work.

Going to MS edge as the default browser fixed this for several of us - I have both IOS 14.8 on my phone and wife has IOS 15.2.1. My problems started with the latest ST APP update. With that popup. Now, presence has worked solidly for last 4 days zero issues. FWIW.

1 Like

For the record my default browser has always been Chrome and I am not sure what pop up you are referring to but I was not getting it and presence hadn’t been working until I upgraded to iOS 15.3 public beta. Since the upgrade it has been flawless while on my other device on iOS 15.2.1 presence is still an issue. Here’s hoping the app upgrade today has indeed fixed the constant prompt to log in that has also been quite annoying and has been promise to have been fixed. We’ll see…

2 Likes

15.3 was just released. Does that fix 5he geolocation issues?

So far so good for me on 15.3.

1 Like