Integrating Sonoff Mini with ST. My findings

Without static IP address, it may be assigned with a different IP address on reboot/restart.

A static IP address ensures it always get the same IP address on reboot/restart.

Ok, I am for this. Will you offer how to do this? I didn’t get to where I am with getting tasmota flashed to these devices without help, and I am for getting this resolved so I don’t have to updated the IP address every time it resets.

Which router are you using?
Maybe you can try googling “how to assign static IP addresses on [ROUTER BRAND model] router”

I have a Samsung SmartThings Hub. Thanks, I will Google how to set a static IP address for Samsung SmartThings Hub soon, I must rest for now.

Thanks Hawks, I tried using the Tasmota (Connect). Installed the SmartApp, added to ST mobile, and set the date time format and polling interval and then attempted to add my mini. I selected sonoff basic because the sonoff mini wasn’t an option, and named my mini. Clicked next - got a blank screen within ST. Only options are to click save or < (back). I clicked save and hit an error.

! Error-bad state. Unable to complete page configuration. x

I didn’t get to the point where I could define the ip address of the mini. I tried different device types, but all had the same result.

hongtat - I see you are on this thread too- any idea why I wasn’t able to config my sonoff mini via Tasmota (Connect) SmartApp?

Thank you for your help!

Moddy, you can set your static IP addresses in your wireless device. The Cisco device makes it really really easy. All you need to do is login into your wireless router, click on the device on your network map, and select DHCP reservation. From that point on that device’s macaddr will always be associated to the same IP address.

@retluoc Have you added all the device handlers to “My Device Handlers”?

I made the following FAQ for Tasmota devices and would welcome any input

Thanks, I’m on it. Haven’t been home for a couple of days. If I’m able to do this though your instructions had terms I wouldn’t have expected to see when changing a static IP address. Will get to it when I get home. This will be valuable to not have to change the IP address in the device each time I lose power.

Hi hongtat,
What do you mean by all? I do have your Tasmota (Connect) smartapp loaded. I also still have Brett’s generic tasmota and the tasmota-power DH’s. Are there other DH’s I need to load & publish?


Yes, Tasmota (Connect) comes with its own DH that you’d have to load and publish.

Please find the instructions here -

1 Like

Thanks for the help on the static ip, it worked as you said it would. I’ve never logged into my router before and end up finding the menu needed. I haven’t tested it by disconnecting power but found the menu for reserving ip in a radio box menu, then selected the ip addresses for the devices I have in place.
Now this is interesting, when I accessed my router from my phone, there were 20 items with ip addresses and could see the sonoff devices. When I showed my wife on the pc, accessing the router, there were far less ip addresses and none of them sonoff devices.

The Tasmota (Connect) worked perfectly after I loaded the two device handlers - hongstat : tasmota generic switch & honstat : tasmota child switch device and redefined my Sonoff Mini’s within the ST app on my mobile device. I have been struggling to get my Sonoff mini’s to function properly in ST for months. Thank you!

Thanks again for your help too. Thumbs up to Tasmota (Connect)! Although, I never got Brett’s DH’s to work; I do think Tasmota (Connect) is cleaner. You don’t have to deal with two devices in ST. There is no child [device name switch] device in ST. The Mini’s were also discovered seamlessly to Alexa.

Off to my next project with - my attic fan.

1 Like

Are you sure you don’t have a filter applied? My Cisco router let’s you filter for LAN, wireless 2.4ghz, and wireless 5.0ghz connected devices. If you are looking for Sonoff devices, you need to look at the 2.4ghz connected devices. They only connect at 2.4ghz today. Good luck, Glenn

So far, whether I have looked at my router on my phone or the PC is hit-and-miss with 9 to 20 items connected showing their IP address. I don’t understand why I can’t see them all, there is no radio button or other settings suggesting any devices are being hidden.

Do you have separate tab for 2.4gz and 5gz? I go under 2.4 and there’s a tab for client list which shows all. Probably different for other routers maybe. I have a Arris surfboard.

Sorry just saw your other post above a couple.

Getting a chance to play around with it again, I selected 2.4 gigahertz on another menu before I selected DHCP table link from the original menu and saw all the needed IP addresses, thanks.
Wasn’t treating it as a two-step process. I went straight to the monitor icon and selected DHCP table seeing an inconsistent total devices.

A question…Do you think there is a market to sell Sonoff Minis flashed with Tasmota? Thinking I could sell for same price as Amazon…$11.00. I made a fixture where I can flash them easily.

Personally I don’t think it’s worth the effort, though you would probably sell some.
In this realm of chips, servers and iot. It moves very fast and changes happen all the time that people who make YouTube videos of a DIY something-or-other, end up making a new video because there are easier methods.
I flashed 10 of the ones I used and if you were to make it work you’d need it set up for you to be able to do something else rather than just sit there and burn time.

I haven’t seen much on this lately and was having some trouble figuring out how to get into the Mini R2 DIY mode without the jumper. I tried using the c to c solution and it worked pretty well until my Ewelink connection had to be reset, so I figured I would give Tasmota a try. This is what I came up with to flash my 4 mini R2s with Tasmota and get them connected to Smartthings.

  1. Power on - hold 5-6 sec twice until steady flashing blue LED
  2. Connect pc to wifi network now transmitting from device ITEAD-XXXX, p/w 12345678
  3. Enter IP in browser and connect to Sonoff DIY page
  4. Start sonoffDiy hotspot on phone with p/w 20170618sn
  5. On Sonoff DIY page, enter sonoffDiy pw 20170618sn, click OK and wait for Wifi Configuration is complete notification
  6. Check device is connected to phone sonoffDiy hotspot
  7. Connect pc to sonoffDiy hotspot
  8. Open Sonoff DIY flashing tool–device should be visible in window (get tool_01DIY85(3.3.0).exe from GitHub - itead/Sonoff_Devices_DIY_Tools )
  9. Select tasmota-lite (get from Releases · arendst/Tasmota · GitHub )
  10. Select device–not easy…play around until it will flash, usually have to cancel and tray it a second time
  11. After device restarts, tasmota-XXXXXX-XXXX wifi should be available
  12. Connect to it on pc and Tasmota page should open
  13. Enter home wifi credentials very carefully and enter
  14. Connect pc to home wifi
  15. Device will connect to home wifi–check on router for IP address and note MAC and IP with sticker on device
  16. Set static IP address for this device on router
  17. Enter this IP and Tasmota page will open
  18. Go to configuration>configuration other and paste template from Sonoff Mini Switch Template for Tasmota and select activate.
  19. Download Tasmota Connect Smartapp and device handler using instructions from [RELEASE] Tasmota (Connect) for Sonoff, Tuya, SmartLife & other ESP8266 devices) and GitHub - hongtat/tasmota-connect: Add your Tasmota devices as SmartThings devices
  20. Open Tasmota Connect smartapp>new device>select which type of device>name it> click done>set IP address
  21. Now your Sonoff Mini is a Smartthings connected device!
1 Like