Inovelli dimmer NZW31, connected but doesnt switch the light

I am trying the Inovelli NZW31, no luck so far.

I have installed the dimmer NZW31 in a single switch configuration to control 9 ceiling can LED lights.
I did pair it with the smartthings hub, however it doesnt turn on the light neither manually nor thru the app.
Blue LED light occasionally turns on/off, not sure if it is normal.

I did refresh the z-wave mesh, try excluding and pairing it back, removed the airgap - same thing.

Also, originally installing I switched hot/line, hope it did not toast the switch.

Any thoughts?

If by manually you mean pressing the switch on the wall, then if that doesn’t work the wiring is incorrect. So you need to get that working first.



Thanks. But since it was able to pair, I assume at least line and neutral are connected correctly, so only the load could be off. I’ll double check, but I pretty sure the load was connected to the correct terminal. If ltsnot that, does it mean the unit is faulty? Or something with LED bulbs?

Hey @muse,

Happy to try to help here as well. When the switch is off, does the blue LED turn on (vice versa for when the switch is on… is the LED off)? If it flickers, then try tightening down your line or neutral wire to see if that helps.

Another thing to check (I see you responded as I’m typing this out, so I apologize if you’ve already tried this) is to make sure your can lights are dimmable (since you’re using the NZW31). On that note, what name-brand are the lights?

What it sounds like is either:

  • Lights are non-dimmable
  • Wiring isn’t tightened down
  • LED’s are not compatible (it’s very tricky with can lights for some reason)
  • Switch is defective

Once you’ve confirmed they’re dimmable lights and that the wires are tightened down, let me know if you still experience the issue and I can send you a switch that we’ve personally tested. If it still doesn’t work, then the LED’s are likely incompatible.

Either way, we’ll figure this out!

Founder | Inovelli

1 Like

I have this so far:

  • can lights are dimmable LED, I even have tried putting one regular led, no effect.
  • Status light turns blue whenever I switch it OFF from the app. When I switch on light goes away. When I manually hand switch it up or down, it has no effect on the blue LED light.

I still have to check the wiring.

1 Like

Ok, very helpful, thank you @muse.

When you turn it on/off from the app, does it physically turn off the light?

Reason I’m asking is what may have happened is the internal relay was disabled by accident.

If the physical light works via the app, but not via physically touching it, the relay is likely disabled. To re-enable it, tap the switch UP 8x and see if that fixes it.

Hang in there, we’ll figure it out!



Sorry guys, I’ve figure this out, it was the wrong circuit! Now it is working, that was stupid on my part )
Now I have to figure, though, how to work with ramp rate to fade in more slowly. Thanks!

1 Like

I have a somewhat similar sounding issue with a GE ZigBee smart switch here, so I have to ask, would you mind expanding on what your issue turned out to be?

Thank you!

Fantastic! Great to hear you got it working.

To change the ramp rate, you can install our device handler for it located here:

Once it’s installed, when you click on the device located in the ST Classic App, you’ll see the inovelli logo (this means it was installed correctly). After you’ve clicked on the device and you’re in the menu, click on the gear icon at the top right, which will take you to the settings.

There’s a section called, “Dimming Step Size”. Enter a number between 0 (Instant On) and 99 (Very Slow) to change the rate.

Hope this helps!


Ok, after a week it stopped working thru smartthings app. When you turn it on or off thru the app it shows, that it did turn off or on in tha app, nut nothing happens. How to trouble shoot this? Thanks.

Hey @muse – sorry to hear this. This sounds like a distance issue (where you are pressing on/off in the app, but the signal doesn’t quite make it to the switch from the HUB).

Question for you:

  • How many Z-Wave devices do you have in your network (non-battery)?
  • Does the signal from your switch have to go through any walls, furniture, etc to get to the HUB?

I’m betting it’s a signal issue and we can definitely help you with that – I just want to make sure I’m understanding correctly before going down that path.

Hang in there, we’ll get you up and running!


Thanks, Eric.
The hub and the switch are within one room, 15 feet apart. But its around the corner, so directly signal would have to go thru two or tree drywalls. There are no other Z-Wave devices there yet. I could add something non-battery, if needed, I wounder why it did work for couple of days, and than stopped. It did not have problems paring in the begining. Do I need exclude and add it again? Or just add more devices to improve mesh.

I have installed invoelli switches, they work fine manually and via the app. however in the process of pairing, i must have hit the up or down button too many times, resulted in changing the built in blue light status. initially the blue light would stay on when the room light was off and blue light would go off when the room light is on; but in the pairing process its has been reversed. is there any way to change the blue light status to its original stage?