Ikea Symfonisk Remote - Pairing

Hi,

I’ve just bought an Ikea Symfonisk Remote to use (hopefully) with my existing Sonos set-up (no symfonisk speakers). I’ve tried to pair the remote with my Smartthings Hub v2 but so far have failed. Can anyone help?

1 Like

Have you tried installing with the new ST app and not the ST Classic app?

Smartthings doesn’t have a device handler for remote, you can use my “early stage” handler, https://github.com/lap33733/Smartthings/tree/master/devicetypes/smartthings/ikea-symfonisk-button.src

1 Like

Garcias Amigo!

Not that techy :frowning:

How do I install?

Kenny

Enter smartthings developer site, create a new device type from code and paste my code inside. Then you will have to program what each button will do. If you never did something like it than it might be a little complicated.

1 Like

Hi. I’m using your code, and ST find the device. But nothing happenens when i push the button. Can you tell me how to fix this?

@Luis_Pinto, I also attempted to use your device handler, but no events are triggered when the button is manipulated. I have two Symfonisk buttons and neither caused any state change when pressed or turned. They also aren’t reporting their battery level. From what I can see, it doesn’t look like they are communicating at all.

Thanks for taking the time to work on this!

I didn’t found yet how to read battery. Button clicks might not be visible because they are momentary, nevertheless you should see level rise once button is turned. Did you use any smartapp for actions? Can you check with live log to see if there is any error rising up?

If my previous post doesn’t help try to remove and pair it once again.

It does not help to pair it again. Got the same issues as mention over here

Did you check live logging on graph site?

This is everything it logs after pairing

I have the same problem as @Karl_Martin_Brevik . I have tried removing the device and re-pairing it. Nothing shows up in the live log when pushing the button.

Another DH has been posted here today.

Otherwise, what version of Hub are you using? The log indicates that the binding has failed, due to a null value in the command.

I just tried it but it doesn’t work for me either. The Hub I have is the ‘SmartThings Hub (2018)’, which is I suppose v3.

Here is the log from the device:

The log shows no actions from the button. I have also tried using it in automation rules.

Have you deleted the button before? That looks like in the log a battery reporting of 45%. And it looks like just after the pairing process.
I haven’t tried none of the DH, just guessing according my best knowledge.

It should be working with the v3 hub.

Yes, I have deleted the button and re-paired it.

The log is right after the pairing and trying button presses.

I bought the button today, so it should have more than 45% left.

This is the log right after pairing with @Luis_Pinto DTH.

I will check it once I near my PC.

Have you had a chance to look into this?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.