IFTTT and SmartThings (UK accounts)

So Harmony has also finally made changes and connection with v2 UK hub has been made!

1 Like

This is shocking. Have Samsung actually acknowledged the oath issue and gave any updates or timescales as to when it will be fixed?

I think it’s going to get returned if there’s no fix/announcement soon.

Most Oauth connections now fixed, IFTTT, Harmony are both done. Proactive communication and ownership of the problem is still an issue (Even though the problem in itself seems to be fixed for most)

2 Likes

Harmony Hub still don’t work for UK servers.

Joao, Which part doesn’t work for you? Maybe we can help.

I’ve had mine setup for just over two weeks without issue.

@ognaf

I’m losing my mind that this… :stuck_out_tongue: , with all the things i have try to make this to work.

The last thing i’m going its in this topic,

I have manage to create the app, but now the problem is to “Authorize”.

What was the steps you make to work?

The only time i have manage to work, was create a location in the USA, i did manage to make the connections for the Harmony, but the only thing it does, is to turn on // off activities, because in that location i din´t have hub/devices.

Hi @Joao_Cautela

It looks like you are still trying to use workarounds where they should/are not needed. Have a look here:

Some points of note:
You should not need to alter any URL
Nor copying the OAuth ID on the IDE. This is all just done from within each of the apps (Logitech & ST)
What might be disturbing things is having a US graph.api account setup when you login. As I remember, cannot verify right now, but the Harmony app is still pointing to graph.api but it still finds the EU account somehow and allows you to select the hub and then the devices without any trickery

@thedezza

That link works for the USA server.

The point 2 (Under Things, tap Entertainment) don’t exists on the UK server, there isn’t possible to add the hub in the UK.

I don’t have US location ( already had, but already delete )

Interestingly this is progressing in the background for the UK they just aren’t communicating. I noticed today that I was able to connect my Harmony Home Hub to my UK SmartThings Hub and control the lights from the remote. That wasn’t working last time I tried before Christmas, so I suggest you have a go in the Harmony app. I connected the remote to my computer and add SmartThings, after oAuth authentication the devices were available.

The other way is still working for me i.e. smartthings to harmony but I was lucky enough to have the smartapp installed before they removed it from the uk marketplace.

Surely this can’t be far off because every aspect seems to work from my point of view on a UK hub.

The problem is not adding the SmartThings to the Harmony Hub, that is working, like you i can control my hue ligths (yeahhh)

What is not working (now) is adding Harmony Hub to SmartThings, to control the activities, like you say,

I’m trying workarounds, but still not luck.

I know i’m just one person, but really like to know why its so hard, to put something that is working on the USA and “copy” to the UK server.

This is all working fine for me.

Have you gone into the Logitech Harmony (Connect) SmartApp (which should have installed automatically), searched for and selected your Harmony and then selected the activities you want to hav visible to SmartThings?

This is working, so if it isn’t working for you it may be worth uninstalling the Connect SmartApp and reconnecting everything via the Logitech software.

It’s been a frustrating wait but these integrations are now coming online.

Automatically is not possible (in the UK server) at least now, because is not available.

What is now possible is to add the Logitech Harmony (Connect), manually ( graph-eu01-euwest1.api.smartthings.com > My SmartApps )

But when selecting Harmony Credentials, there is a error >

{“error”:invalid_client",“error_descripiton”:“Client authentication failed.”}

Probably this is something to do with the changes they made in OAuth? Don’t know.

It’s working for the people that already had this installed for newcomers is “not possible” now.

Yes it’s a little bit frustration, but the harmony hub working with IFTTT (leave/arrive area to turn off/on) the only thing i really can do is trying the workarounds, and hope for some day, they put this working again in the UK server (for newcomers)

Does for me, very happily. Button on my ultimate controls the ST outlet that turns the whole hifi stack on.

Again, it did for me, from the Harmony mobile app - prompted me for ST login, paired them up. No problem, less than two weeks ago.

But i’m not saying that didn’t work… :slight_smile:

Using the Harmony app , add a device ST, connecting to the ST, selection the location, that is OK

What is not working // available

Using the ST app to paired the Harmony Hub > UK server going to Marktplace > Things > Can’t be found, Logitech (at least NOW ) because some mouths ago, it was there, but they remove it.

Basically there are two apps, one is working and another is not.

I see the Oauth issues were officially resolved last week but there still seems to be an issue connecting to ifttt for uk users, even when changing the URL to graph-eu01-euwest1.

Guys has the IFTTT issue been resolved for Smarthing UK users. I got myself a couple of FLIC buttons to play with - and the easiest way to control smartthings with these is through IFTTT - which I cant get to work. Theres another way by adding a smartapp but its way complicated. I gave up after reading the tutorial so many times my eyes started watering…

Yes, this is now resolved. I don’t know what FLIC is but IFTTT should be working fine.

What problem are you experiencing?

Hi Giles
Yes you’re right its been resolved. I was being directed to the US API url and I thought it wouldnt work.
A FLIC is a physical button where you can assign tasks to it. The tricky thing is that this button connects via bluetooth to your phone [rather than ZWAVE for instance] so the easiest way to control it is via IFTTT.
Theres been some discussions here to skip IFTTT (by creating a smartapp and connecting to devices directly from the FLIC) - but its wayyy to complicated for me to follow. So I’ll stick to IFTTT for now. At the moment Im trying to create a virtual device/switch so it can trigger a routine.
Thank you for replying promptly.
Chris

Im looking for an update on this issue please? Im simply trying to connect to the smartthings channel from the ifttt website as a UK user, but unable to login on the page Im directed to - https://graph.api.smartthings.com/login/auth