IFTTT and SmartThings (UK accounts)

I think just anything can’t remember exactly what I changed

1 Like

@625alex @tgauchat Many, many thanks for this. Thanks for all the hard work.

2 Likes

Have to say a massive thanks to @joshua_lyon and @tgauchat for updating their apps so quickly.

As Josh says though, it’s worth pointing out that these fixes use a way which SmartThings are planning to make obsolute by the end of the year, so as great as it is that we have a fix… it is only temporary.

SmartThings need to discuss a longer term fix with community developers. Any thoughts @Aaron?

4 Likes

I’m having this exact same issue. Could you be more precise on what you did to fix it?

{“error”:true,“type”:“java.lang.ClassCastException”,“message”:“An unexpected error occurred.”}

I understand those with UK accounts can now add the SmartThings channel to their IFTTT account. Can you actually create recipes that control SmartThings devices yet?

I have some online friends waiting on this. The simplest, if not the most elegant, way to add voice control to SmartThings is simply to send a voice text to IFTTT and have that trigger a SmartThings action. ( this is a method first identified by @Will_Poirier).

Generally it costs nothing as long as there is no cost to send a text, and it requires no additional devices. And a single text can be used to trigger multiple IFTTT recipes. So it is especially helpful for people with limited hand control as essentially anything that can be done in SmartThings can then be done by voice.

However, it does require IFTTT recipes that work. So are we there yet?
Thank you.

(The voice text message is rather clunky. “Hey, Siri, tell house hashtag kitchen underscore lights on”. No natural language. However, it’s a great deal better than not having it if nothing else is available. :sunglasses:

For those interested in more about voice command solutions with SmartThings, see the following topic. However, I believe all except the SmartWatch widgets will require that OAuth is working.

Voice Command Solution - Discussion )

1 Like

Definitely tag @HughB for more details on his fix, but also jump over to the main SmartTiles Topic to seek further help…

1 Like

As far as I’m aware IFTTTT hasn’t been updated yet with the fix - or at least it hasn’t for me.

1 Like
2 Likes

Can add channel to IFTTT but when try to use receipe there is no device to select
eg *** problem accessing your motion sensors! ****

2 Likes

Any Harmony update please? The lack of mention makes me believe there is a lack of co-operation (mentioned on IFTTT) and it will be 2016 before fixed

Also being worked on

3 Likes

Pretty sure I went into device order. That collected the device list and i guess updated it. clicked done and away we went.

1 Like

I have just posted a query as to when we can expect harmony to make the required changes in the harmony home control forum as there was no mention of the problem that I could see in there.

Maybe badgering from both ends might speed things up

Bob

1 Like

I was so hopeful the issues were fixed. Just logged in and managed to connect SmartThings to IFTT; even showed up my location and then all my devices which I gave permission to. Tried linking a Recipe to my locks and just comes up saying '*** Problem Accessing Your Locks!*** :frowning:

Update:

Super close guys and gals.

Going through final rounds of testing right now. :smile:

2 Likes

This this for a global 3rd party solution? Or are we just talking IFTTT here?

IFTTTT


1 Like

Same issue. I can see all my Things when I grant the access on IFTTT, but they are not available when I want to build a rule.

I will try to find it, it can do no harm…